MozillaZine

add security exception

User Help for Mozilla Thunderbird
thetexasav8r
 
Posts: 1
Joined: October 14th, 2010, 6:12 pm

Post Posted October 14th, 2010, 6:24 pm

Two days ago I started getting an error screen:
ADD SECURITY EXCEPTION
You are about to override how Thunderbird identifies this site
legitimate banks, stores and other public sites will not ask you to do this
SERVER: Location: pop3.comcast.net:110 GET CERTIFICATE
Certificate Status
This site attempts to identify itself with invalid information
WRONG SITE
Certificate belongs to a different site, which could indicate an identity theft
There is a VIEW button, which contains a LOT of information.

What is this? It pops up continually during e-mail sessions. Sometimes I have to click off 10 or more of these in a row to view my e-mail.

tanstaafl
Moderator

User avatar
 
Posts: 38879
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted October 15th, 2010, 2:08 am

http://kb.mozillazine.org/SSL_Security_Error

If you make a secure connection (use SSL) and the SSL certificate the mail server returns specifies the wrong domain it warns you that something is wrong. You can either cancel, or create a security exception, which is a way of saying you understand the risks and don't want to be bothered again. They could have made it more user friendly but it works the same way as Firefox.

You should not be getting a SSL certificate connecting to a POP mail server on port 110. That port is meant to be used only for non0secure connections. Normally you'd use port 995.

Guest
Guest
 

Post Posted October 15th, 2010, 9:41 pm

I had a similar problem with only the outgoing e-mail.

For Incoming e-mail:
Select Tools->Account Settings
On the left side select the correct Server Settings.
Port 110 is a non-secure Port, so set the Connection Security to "None" and set the Authentication method to "Password, transmitted insecurely"

For Outgoing e-mail, you need to set the Outgoing Server (SMTP) Settings as follows:
Select Tools->Account Settings
On the Left side select Outgoing Server (SMTP)
Select the problem SMTP and set:
Port: 25
Authentication method: "Password, transmitted insecurely"
Connection Security: "None"

I used to have the Connection Security set to "STARTTLS, if available", but this option is no longer available with the latest Thunderbird (3.1.4).

I hope this helps.

JBSch
 
Posts: 7
Joined: April 8th, 2009, 12:41 pm

Post Posted October 25th, 2010, 7:43 am

A few days ago, I started having apparently this same dialog pop up occasionally. I hadn't changed any settings or been doing anything different, and Thunderbird had worked fine for me for years until now.

Server location: pop.att.yahoo.com:995
"site attempts to identify itself with invalid information"

WinXP
TB 3.1.5

tanstaafl
Moderator

User avatar
 
Posts: 38879
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted October 25th, 2010, 10:14 am

Login to yahoo webmail using Firefox and SSL (https) and see if it also complains.

Zombiemommy
Guest
 

Post Posted May 20th, 2011, 6:20 pm

Great, yes I am having this problem. And yes Firefox is having issues too with the webmail. I got an error message.

So what's next?:)
:D What do I do next?

rhkern2
Guest
 

Post Posted October 18th, 2011, 2:13 pm

I just started receiving the same message today - after many years of using Firefox (now V3.6.23) and Thunderbird (V3.1.15 ) the location highlighted is pop.gmail.com:993. Do I want to click on "get certificate"? or "confirm security exception"? I have a yahoo pop3 account on this same system and it is not having this problem. Neither is another laptop I travel with that pulls pop 3 from two gmail accounts and one Yahoo account and an android 2.2.3 phone that pulls from all three also without problems. I might add that the unit I am writing about just underwent a 65 MB update(Microsoft) to Vista HP SP2 64 bit this morning while the laptop - running the same OS configuration underwent the same update two days ago. Do you have any suggestion?

qwertinsky
Guest
 

Post Posted November 6th, 2011, 11:31 am

I am having the same problem and it's to pop3.comcast.net:995 "wrong site"

I under stand by clicking the "confirm security exception" this should make this not happen anymore.

BUT IT DOES NOT! Every single time I check my Comcast mail I get this pop up! :x

DanRaisch
Moderator

User avatar
 
Posts: 106620
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted November 6th, 2011, 11:36 am

Try menu path Tools->Account Settings->Server Settings->change the server name to "mail.comcast.net" (without the quotation marks) and change the port number to 110.
Vista Home Premium 64 - FX 37.0.1 & TB 31.6.0 Win 8.1 - FX 37.0.1 and TB 31.6.0

qwertinsky
Guest
 

Post Posted November 6th, 2011, 12:24 pm

DanRaisch wrote:Try menu path Tools->Account Settings->Server Settings->change the server name to "mail.comcast.net" (without the quotation marks) and change the port number to 110.


Actually the mail server is "mail.comcast.net" in the server settings. I don't know why the add security exception pop-up says "pop3.comcast.net"

Changing the port to 110 "works" I guess but I have to turn off all connection security to connect on port 110. #-o

So it does not really fix the problem, it's more of a "It hurts when I do this, so don't do that." solution

Interestingly enough as the original poster stated my previous configuration work fine for years. Only in the past week or two has this issue came up.

I am guessing Comcast changed something, but since I am not using Outlook Express Comcast will not offer any support.

DanRaisch
Moderator

User avatar
 
Posts: 106620
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted November 6th, 2011, 1:48 pm

Connection security is not a user choice. If the server is not set to support it, selecting settings that call for in the email client will result in problems such as you have seen.
Vista Home Premium 64 - FX 37.0.1 & TB 31.6.0 Win 8.1 - FX 37.0.1 and TB 31.6.0

Guest
Guest
 

Post Posted November 6th, 2011, 4:55 pm

DanRaisch wrote:Connection security is not a user choice. If the server is not set to support it, selecting settings that call for in the email client will result in problems such as you have seen.


That's all well and fine and as I said is is probably a Comcast change that caused it, because the problem just cropped up recently and I have changed nothing as Thunderbird has been running fine for years with the exact same configuration.

BUT, the fact that the Add Security Exception pops up every time it attempts to retrieve mail even after checking the "Remember this exception" or whatever it says box is a Thunderbird problem.

to add more it does not even happen every time, but if I leave Thunderbird running and come back later there will be multiple "add security exception" pop-ups waiting for me.

gumof
Guest
 

Post Posted September 11th, 2012, 3:13 am

DanRaisch wrote:Connection security is not a user choice. If the server is not set to support it, selecting settings that call for in the email client will result in problems such as you have seen.


how about using UTM in the middle of connection -choosing to be safe, then can't use it bcos TB specyfic rules baout certyficate and can't add exception ?,
at lest in XXI we should have a choice, to trust own CA / security solutions

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 10 guests