MozillaZine

connection timeout smtp.gmail.com port 587

User Help for Mozilla Thunderbird
AlbConst
Guest
 

Post Posted October 31st, 2010, 7:01 pm

For a few weeks, I've had trouble with sending outgoing mail via Thunderbird. I was previously using the default settings for gmail IMAP and SMTP (port 993 for IMAP and port 465 for SMTP SSL). All of a sudden, I started having trouble sending email and kept getting connection errors. From some testing using telnet, it seems that my ISP is blocking port 465 and 25... is port 587 the only remaining option? When I try port 587 with STARTTLS and smtp.gmail.com and send an email it says "connected..." and after 20 seconds it says "connection timed out...".

I'm using Thunderbird 3.1.5 on Windows 7.

The current settings I have for Tools>>Account Settings>>Left Pane: Outgoing Server (SMTP) are:
Server: smtp.gmail.com
Port: 587
Connection Security: STARTTLS (choices are: none, STARTTLS, or SSL/TLS)
Authentication Method: Normal Password (choices are No Authentication, Normal Password, Encrypted Password, Kerberos/GSSAPI, or NTLM)
User Name: UserName@gmail.com

I've tried various combinations of authentication/ports but maybe I'm entering these wrong or overlooking something. (Incoming mail has been fine this whole time)

Look forward to any suggestions!

tanstaafl
Moderator

User avatar
 
Posts: 39272
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted October 31st, 2010, 11:16 pm

http://kb.mozillazine.org/Using_Gmail_w ... illa_Suite (hasn't been updated for 3.* yet)

Port 587 is the correct port to use. If you're using Thunderbird 3.0 or later the connection security you want to use for the SMTP server is STARTTLS. The authentication method is "normal password". ISPs typically don't block port 587, its actually the workaround for when a ISP blocks port 25.

Typically if the Gmail connection settings are wrong the connection is refused, it doesn't time out unless you're using the wrong server name. You're using the correct mail server.

It might be as simple as your ISP is having temporary problems making network connections to the mail server. Try pinging it and see if you lose any packets.

Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Users\eric>ping smtp.gmail.com

Pinging gmail-smtp-msa.l.google.com [72.14.213.109] with 32 bytes of data:
Reply from 72.14.213.109: bytes=32 time=60ms TTL=55
Reply from 72.14.213.109: bytes=32 time=61ms TTL=55
Reply from 72.14.213.109: bytes=32 time=59ms TTL=55
Reply from 72.14.213.109: bytes=32 time=60ms TTL=55

Ping statistics for 72.14.213.109:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 59ms, Maximum = 61ms, Average = 60ms

AlbConst
Guest
 

Post Posted November 1st, 2010, 1:47 pm

Pinging gmail-smtp-msa.l.google.com [74.125.113.109] with 32 bytes of data:
Reply from 74.125.113.109: bytes=32 time=17ms TTL=52
Reply from 74.125.113.109: bytes=32 time=19ms TTL=52
Reply from 74.125.113.109: bytes=32 time=18ms TTL=52
Reply from 74.125.113.109: bytes=32 time=22ms TTL=52

Ping statistics for 74.125.113.109:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 17ms, Maximum = 22ms, Average = 19ms

So I'm able to ping smtp.gmail.com without a problem. I tried telnetting to smtp.gmail.com on port 25, 465, and 587. It only lets me through on port 587. My settings are listed above and seem to match what you've suggested (STARTTLS, Normal Password). Nevertheless, I've had this connection timeout issue for the past few weeks every single time I try it.

Any suggestions on possible causes for this issue? Even better, any suggestions on possible solutions?

Thanks again!

tanstaafl
Moderator

User avatar
 
Posts: 39272
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted November 1st, 2010, 6:03 pm

http://kb.mozillazine.org/Modify_Thunderbird_settings explains how to modify the timeout, but it doesn't do any good to increase it past whatever the tcp-ip timeout is set to.

Gmail has a history of claiming your login failed when they're overloaded, and prompting you for a new password (even though you gave the right one) for POP and IMAP accounts. I don't know if you're running into something similar for SMTP.

If you have some non-Gmail accounts its possible to use its SMTP server with your Gmail account. http://kb.mozillazine.org/Multiple_SMTP ... hunderbird

AlbConst
Guest
 

Post Posted November 4th, 2010, 6:14 pm

This seems to happen every time, not intermittently, so I'm guessing it is not related to overload of on Google's end.

Are there any free email accounts that provide an SMTP server on alternate ports (other than 25, 465, or 587)?

Any other suggestions?

I think the problem is the port is blocked by my ISP in some form or another and I'm trying to figure out how I can continue to send outgoing emails through thunderbird in this situation.

tanstaafl
Moderator

User avatar
 
Posts: 39272
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted November 4th, 2010, 8:56 pm

I've never heard of a ISP blocking port 587. One way to verify that would be to see if you can use telnet to send a message. Its not user friendly, but a good troubleshooting tool. Windows comes with a version of telnet, though you have to jump through some hoops to make it available under Vista/Windows 7. Or you could use something like PuTTy.

You'd just type telnet smtp.gmail.com 587 and see if you get a response. In my case it clears the screen and then shows 220 mx.google.com ESMTP e14sm953852wfg.20 . I could then start typing actual SMTP commands to send a message but there is little point as its proved my ISP doesn't block that port.

http://www.yuki-onna.co.uk/email/smtp.html
http://www.windowsitpro.com/article/tel ... ista-.aspx

AlbConst
Guest
 

Post Posted November 5th, 2010, 2:52 pm

Thanks for the response... I'm able to telnet to 587 as you've described below (and have been able to for weeks since the problem started). The problem is, I still am unable to connect using the settings I've described above for port 587. Prior to the problems, I was using port 465 for SMTP without a problem. This just stopped working all of a sudden one day so I tried telneting to troubleshoot the problem and it seems port 465 was blocked but 587 remained open. I figured I'd just try using 587 but it hasn't worked out for me so I'm stuck. Maybe I'm entering settings wrong or something, but I've been stuck for almost a month now!

Thanks for trying to help... I really do appreciate it and hope I can have SMTP working again soon!

tanstaafl
Moderator

User avatar
 
Posts: 39272
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted November 5th, 2010, 3:58 pm

I suggest you sign up for a free GMX.com account and experiment using its SMTP server. You can use it to verify your ISP doesn't block a certain port, and you could always configure your Gmail account to use the GMX.com SMTP server as a workaround.

AlbConst
Guest
 

Post Posted November 6th, 2010, 3:17 pm

Thanks for the suggestion. I tried GMX.com for SMTP today using their server, mail.gmx.com on port 587. Again, I'm connected but then it eventually just times out again without sending the email.

My one question is, there was no place where I entered my new password for my GMX.com SMTP account and it never popped up asking for it. All I have entered is my username (one the same screen where I select port 587 and STARTLS for the outgoing mail server). I tried deleting all my passwords which makes it pop up and ask for my Gmail password to download IMAP emails from my inbox but still doesn't ask anything about a password when I'm sending emails.

Shouldn't there be somewhere that I should be entering my GMX.com account password before it lets me connect?

Hoping maybe there is just a simple setting that I'm overlooking.

Thanks again!

tanstaafl
Moderator

User avatar
 
Posts: 39272
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted November 6th, 2010, 5:05 pm

You need to select "authentication method" is "normal password" in the SMTP entry. This is equivalent to entering the username and checking a checkbox about the password in earlier versions. The connection security (in the SMTP entry) should be "starttls if available"

AlbConst
Guest
 

Post Posted November 7th, 2010, 1:24 am

Thanks for the reply... my question is more along the lines of: where do I type in the password for the SMTP server? Or does it just use the password that I have for IMAP server? In that case, my GMX password and GMail password have to be the same? I've tried it with these passwords the same but still the same problem... Anyway, just making sure I have all my settings correct.

Thanks!

AlbConst
Guest
 

Post Posted November 7th, 2010, 10:28 am

After all the reseting of passwords and stuff, I had the chance to try my computer again through a different internet connection (tethered to my phone) and it connected just fine and sent the email through port 587 with the STARTTLS and Normal Password settings for the smtp.gmail.com server.

The interesting thing is that when I use my home connection (which is the problem), and send an email, it says "connected" and then sits there and times out. If I use the mobile phone connection through tethering, and send an email, it says connected, then pops up a box to ask for my SMTP password, and then sends the email successfully. So the problem is somewhere in that step before the password window pops up but after it makes a connection to the SMTP server. (If i use one of the blocked ports such as 465 or 25, it doesn't even say connected).

Spoke to the ISP providing my home connection a few times now and they've been completely unhelpful so I'm sort of stuck here. Hopefully there is something else I could do to fix the problem since I don't have much choice in ISP where I live right now...

fredpp
Guest
 

Post Posted November 18th, 2010, 10:36 am

I travel a fair bit, and have run into this problem in the past when using the email client on my laptop in different WiFi zones. To solve the port blocking problem, I use the Loa Powertools application as described at http://www.loapowertools.com/gmail.html With this app, I don't have to change any settings when I move from environment to environment. It also allows me to send emails from any of my email accounts (I wear many hats) and have the correct "From" field in the message. Oh, and I confess that I do wear a LoaPowerTools hat from time to time.

LIMPET235
Moderator

User avatar
 
Posts: 34647
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted December 10th, 2010, 12:26 am

Locking due to persistent spamming.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-30.0-36.0.1-38/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.5.0.
RadioYachting. Conficker Test.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 21 guests