MozillaZine

editing a draft changed the from account

User Help for Mozilla Thunderbird
stduc
 
Posts: 16
Joined: November 8th, 2010, 2:14 pm

Post Posted November 8th, 2010, 2:18 pm

When I edit a draft message the account in the from field always changes to the last account I have. Is this normal behaviour or can I set something somewhere to make to keep the account used when the email was saved to that drafts folder in the first place.

tanstaafl
Moderator

User avatar
 
Posts: 43358
Joined: July 30th, 2003, 5:06 pm

Post Posted November 9th, 2010, 5:20 am

Perhaps you selected a different account just before editing the draft message. I don't run into your problem but I have each accounts email address defined as a multiple identity in all of the other accounts, the same compose message preferences in each account, and one common drafts folder, so that it really doesn't matter what account I'm in.

http://kb.mozillazine.org/Multiple_iden ... il_account

stduc
 
Posts: 16
Joined: November 8th, 2010, 2:14 pm

Post Posted November 9th, 2010, 6:40 am

tanstaafl wrote:Perhaps you selected a different account just before editing the draft message


No, I was editing from that accounts drafts folder.

tanstaafl wrote:I don't run into your problem but I have each accounts email address defined as a multiple identity in all of the other accounts, the same compose message preferences in each account, and one common drafts folder, so that it really doesn't matter what account I'm in.


I don't really follow you. I have several accounts, i.e one for work etc. They are a mix of gmail and pop accounts. However there may have been some issue with gmail yesterday, or my PC as it's behaving itself today!

It is my usual practise to write an email and then unless it's a really simple email I will often save it to drafts and revisit it a while later. I find I avoid making stupid mistakes that way. I used to use Eudora and like the way you could set an email to be delayed by an hour or so. Thus avoiding those 'whoops' moments!

tanstaafl
Moderator

User avatar
 
Posts: 43358
Joined: July 30th, 2003, 5:06 pm

Post Posted November 9th, 2010, 3:49 pm

You might like the BlunderDelay add-on. It seems to emulate what you're used to in Eudora.

stduc
 
Posts: 16
Joined: November 8th, 2010, 2:14 pm

Post Posted November 16th, 2010, 2:46 am

SL8TR is a better replacement for what Eudora does but doesn't work after Thunderbird v2.

I have cracked my original issue. "When I edit a draft message the account in the from field always changes to the last account I have." - It happens when I change machines. I don't know why I didn't twig this before. So if I save something to drafts on my desktop and later edit that on my desktop, all is well. But if later I pick it up on my laptop it defaults to sending it from the last account in the list! Grrrrrrr

tanstaafl
Moderator

User avatar
 
Posts: 43358
Joined: July 30th, 2003, 5:06 pm

Post Posted November 16th, 2010, 4:02 am

Doesn't work or won't install/enable? If the latter try installing the "add-on compatibility reporter" add-on. One side effect is it enables all extensions. http://kb.mozillazine.org/Updating_extensions mentions several other workarounds

corz
 
Posts: 23
Joined: February 7th, 2005, 1:27 am
Location: Scotland

Post Posted September 16th, 2013, 10:07 am

This is a real issue for me, still. 2013, Thunderbird 17.

I have all my accounts funneled into one inbox/outbox/etc. When I save & close a message, the from: address is fine. When I open it later to finish and send it, it's from: my main account. More than once this has caused embarrassment!

I have used the Correct Identity plugin, but it is more of a headache than anything else.

When I save a document, I don't expect it to be different when I open it, with ANY program. Thunderbird changing my saved documents without my say-so. WTF!

So I guess I'm asking, where do I report this stupid bug?

;o) Cor
<small>nothing is foolproof to the sufficiently talented fool</small<

LIMPET235
Moderator

User avatar
 
Posts: 37714
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted September 16th, 2013, 10:10 am

corz,
Please start a new thread in the Thunderbird Support forum.
This oldie from Tue 16th Nov 2010, needs its rest.

Thank you.

Locking.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-56.0.1-57.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting.
(Always choose the "Custom" Install.)

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 2 guests