MozillaZine

IMAP messages read on web still marked unread in Thunderbird

User Help for Mozilla Thunderbird
violetmoz
 
Posts: 18
Joined: July 18th, 2008, 9:12 am

Post Posted January 12th, 2011, 1:04 pm

Running Thunderbird 3.1.7 on Windows 7 with a gmail account set up using IMAP.

If I read a message on the web, it is still marked unread in Thunderbird, even after doing a "get mail" in Thunderbird. The only way I have gotten it to update read messages correctly is to restart Thunderbird, which is not a good solution.

On the other hand, if I delete a message on the web, it is deleted within a second or two in Thunderbird (no "get mail" is needed). Also, if I read a message on Thunderbird, it will show as read on the web after I refresh the web page (i.e. the reverse process works). I'm just providing these tidbits to show that IMAP seems to be setup correctly (for the most part).

Thanks,
Debbie

Guest
Guest
 

Post Posted January 12th, 2011, 1:16 pm

Running Thunderbird 3.1.7 on Windows 7 with a gmail account set up using IMAP.

If I read a message on the web,(at this point) it is still marked unread in Thunderbird, even after doing a "get mail" in Thunderbird. The only way I have gotten it to update read messages correctly is to restart Thunderbird, which is not a good solution.

if it is marked Read at this point, how would you be able to download any mail to Thunderboid ?

Guest
Guest
 

Post Posted January 12th, 2011, 1:21 pm

how would you be able to download all mail to TB ?

tanstaafl
Moderator

User avatar
 
Posts: 39424
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted January 12th, 2011, 6:06 pm

I've got several Gmail IMAP accounts and have never seen that.

1. Is message synching (offline folders) enabled or disabled?
2. Is global search/indexing enabled or disabled?
3. Did you unsubscribe the Archive folder?
4. Does this problem only occur with the inbox?
5. How many messages are in your inbox? Its harder to corrupt a remote folder but it can occur. You might try moving all of the messages in your inbox to other folders/child folders, empty the trash, and then compact the folders.

violetmoz
 
Posts: 18
Joined: July 18th, 2008, 9:12 am

Post Posted January 12th, 2011, 10:42 pm

My answers are embedded below in red.

tanstaafl wrote:I've got several Gmail IMAP accounts and have never seen that.

1. Is message synching (offline folders) enabled or disabled?
Where would I find this? I do see a "Synchronization" under the T'bird account settings (and it is checked), but it doesn't mention offline folders.

2. Is global search/indexing enabled or disabled?
Where is this set?

3. Did you unsubscribe the Archive folder?
Yes.

4. Does this problem only occur with the inbox?
No, it also occurs with other folders (and both of the other gmail IMAP accounts that I set up around the same time).

5. How many messages are in your inbox? Its harder to corrupt a remote folder but it can occur. You might try moving all of the messages in your inbox to other folders/child folders, empty the trash, and then compact the folders.
I'll give this a shot, but these are all fairly new folders, I keep my inbox fairly small, and I have T'bird set to compact folders regularly.


violetmoz
 
Posts: 18
Joined: July 18th, 2008, 9:12 am

Post Posted January 14th, 2011, 11:49 am

Aside: I thought I already posted this, so my apologies if it shows up twice.

I tried your #5 suggestion, but it didn't make any difference. When I selected the compact command, I noticed the "Offline ... Download/Sync Now" command (I never use it and had forgotten about it). After finishing the test for your suggestion, I tried the sync command (without going offline), but it didn't make any difference. I also tried the "Offline/Work Offline" command, but it also didn't make any difference (nor did it when I put T'bird back "online".

However, restarting T'bird does work. Any ideas on what might be getting done during startup that correctly marks read messages but that is not getting done (in my setup) when running?

violetmoz wrote:My answers are embedded below in red.
tanstaafl wrote:[..]
5. How many messages are in your inbox? Its harder to corrupt a remote folder but it can occur. You might try moving all of the messages in your inbox to other folders/child folders, empty the trash, and then compact the folders.
I'll give this a shot, but these are all fairly new folders, I keep my inbox fairly small, and I have T'bird set to compact folders regularly.

tanstaafl
Moderator

User avatar
 
Posts: 39424
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted January 14th, 2011, 5:09 pm

Synchronization is set using tools -> account settings -> synchronization & storage -> keep messages for this account on the computer. Global search is set using tools -> settings -> advanced -> general -> enable global search and indexer. "Offline ... Download/Sync Now" is a different, incompatible and older way to have a offline folder than the " synchronization & storage" settings.

Offline folders and/or global searching shouldn't effect your problem, but there are more opportunities for things to go wrong since they download messages in the background.

Check if tools -> account settings -> gmail -> server settings -> advanced -> IMAP server directory is set to [Gmail] . That should effect just the folder layout (fixes a display problem), but I'm trying to think of anything different we might have that matters. Also check that "use IDLE command if the server supports it" is still checked. IDLE is used to notify a email client of new mail without the email client having to periodically poll for new mail.

violetmoz
 
Posts: 18
Joined: July 18th, 2008, 9:12 am

Post Posted January 15th, 2011, 7:51 am

Synchronization and global search were both checked. How odd that the "Offline" command was left in when it is incompatible.

The IMAP server directory was blank. I set it to [Gmail], but that didn't make any difference. The "use IDLE ..." is still checked.

tanstaafl
Moderator

User avatar
 
Posts: 39424
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted January 15th, 2011, 4:20 pm

"How odd that the "Offline" command was left in when it is incompatible."

I don't know their reasoning but suspect they kept it because it supports true synchronization, where any changes you make in the offline folder effect the remote folder. Some people find that useful. The new version doesn't effect the contents of the remote folder, not will it lose messages if you delete them in the remote folder.

Are you using more than webmail and Thunderbird 3.1.7 with that Gmail account? Perhaps some smart phone?

violetmoz
 
Posts: 18
Joined: July 18th, 2008, 9:12 am

Post Posted January 17th, 2011, 7:52 am

tanstaafl wrote:Are you using more than webmail and Thunderbird 3.1.7 with that Gmail account? Perhaps some smart phone?


The reason that I finally switched from POP to IMAP was that I got an iPhone. ;) I also got new email addresses at the same time, so these accounts have been set to IMAP from the get-go (as opposed to having been converted ... not sure if that would make any difference). I first noticed the problem with reading mail on my phone and seeing that the Thunderbird messages were not getting marked as read. However, before asking about it, I tested it by reading mail on just the web; my phone shows the messages as read, but Thunderbird does not.

violetmoz
 
Posts: 18
Joined: July 18th, 2008, 9:12 am

Post Posted January 20th, 2011, 1:33 pm

Just hoping there are some more ideas ...

I also tried deleting one of the IMAP accounts in Thunderbird, restarting Thunderbird, and re-creating the IMAP account in Thunderbird. No luck.

Foggen
 
Posts: 3
Joined: January 25th, 2011, 8:13 am

Post Posted January 25th, 2011, 8:28 am

I've had this same problem for years, I think on multiple machines. I've tried to fix it a number of times with no success.

tanstaafl
Moderator

User avatar
 
Posts: 39424
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted January 25th, 2011, 10:15 am

I've always had the read status of messages automatically stay in sync between webmail and Thunderbird, but deletion can be troublesome if they use different types of deletion. Most of my email providers webmail implementations either move a deleted message to trash or expunge a deleted message (physically delete it) while I keep the accounts in Thunderbird set to just mark it as deleted.

If the read status doesn't automatically stay in sync I'd suspect either you've disabled IDLE support in account settings -> server settings -> advanced or the IMAP server claims it supports IDLE but doesn't actually implement it.

If the problem occurs with a email provider that I have an account with I can enable IMAP logging, try to duplicate the problem, and see if I can discover whats going on by examining the log file. I have Yahoo, Gmx, Gmail, Google Apps, Fastmail.fm (uses Cyrus IMAP server), Lavabit, Aixgen, and Aim IMAP accounts. Does the read status problem occur with any of them?

If not, do you have any idea what type of IMAP server you're using that causes this problem? i.e. is it a Dovecot, Cyrus, Courier, UW etc. IMAP server.

tanstaafl
Moderator

User avatar
 
Posts: 39424
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted January 25th, 2011, 10:23 am

Normally if you open a folder that should discover any new mail in it. If Thunderbird doesn't recognize that a folder contains unread messages try setting mail.imap.use_status_for_biff false using the config editor. It causes Thunderbird to explicitly select each folder to update the message summaries, rather than use the STATUS command. It has more overhead, but some IMAP servers don't return STATUS correctly.

The IDLE command lets a mail server automatically notify a email client of a new message without the email client having to ask what is the folders status. That avoids the need to periodically poll for new messages or open the folder to discover new messages.

Foggen
 
Posts: 3
Joined: January 25th, 2011, 8:13 am

Post Posted January 25th, 2011, 11:22 am

I have a work Exchange account and a Gmail account, both of which are accessed via IMAP. Exchange works right, Gmail does not. My specific issue is that I will read Gmail in a web browser or on my iPhone and when I get back to work Thunderbird will show all of the Gmail messages that had come in unread until I reread them or restart Thunderbird. IDLE is turned on, use_status_for_biff is turned off. I think the biff thing made it work for me briefly, but not anymore.

Return to Thunderbird Support


Who is online

Users browsing this forum: Adrian Bell, Bing [Bot], Google [Bot], Google Adsense [Bot] and 9 guests