MozillaZine

Image won't appear in email signature - TB3

User Help for Mozilla Thunderbird
Thundercat3
Guest
 

Post Posted April 20th, 2011, 3:08 pm

I have been struggling for days with my thunderbird 3 html signature that has an image attached to it. I am referencing the image off of my computer locally and I have tried the <img moz-do-not-send="true"> as was suggested to put into the image tag, but it it just will not appear. It was never a problem in outlook express 6. Does anyone has a solution or a workaround for this issue? Thank you!

Bernd S.
 
Posts: 94
Joined: January 22nd, 2010, 7:14 am

Post Posted April 21st, 2011, 2:42 am

Did you create the signature in TB itself or with an external program?

Guest
Guest
 

Post Posted April 21st, 2011, 10:06 am

Bernd S. wrote:Did you create the signature in TB itself or with an external program?


I created the signature in a text document and then saved it as an html document. In the code I referenced the image where it is in a local folder on my computer (the absolute address).

Thundercat3
Guest
 

Post Posted April 21st, 2011, 10:28 am

Can I create an HTML signature with an image in TB itself? How would I do that?

DanRaisch
Moderator

User avatar
 
Posts: 108248
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted April 21st, 2011, 10:32 am

See if this article is what you want -- http://kb.mozillazine.org/Signatures_%2 ... ture_files

Bernd S.
 
Posts: 94
Joined: January 22nd, 2010, 7:14 am

Post Posted April 21st, 2011, 10:35 am

Sometimes that doesn't work this way. Try to create it in Thunderbird and save it as html.
Go into the compose window, click into the message body, then on Insert, Image, Location and uncheck "attach this image to the message".
After inserting the URL of the image it must appear right now in the "image preview" below.[/quote]

Guest
Guest
 

Post Posted April 21st, 2011, 12:01 pm

Bernd S. wrote:Sometimes that doesn't work this way. Try to create it in Thunderbird and save it as html.
Go into the compose window, click into the message body, then on Insert, Image, Location and uncheck "attach this image to the message".
After inserting the URL of the image it must appear right now in the "image preview" below.
[/quote]

Thanks for this. I'm not sure what you mean by, "it must appear right now in the image preview". I have tried pasting all the same html into the signature box for html in TB3 and it didn't work. I have also read the other post in the URL posted by the other person and it didn't work. I haven't tried the "Quote and Compose add on" referred to in the article though. I may do that. THANKS GUYS!

Bernd S.
 
Posts: 94
Joined: January 22nd, 2010, 7:14 am

Post Posted April 21st, 2011, 12:45 pm

I have tried pasting all the same html into the signature box for html in TB3 and it didn't work.

Yes, that doesn't work alwasy as I said.

I wrote
"it must appear right now in the image preview".

Having inserted the last letter of the link into the item (image location) the image immediately appears in the "Image Preview" item below.
If not, there is something wrong and it won't work.

Bernd S.
 
Posts: 94
Joined: January 22nd, 2010, 7:14 am

Post Posted April 21st, 2011, 12:48 pm

Bernd S. wrote:
I have tried pasting all the same html into the signature box for html in TB3 and it didn't work.

Yes, that doesn't always work as I said.

I wrote
"it must appear right now in the image preview".

Having inserted the last letter of the link into the item (image location) the image immediately appears in the "Image Preview" item below.
If not, there is something wrong and it won't work.

thundercat3
Guest
 

Post Posted April 21st, 2011, 6:03 pm

Bernd S. wrote:
Bernd S. wrote:
I have tried pasting all the same html into the signature box for html in TB3 and it didn't work.

Yes, that doesn't always work as I said.

I wrote
"it must appear right now in the image preview".

Having inserted the last letter of the link into the item (image location) the image immediately appears in the "Image Preview" item below.
If not, there is something wrong and it won't work.


I don't know if I'm missing something but in my Thunderbird 3 when I go to "view settings for this account" and then check, "use html" the only thing I see is the text box to enter in html. I don't see a preview window.

Here is my image tag: <img moz-do-not-send="false" src="C:\Documents and Settings\Administrator\My Documents\Dan's Docs\email signatures\MainIdentity.png

and of course I have it all between to html tags = <html> and </html>
Can there be spaces in folder names? I don't think that is a probelm though.

Bernd S.
 
Posts: 94
Joined: January 22nd, 2010, 7:14 am

Post Posted April 22nd, 2011, 7:35 am

For creating a HTML-signature you must go into the compose window.
There to "Insert" then "image".

Thundercat3
Guest
 

Post Posted April 22nd, 2011, 8:28 am

Bernd S. wrote:For creating a HTML-signature you must go into the compose window.
There to "Insert" then "image".


Oh, I got ya'. I didn't realize that an html signature could be added that way. Would I have to create a signature for every email, or will it be automatic at that point?

Thundercat3
Guest
 

Post Posted April 22nd, 2011, 10:30 pm

Thanks for all your help Bernd S. It worked to insert the image via that method, by inserting it in the compose window. I can put the html for the rest of the signature in "View Settings for this Account", and then insert the image to go along with it from the compose window, and it shows up every time. Then I can click, "Index Text (Move Right)" to line it up with the rest of the signature. It's pretty fast actually, and for now appears to be the best method for me, since I don't want to link to an image remotely.

Thanks again!

Bernd S.
 
Posts: 94
Joined: January 22nd, 2010, 7:14 am

Post Posted April 23rd, 2011, 1:56 am

But you wrote
y and I have tried the <img moz-do-not-send="true">
.
Do you know what that means?
That means that TB doesn't attach an image file to the e-mail. You can use that tag only for remote images.
In this case TB expects a remote image with an URL.

thundercat3
Guest
 

Post Posted April 24th, 2011, 3:25 pm

Bernd S. wrote:But you wrote
y and I have tried the <img moz-do-not-send="true">
.
Do you know what that means?
That means that TB doesn't attach an image file to the e-mail. You can use that tag only for remote images.
In this case TB expects a remote image with an URL.


I actually meant to write that my tag was <img moz-do-not-send="false"> when I wrote that earlier. So, either way ("true" or "false") is that tag with "moz-do-not-send" meant only for remote images? When I tried to attach an image from a local folder into my html code I had tried the <img src> tag with "moz-do-not-send" and also without it with no success.

Return to Thunderbird Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 13 guests