MozillaZine

Thunderbird 3.1.10 intermittently unresponsive 5-30 seconds

User Help for Mozilla Thunderbird
jeff.welling
 
Posts: 8
Joined: May 29th, 2011, 3:29 pm

Post Posted May 29th, 2011, 3:37 pm

I'm having a problem with Thunderbird and I can't for the life of me figure out what the problem is.

I'm using
OS X 10.6.7
Thunderbird 3.1.10

I have it configured to check 3 IMAP google accounts, one of which sees massive amounts of traffic (the account I use for mailing lists). I mention the high traffic volume because I suspect it is closely related to the problem.

The problem is this: Thunderbird regularly and without warning locks up, pinning one of my CPUs and going completely unresponsive for a period of anywhere between 5-45 seconds.

I've found that the best way to reproduce this bug is first configure 3 mail accounts, one with around 1.9Gigs of emails (no attachments, just regular emails), then simply click Write to open a new email dialogue. Within 10 seconds, Thunderbird (and the new Write window) locks up becoming unresponsive. You can continue to type as you normally would but characters are just held in the buffer until Thunderbird comes back, at which point it catches up on everything you typed.

I've tried checking the Activity Monitor while writing a new email to see if anything shows up, but nothing does. The only way I know how to get it to not lockup like that is to disconnect from the internet while I'm composing the email. But that's really only a temporary fix that really only applies to writing emails, and this lockup problem rears it's ugly head even when I'm browsing my email in my inbox.

I switched from Apple Mail to Thunderbird for the OpenPGP plugin, something Apple Mail still doesn't support natively to the best of my knowledge, so I can't switch back. I remember Apple Mail didn't have this problem though, so I'm considering using Apple Mail for anything not requiring signing/encrypting, but I'd really like to figure out and fix what Thunderbird is choking on. It's Open Source, after all.

Note: This question was copy/pasted from SuperUser, as nobody was able answer the question and a comment suggested I bring it here. Any useful help that is posted here will be relayed back SuperUser.
http://superuser.com/questions/288201/t ... responsive

Edit: I should add that I've tried all of the solutions listed here, which include several from mozillaZine.
http://superuser.com/questions/60319/wh ... 2091#72091

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted May 29th, 2011, 4:20 pm

howdy jeff.welling,

while i don't really think "gloda" [global indexing & search] is the source of the problem, have you tried turning off global indexing? that's at ...
tools/options/advanced/general-tab/enable-global-search-and-indexer

on a mac the menu path will be different but i don't remember just how. [*blush*] you can find some more info here ...
http://getsatisfaction.com/mozilla_mess ... ver_6_gigs

take care,
lee

DanRaisch
Moderator

User avatar
 
Posts: 107274
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted May 29th, 2011, 4:22 pm

Do you regularly compact the message folders? Compacting is something that needs to be done regularly in any email program. We recommend weekly, but many of us do it daily. When done often enough, it can be an extremely fast process. Not doing so can lead to problems like those you are experiencing. See this about how to and why it's so important: http://kb.mozillazine.org/Compacting_folders

If you haven't been doing that before, first back up your Thunderbird Profile -- http://kb.mozillazine.org/Profile_backup then compact all folders. If 'compacting' them (and leaving a long enough time for the process to complete) doesn't fully resolve the problem then do the following on each account:

Close Thunderbird. Find and delete all of the files with the .msf file extension in your profile folder/Mail http://kb.mozillazine.org/Profile_Folder#Thunderbird including your Local Folders, especially if you are using the global inbox. You must have "View hidden files and folders" on http://spywarewarrior.com/viewtopic.php?t=272 and you need to set "hide extensions for known file types" off (just below View Hidden) if you are using Windows. These are your mail summary files and do not hold any messages themselves. They will be rebuilt the next time you open each folder in Thunderbird. Compact all your folders when you have completed this.

To avoid this happening again, see the tips in these articles:
http://kb.mozillazine.org/Keep_it_worki ... derbird%29
http://kb.mozillazine.org/Performance_%28Thunderbird%29

jeff.welling
 
Posts: 8
Joined: May 29th, 2011, 3:29 pm

Post Posted May 29th, 2011, 8:11 pm

Lee_Dailey wrote:howdy jeff.welling,

while i don't really think "gloda" [global indexing & search] is the source of the problem, have you tried turning off global indexing?


Hey Lee, Thanks for your suggestion.
The 'Enable Global Search and Indexer' check-box is unchecked in my configuration, do you have any other suggestions?
Cheers,
Jeff.

jeff.welling
 
Posts: 8
Joined: May 29th, 2011, 3:29 pm

Post Posted May 29th, 2011, 8:32 pm

DanRaisch wrote:Do you regularly compact the message folders? Compacting is something that needs to be done regularly in any email program. We recommend weekly, but many of us do it daily. When done often enough, it can be an extremely fast process. Not doing so can lead to problems like those you are experiencing. See this about how to and why it's so important: http://kb.mozillazine.org/Compacting_folders

This is the first I've heard of compacting folders aside from noticing the menu option. I'm curious, why *doesn't* it compact periodically by default, that seems like the intuitive solution to me -- is there some kind of performance drawback?

Compacting now, just waiting for it to finish. Will post back with the results.

DanRaisch wrote:... If 'compacting' them (and leaving a long enough time for the process to complete) doesn't fully resolve the problem then do the following on each account: ...

This looks suspiciously like one of the answers I already tried that was suggested on the Answer of the duplicate SuperUsers question, linked to at the bottom of my original post. Thanks though, much appreciated :)
Cheers,
Jeff.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted May 29th, 2011, 9:26 pm

howdy jeff,

based on your statement ...
The only way I know how to get it to not lockup like that is to disconnect from the internet while I'm composing the email


... i've one other idea. what happens if you disable auto-checking for mail? perhaps turning off these items ...
- check for messages at startup
- check for messages every [#] minutes

... for each account might point to the problem. _not_ a solution, i admit, but perhaps a way to narrow the source down.

in reference to the msg from DanRaisch ...
- re-covering what you've already done
his message to you is boilerplate. effective, useful and well worth repeating - so he does repeat it. [*grin*] that's why you saw a bit of overlap with your previous work on this.
- compacting
i confess that i thot tbird did turn compacting on in new installs starting in v-2 sometime. i know it did NOT auto-compact when i 1st started using tbird back in v-1 cuz it took too long, was disruptive AND caused some really odd errors when tbird was trying to multitask. i thot the devs had decided that new systems are fast enuf that auto-compacting was turned on in new installs by default.

take care,
lee

-ps
was wandering thru bugzilla and found that auto-compacting is OFF by default in tb3.1.x and a patch has been added for tb3.3 [likely tb5, now] to turn it ON by default and to bump the size from 100kb to either 5mb or 20mb.
lee-

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted May 29th, 2011, 9:50 pm

howdy jeff,

been wandering thru bugzilla, as mentioned above, and found this interesting item ...
- Frequent freezing during composition with "Attaching..." on Status Bar (autosave, compacting, IMAP) at zero to low cpu - low value for preference Auto Save every N minutes
https://bugzilla.mozilla.org/show_bug.cgi?id=485524

be aware that this applies to a different version of tbird! still, it otta be somewhat pertinent. you might wanna read thru it as it has _some_ connection to your problem. the point that caught my attention was the "during composition" phrase.

if a bug fits your situation, you might want to vote for it ... and perhaps add yourself to the CC list. please, do NOT comment unless you have new info. bugspamming - "me too" comments and various rants [*grin*] - is a good way to get the bug ignored.
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

take care,
lee

jeff.welling
 
Posts: 8
Joined: May 29th, 2011, 3:29 pm

Post Posted May 30th, 2011, 4:11 pm

Hey again. So It's been several hours now since I compacted the folders, and I've noticed that when I intentionally reproduce the delay by writing a new email, the delay has shrunk to around 5-8 seconds instead of the 10-40ish seconds I was seeing before. I haven't yet noticed the intermittent lockups previously mentioned, but I have only spent a brief amount of time in Thunderbird so far. It's an improvement, but IMO I think Thunderbird can still do better. I'm going to leave it be for another couple days to see if not compacting the folders increases the delay noticeably.

Thanks for the additional tips Lee :)
I appreciate the tip on disabling auto-checking, but I think the stack traces would be more helpful in this regard, described below.
I'll take a stroll through Bugzilla to see what looks potentially relevant, but the number of responses here has me thinking that not many people have Thunderbird set up like I do with gigabytes of email and thus don't experience the problem.

I think what I may end up doing, if the lockups persist, is to compile Thunderbird from source and just force-kill it when it starts misbehaving to look at the stack-trace. Doing that several times should give me an idea of which part of the code is causing problems based on what shows up most frequently in the stack traces.
After all, it *is* Open Source, what better way to embrace that philosophy than to try to fix it myself.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted May 30th, 2011, 5:15 pm

howdy jeff,

good that you are seeing some improvement. [*grin*] did you note the relationship between autosave interval, drafts folder compacting and composing? the drafts folder can grow wildly large if it aint compacted often and autosave is set to a small number.

it's kool that you are going at the inner workings. if you decide to post in bugzilla, please drop a line here so the curious [such as myself] can follow along.

good luck!

take care,
lee

jeff.welling
 
Posts: 8
Joined: May 29th, 2011, 3:29 pm

Post Posted May 31st, 2011, 1:45 pm

Lee_Dailey wrote:[*grin*] did you note the relationship between autosave interval, drafts folder compacting and composing? the drafts folder can grow wildly large if it aint compacted often and autosave is set to a small number.


The strange thing about that is that I remember when I first encountered this problem I went hunting for possible solutions in the configuration, things like auto-save and global indexing were the first things I tried disabling but they didn't produce any noticeable changes. Thinking about it now, this could be due to the drafts folder growing large while auto-save was enabled, and then simply staying that large because I didn't realize compacting folders was required as regular maintenance and wasn't doing it.
*ponders...*

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted May 31st, 2011, 3:47 pm

*ponders...*
[*grin*]

jeff.welling
 
Posts: 8
Joined: May 29th, 2011, 3:29 pm

Post Posted June 6th, 2011, 9:13 am

Update: I've noticed Thunderbird has reverted to it's good old behavior of locking up for 10-40 seconds which is absolutely inexcusable, so I'm going to be switching to an alternate email client until this problem is resolved or until I have time to work on it myself. Thanks to everyone who provided useful input :)

jeff.welling
 
Posts: 8
Joined: May 29th, 2011, 3:29 pm

Post Posted June 6th, 2011, 9:26 am

During the most recent lockup, there was a change in behavior as well. Normally, anything typed while Thunderbird is AFK is remembered and Thunderbird catches up when it comes back.
However this time, Thunderbird did not remember anything typed while it was unresponsive. What caused this change in behavior, I don't know, but this lack of effective input-buffering is what has driven me away from Thunderbird until it is fixed or I have time to address the issue.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted June 6th, 2011, 9:38 am

howdy jeff,

good luck with your next email client. [*sigh ...*] hope it goes better than this fiasco.

take care,
lee

MERobison
Guest
 

Post Posted June 6th, 2011, 8:53 pm

same issue, which I think started with 3.1.10. I run TB on two different laptops, and I've been running it for years. Its only been the last few weeks or a little more that it periodically hangs for 5-10 seconds. I regularly compact (and confirmed compact is still enabled), and no other settings change on either laptop. It has to be something in the new version since it started happening on both laptops.

I remember years ago TB had a similar problem and instructions to correct it until a new version came out, but I can't seem to find the old instructions. It wasn't related to the auto save or the auto check settings.

Hopefully TB gets enough complaints to find the bug and resolve quickly, as small things like this turn many fans away from TB.

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 6 guests