MozillaZine

Junk mail selections won't stay checked

User Help for Mozilla Thunderbird
Clayton787
 
Posts: 4
Joined: October 8th, 2009, 8:15 am

Post Posted October 26th, 2011, 11:11 am

My junk mail controls are no longer working. I have read numerous posts about ways to fix. But, any changes I make to the junk mail settings under "Account Setting" / "Junk Settings", do not get made. For example, if I check the "Move new junk messages" box, and click "OK" and then reopen, the check mark is gone.

Running Windows 7 and Thunderbird 7.0.1

DanRaisch
Moderator

User avatar
 
Posts: 122527
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted October 26th, 2011, 1:09 pm

Do you regularly compact the message folders? Compacting is something that needs to be done regularly in any email program. We recommend weekly, but many of us do it daily. When done often enough, it can be an extremely fast process. Not doing so can lead to problems like those you are experiencing. See this about how to and why it's so important: http://kb.mozillazine.org/Compacting_folders

If you haven't been doing that before, first back up your Thunderbird Profile -- http://kb.mozillazine.org/Profile_backup then compact all folders. If 'compacting' them (and leaving a long enough time for the process to complete) doesn't fully resolve the problem then do the following on each account:

Close Thunderbird. Find and delete all of the files with the .msf file extension in your profile folder/Mail http://kb.mozillazine.org/Profile_Folder#Thunderbird including your Local Folders, especially if you are using the global inbox. You must have "View hidden files and folders" on http://spywarewarrior.com/viewtopic.php?t=272 and you need to set "hide extensions for known file types" off (just below View Hidden) if you are using Windows. These are your mail summary files and do not hold any messages themselves. They will be rebuilt the next time you open each folder in Thunderbird. Compact all your folders when you have completed this.

To avoid this happening again, see the tips in these articles:
http://kb.mozillazine.org/Keep_it_worki ... derbird%29
http://kb.mozillazine.org/Performance_%28Thunderbird%29

Clayton787
 
Posts: 4
Joined: October 8th, 2009, 8:15 am

Post Posted October 26th, 2011, 3:12 pm

Thanks for the suggestions. I performed all of the suggested changes. These solutions did not solve the problem. I still have no ability to change the junk settings under the account settings.

DanRaisch
Moderator

User avatar
 
Posts: 122527
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted October 26th, 2011, 3:24 pm

Does the same thing occur if you launch the application in Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode

Clayton787
 
Posts: 4
Joined: October 8th, 2009, 8:15 am

Post Posted October 27th, 2011, 7:14 am

I re-launched in safe mode. It did not fix the problem.

DanRaisch
Moderator

User avatar
 
Posts: 122527
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted October 27th, 2011, 10:34 am

See if this article is helpful -- http://kb.mozillazine.org/Preferences_not_saved

Clayton787
 
Posts: 4
Joined: October 8th, 2009, 8:15 am

Post Posted November 9th, 2011, 8:55 am

I have tried all these various approaches. None have worked. Any other suggestions?

DanRaisch
Moderator

User avatar
 
Posts: 122527
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 9th, 2011, 2:26 pm

Did you review the section on other software that might block the saving of preference changes? What security software are you using on this computer?

Gyotto
Guest
 

Post Posted November 10th, 2011, 3:11 am

Same probleme here !!!

Its 10 days that junk settings dont work and dont stay marked!!!
Its rly frustrating....

Not any suggestion worked.

Gyotto
Guest
 

Post Posted November 10th, 2011, 3:15 am

Forgot...

Im on Windows 7 64 Ultimate
Norton Internet Security 2012 (spam filter disabled)

Gyotto
Guest
 

Post Posted November 13th, 2011, 12:02 pm

any suggestion ???

ss2115
Guest
 

Post Posted January 22nd, 2012, 2:39 am

Hi.
I've had the same problem, tried everything in the post with no success, but have discovered the solution.

Go to the thunderbird profiles as find the prefs.js file as explained above.
Rename it to prefs.old (just in case my solution doesn't work for you).
Then right click on it and open it. Choose notepad. (check or uncheck the box 'always open this file with this application - your choice).

In notepad, go up to the Edit dropdown and choose replace.
In the find box type in "spam" - lowercase and without the quotation marks.
In the replace with box type "junk" - lower case and without the quotation marks.
Then click 'Replace all"

When done (its very quick), save the file back as prefs.js.

Now open thunderbird again and go to OPTIONS first and choose your junk settings as they will have all been unchecked.
Then go to the ACCOUNTS and choose your junk preferences for each account you are using under "junk settings".
You should find that they will now stick.

Guest
Guest
 

Post Posted February 16th, 2012, 7:35 pm

It seems to be a known bug when you have a global inbox:

https://bugzilla.mozilla.org/show_bug.cgi?id=536768

Guest
Guest
 

Post Posted February 16th, 2012, 7:43 pm

Solution seems to be to open the config editor, and reset the values with "spamActionTarget" in the name (right click, reset). That is if you're also getting the error "uncaught exception: unable to find folder to select!" in your error console.

ellray
Guest
 

Post Posted May 23rd, 2012, 1:37 pm

Resetting the spamactiontarget settings (in the config editor) that were marked as set by user worked perfectly for me. Many thanks!

Guest wrote:Solution seems to be to open the config editor, and reset the values with "spamActionTarget" in the name (right click, reset). That is if you're also getting the error "uncaught exception: unable to find folder to select!" in your error console.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bruce L. and 6 guests