MozillaZine

Thunderbird 8.0 Vertical Pane Scrolling Slow

User Help for Mozilla Thunderbird
alharaka
 
Posts: 18
Joined: February 19th, 2009, 9:15 am

Post Posted November 21st, 2011, 6:56 am

I am running Windows 7 32-bit on a new Dell Latitude E6220. I recently upgraded from Thunderbird 7.0.1 to Thunderbird 8.0, but the problem persists where vertical pane scrolling (without the standard Message Pane in Classic Mode) is very slow. This is true if I use an external USB mouse, or the integrated touchpad on the laptop. This is true also if one uses the scrollwheel or select the scrollbar on the right-hand side of the vertical pane. The indicator/grip/scroll thumb always lags behind the mouse pointer.

I tried manipulating the smoothScroll boolean value, but it failed to work.

Will toggling hardware acceleration settings impact this? I have seen discussion of the following relevant settings, but I am not sure which are relevant, if any at all.

    gfx.direct2d.disabled
    gfx.direct2d.force-enabled
    layers.acceleration.disabled
    layers.acceleration.force-enabled
    layers.prefer-d3d9
    layers.prefer-opengl

alharaka
 
Posts: 18
Joined: February 19th, 2009, 9:15 am

Post Posted November 21st, 2011, 7:32 am

I forgot to add that I am not running Thunderbird 8 with any add-ons, and the only modifications made were to account settings and cosmetic appearance so far. I could not find any bugs in Bugzilla yet, but I just wanted to see if anyone else has had similar issues before moving forward on this.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted November 22nd, 2011, 6:55 am

howdy alharaka,

os = win7x32
tb = 8.0
extensions = lots

when i use classic view & then hit f8 to turn off the msg preview pane, i do NOT see any slowdown in scrolling in the threadpane/msg list pane. not in my normal profile or in a clean, unmodified profile or in mozilla safe mode for either profile.

you may be seeing a side effect of HA [hardware acceleration]. you can test that by trying mozilla safe mode to see if it helps. safe mode disables HA along with many other things.

you get to mozilla safe mode thus ...
- help/restart-with-addons-disabled
- leave the checkboxes UN-checked
- hit the continue button
- test
- when you restart the app you will be in normal mode again

take care,
lee

tanstaafl
Moderator

User avatar
 
Posts: 45869
Joined: July 30th, 2003, 5:06 pm

Post Posted November 22nd, 2011, 7:18 am

Hardware acceleration was added in Thunderbird 5.0. Just to be clear, did you have this problem when you were running Thunderbird 7.0?

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted November 22nd, 2011, 7:29 am

howdy tanstaafl,

this ...
I recently upgraded from Thunderbird 7.0.1 to Thunderbird 8.0, but the problem persists


... from the 1st post leads me to think it was there in v7 also. [*grin*]

take care,
lee

alharaka
 
Posts: 18
Joined: February 19th, 2009, 9:15 am

Post Posted November 23rd, 2011, 12:29 am

Lee_Dailey wrote:howdy tanstaafl,

this ...
I recently upgraded from Thunderbird 7.0.1 to Thunderbird 8.0, but the problem persists


... from the 1st post leads me to think it was there in v7 also. [*grin*]

take care,
lee


I did not notice it on the previous installation. So, some background. I had installed 7.0.1 on a new laptop, then migrated my profile to the new laptop (the E6220 mentioned in the original post). I had noticed this issue, then performed the upgrade, and notice it is persisting from 7.0.1 to 8. I had suspected this might be HA-related from my research, and why I ended up here.

alharaka
 
Posts: 18
Joined: February 19th, 2009, 9:15 am

Post Posted November 23rd, 2011, 12:30 am

tanstaafl wrote:Hardware acceleration was added in Thunderbird 5.0. Just to be clear, did you have this problem when you were running Thunderbird 7.0?


Yes, I did. The reason I upgraded is that I noticed the issue, and immediately checked my version number and noticed I was behind (installed Thunderbird, but had not used it for a period).

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted November 23rd, 2011, 12:55 am

howdy alharaka,

so, does mozilla safe mode help?

take care,
lee

alharaka
 
Posts: 18
Joined: February 19th, 2009, 9:15 am

Post Posted November 23rd, 2011, 12:57 am

Lee_Dailey wrote:howdy alharaka,

when i use classic view & then hit f8 to turn off the msg preview pane, i do NOT see any slowdown in scrolling in the threadpane/msg list pane. not in my normal profile or in a clean, unmodified profile or in mozilla safe mode for either profile.

you may be seeing a side effect of HA [hardware acceleration]. you can test that by trying mozilla safe mode to see if it helps. safe mode disables HA along with many other things.


Perfomance definitely seems to improve in Safe Mode. I feel like an idiot for not trying that. I did not know HA was disabled in Safe Mode, but it certainly makes sense. I am trying to search the wiki for what config options change in Safe Mode, but the Squid cache seems messed up. I will report back later. Thanks.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted November 23rd, 2011, 1:39 am

howdy alharaka,

take a lookit this ...
in tbird you can turn off hardware acceleration thus ...
[hopefully, a checkbox like the one in firefox will be in tbird someday.]
[1] on windows, tools/options/advanced/general-tab
-- on osx, firefox/preferences/advanced/general-tab
[2] config-editor-button
[3] on windows, search for the 1st item below by putting some or all of it in the filter box
-- on osx, search for the 2nd item below by putting some or all of it in the filter box
Code: Select all
gfx.direct2d.disabled
layers.acceleration.disabled
layers.prefer-opengl

[4] double-click on it to toggle it to TRUE
[5] close that dialog
[6] exit tbird
[7] restart tbird
[8] test

depending on your video system, you may need to toggle any or all of the above to TRUE. don't bother until you've tried the recommended setting for your OS.

the 1st one on your list - and on this one - is usually all you need on windows machines.

take care,
lee

tanstaafl
Moderator

User avatar
 
Posts: 45869
Joined: July 30th, 2003, 5:06 pm

Post Posted November 23rd, 2011, 1:45 am

"If you upgrade to Thunderbird 5 or later and the user interface seems much slower than before disable Direct2D hardware acceleration by setting gfx.direct2d.disabled true and layers.acceleration.disabled true using the config editor. This is due to the new version of the Gecko layout engine. "

layers.prefer-opengl should be false (that is its default value, but double check it). When this setting is true that says to use OpenGL rather than Direct2D. You'd only want to do that on OS X and Linux, which you are not using.

The config editor is at tools -> options -> advanced -> general -> config editor. Type in the filter: prompt the name of the setting. No need to press return. Then double click in the entry in the value column to toggle its value. There is no save or OK button, just close the window when you are done.

tanstaafl
Moderator

User avatar
 
Posts: 45869
Joined: July 30th, 2003, 5:06 pm

Post Posted November 23rd, 2011, 1:54 am

"I am trying to search the wiki for what config options change in Safe Mode, but the Squid cache seems messed up"

The knowledge base is temporarily down. However, you can use google search to search for the URL of a KB article such as http://kb.mozillazine.org/Performance_-_Thunderbird , click on the >> just to the right of it in the search results (it will show up when you hover the mouse there) , and then click on the "cached" link to see googles cache of the KB article.

I found the URL by google searching for "mozillazine kb performance"

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 5 guests