MozillaZine

Thunderbird hangs on send saying "attaching"

User Help for Mozilla Thunderbird
higsta1987
Guest
 

Post Posted April 18th, 2012, 10:26 pm

I use Thunderbird every day, in a business environment.

Nearly every day for no apparent reason, 30 seconds after succesfully sending a message, the next message attempting to be sent just hangs displaying "attaching".

When an email is sent successfully it doesn't even bring up attaching on the progress box

We are using an IMAP setup. ](*,)

DanRaisch
Moderator

User avatar
 
Posts: 108329
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted April 19th, 2012, 4:22 am

* Which version of Thunderbird? Check Help>About for the version number.
* What is the full and exact wording of the error message that you are receiving?
* Is your mail service from an ISP, corporate e-mail system or Web-based?
* Are you using an antivirus and/or a firewall program? Which ones?
* Where are the files representing the attachment stored? Are they on the same hard drive as the Thunderbird profile, on a network share, an external drive, or elsewhere?

Diane Vigil
 
Posts: 126
Joined: October 6th, 2010, 3:55 am

Post Posted April 26th, 2012, 2:46 am

The only time I've seen the "attaching" hang-up is when I've pasted in HTML (Insert > HTML) and the HTML references an image that is not on an external server.

That is, I wrote some HTML and referenced an image on my hard drive, but upon pasting the HTML into the email, the HTML has been "moved" so the location that it's referring to for the image is now incorrect ... thus we get into an endless "attaching" scenario.

I hope that made sense; it's late!

Diane Vigil
 
Posts: 126
Joined: October 6th, 2010, 3:55 am

Post Posted April 26th, 2012, 2:53 am

Geez, my computer specs in the bottom right of my post are woefully old, but I can't find where to edit them. I swear I've looked everywhere!

MozUser88
Guest
 

Post Posted May 2nd, 2012, 3:34 am

I just had this issue with Thunderbird 12.0.1 .

I was replying to an email that seems to have a broken image link in it. There were two other embedded images but no attachments.

After clicking Send, a box containing the word "Attaching" and a Cancel button appeared. After 10-20 seconds I clicked Cancel and tried Saving the email instead - but the "Attaching" box appeared again.

I copied my message text to the clipboard, cancelled the message window, created a new reply message, pasted the text into that, and sent it. There was no problem that time even though I was sending exactly the same thing (with the same broken image link in the quoted message below my text).

I've used Thunderbird for over 6 years with the same email accounts and have not seen this before.

OS: Windows 7 Pro SP1, 32-bit
Mail service is POP3/SMTP (not ISP-provided).
Firewall/anti-virus: Comodo Internet Security Premium v5.10.228257.2253

MozUser88
Guest
 

Post Posted May 2nd, 2012, 5:30 am

Since my last post it has happened again and this time there was no "broken image" icon in the quoted message.

As before, "Send" and "Save" were both blocked by the problem.

In both cases I had spent a long time editing my email (perhaps this is a factor in triggering the problem?) but copying the text, cancelling, starting a new reply, pasting the text and sending immediately worked around the problem.

benizl
Guest
 

Post Posted May 7th, 2012, 4:24 pm

This has happened several times to me as well, Thunderbird 12.0.1, Win7. Hitting 'send' on an email has lead to Thunderbird just sitting with its progress box at 'Attaching' indefinitely. The first time was a new email thread to which I did attach several large files, the next time was a reply where the only attachment was an image in the sender's sig. In both cases, pasting my text in to a new reply worked fine.

PQR Theorist
Guest
 

Post Posted May 15th, 2012, 10:21 am

This happened to me too. Thanks to the information supplied in the previous posts, I was able to solve the problem by deleting the offending image from the sender's email which was quoted in my reply. My reply then went through with no problem (and no need for the cut-and-paste workaround either).

huiac
Guest
 

Post Posted May 16th, 2012, 5:40 pm

I can also confirm this behaviour, with a range of releases since at least version 5.0 on AMD64 linux.

Any message with an attachment can produce the issue, and once it occurs simply resending the same email fails in the same way until it's resolved.

I can normally "fix" it by sending myself a short test email with no attachments, after which things work correctly.

I had believed that it only happens if the first sent email of a session had an attachment, but it happoened today with session I'd had open for some time, and that I believe I had already used to send an email.

Possibly of note is that I use client authentication for SMTP, whereas almost all of my customers (who have not reported this issue) do not.

Regsards,


John Pearson

LGustavo
Guest
 

Post Posted May 17th, 2012, 6:50 am

Happening to me also, and started recently. Looks like the time I take to reply and the Drafts folder have something to do with it.

Brian in CA
Guest
 

Post Posted May 18th, 2012, 11:44 am

It has been happening to me for a while now. When I reply to an email, the inline images that were part of the original email are causing the problem. It's like Thunderbird doesn't know how to reattach them when you hit reply. It's not dependent on editing time, as another poster pointed out.

If I screen-capture the inline images, paste them into an image program, and then copy from that back into the email, that works. But that is time consuming - hardly an acceptable workaround.

I would say this is likely a bug in Thunderbird - Thunderbird isn't reattaching inline images properly in replies. And it has been going on for years - I have seen this reoccur in Thunderbird versions going back many years.

Ronskiman
Guest
 

Post Posted May 23rd, 2012, 11:54 am

I've also seen this for a long time, so it's not a resent thing. I've also found copying the message and pasting into a fresh message usually works, but I do remember one time that didn't work, think I had copied something from a website or somewhere.

Currently using 12.01

umdiecker
Guest
 

Post Posted May 30th, 2012, 3:47 pm

Same problem here, it's been occurring since 2009 for me and has never changed with any updates to Thunderbird' version - clearly a "built in" issue. The problem arises when images are received in email signatures - hit reply and, even though the images are still visible (and are often your own images in the same place on the web theyve always been) it just keeps trying to send. Really annoying when you think youve sent an email and 8hrs later at the end of the day you spot it in the background still whirring away trying to attach.

Is there a solution? This really needs addressing, even if it's just for Thunderbird to ignore the attachment or put up a message to say "problem with attachment, send anyway?"

ShadowCat8

User avatar
 
Posts: 2
Joined: April 12th, 2005, 12:20 pm

Post Posted May 30th, 2012, 4:41 pm

Yes,

I have the same issue of not being able to send an email that *doesn't* have an attachment, but Thunderbird 12.0.1 wants to attach something to the email.

I quoted a piece of text that named a .PDF file, which brought up the Attachment Reminder, and now I can't send the email because it is trying to attach a non-existent file (At least the file doesn't exist on my system).

BTW, @ronskiman: Thanks. That helped in this case, after I broke up the filename with spaces.

@DanRaisch: For the information you need:
1.) Thunderbird 12.0.1
2.) No error message other than the "Attaching..." at the bottom of the email window that never clears.
3.) In-house MS Exchange server.
4.) ClamAV on x86_64.
5.) The file doesn't exist on the system and was just mentioned in the email. It wasn't meant to be an attachment.

HTH.
Regards,
ShadowCat8
"In theory there are no differences between theory and practice. In practice, there are." -- aCOSwt @ forums.gentoo.org

Christians
Guest
 

Post Posted June 2nd, 2012, 2:17 pm

Same problem for a few weeks now, as described above. Hangs on sending although there is no attachment. TB 12.0.1, MSWindows7 64.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 14 guests