MozillaZine

Thunderbird hangs on send saying "attaching"

User Help for Mozilla Thunderbird
Ken Herrick
 
Posts: 37
Joined: March 11th, 2005, 4:45 pm
Location: Oakland, CA USA

Post Posted December 15th, 2015, 9:45 am

Has anyone else tried my "fix" posted on 03 Dec 2015? Take a screen-shot of the image and paste that into the new message? I haven't had another occasion to try that yet.

KCH

brainstuff
 
Posts: 79
Joined: July 28th, 2009, 6:32 am

Post Posted January 8th, 2016, 7:01 pm

This stupid problem exists since "the deluge"!!! There is not any hope that the developpers of thunderbird will seek a solution!

The "reason" of the bug are pictures in the mail. Verry crazy ... some days ago I have send a mail with 3 pictures to a correspondent. The mail cames back with the answer (and still the 3 pictures). I have respond to the mail again .. impossible to send it ... TB opens a windows with "attaching ..." and nothing is going on ...

I have tried all kind of tourn-a-rounds .. no result. I have still create a new mail and I have made a copy of the text and the pictures (text separately of the pictures) .. no result. Then I have deleted all the pictures and it was possible to send the mail. It works only the first time when the pictures are copied in the text ..

I wait still that there is a responsible developper in the TB Team who does not find that the TB users are stupid persons. I wait for a direct contact with a developper-chief who will really delete all the multiple bugs in TB...

DanRaisch
Moderator

User avatar
 
Posts: 115498
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 9th, 2016, 5:23 am

You should not expect to be contacted directly by a developer-chief or any other developer. See this article -- viewtopic.php?f=39&t=366405
Also remember that this forum is not run by or formally associated with Mozilla. We're an independent user-helping-user community.

rololo88
 
Posts: 2
Joined: January 17th, 2016, 7:13 pm

Post Posted January 17th, 2016, 7:39 pm

i just have quite similar problem and i just post a new tread here in this forum.

I noticed that this problem happened if i take too long time to write the email + if i need to send attached file or photo.

It's like Thunderbird have a TTL to send message then you have to start over.

When i face this problem, i copy and paste in a new "reply" window add my needed attached files and then i can send
my message without any problem.

It's clearly a bug from what i can read here.

OldEngineer2
New Member
 
Posts: 1
Joined: January 23rd, 2016, 5:16 am

Post Posted January 23rd, 2016, 5:40 am

I too have had this problem for some time. When replying to an email that has an image or table inserted into it, I've often had to delete said image or table to avoid the permanent 'attaching' message that otherwise appears when the reply refuses to send.

Just to make life interesting, a new variation on this theme occurred for the first time yesterday when I attempted to reply to a message that contained a table (just a captured screeenshot .jpg) in the hope it would send without the 'attaching' bug. There was a long delay in sending - not unusual - but eventually the message sent and I assumed that on this occasion it had completed without problems. However, the recipient of the email replied later saying he was mystified by the image that had replaced his table in the email that I'd sent. For some reason, Thunderbird gave up trying to attach the .jpg image contained in the original email that I'd received and decided to replace it with another that had been part of a totally different email received from someone else several weeks earlier! This was a thread containing several responses, and another image further down the thread had also been replaced with another randomly selected picture from yet another old mail received about a month ago. What will they come up with next?

Ken Herrick
 
Posts: 37
Joined: March 11th, 2005, 4:45 pm
Location: Oakland, CA USA

Post Posted January 23rd, 2016, 10:24 am

I've had OldEngineer2's problem also on occasion: an image of Marie Curie of all people, from who knows where, is substituted. One would think that SOMEONE must still be attending to updating TBird now & then & that that someone or perhaps a friend might just occasionally check out this site and pass the word along. Don't you think?...

jorgon
New Member
 
Posts: 1
Joined: February 4th, 2016, 4:38 pm

Post Posted February 4th, 2016, 4:44 pm

Today, there must have been so many broken links on the html I had pasted into my reply message that the usual workaround of Copy, then Paste into New Reply Message did not work.

Rather in panic, I pasted my reply into a word document instead. Then copied it again into a new reply message in Thunderbird.

That worked! The font was all different from my usual font, however and the formatting looked a bit strange. But at least I was able to send my reply.

I hope this can be fixed soon as it arises quite a lot, and this time required a few more clicks to sort out.

Barabba
 
Posts: 28
Joined: March 17th, 2015, 8:08 am

Post Posted February 12th, 2016, 10:21 am

This problem is dated YEARS and no one of developers fixed it! Shame.. cause it's a critical issue

JamesYuYu
 
Posts: 1
Joined: March 2nd, 2016, 9:15 pm

Post Posted March 2nd, 2016, 9:42 pm

How come the troublesome situation is still there /___\ Sometimes customers & colleagues told me they do not receive my mails, but I had sent them hours ago (at least I press [Send] button). After checking TB, they are all in [Attaching.....................................]. I must cancel them and try to capture & re-attach images (or directly delete images), and then mail again. Occasionally I just copy all content, create new mail, and paste. It is time-wasting.

Now every time mailing, I force myself to check if it is sent successfully 5 min later. It is really nonsense.

RayKremer
 
Posts: 27
Joined: December 27th, 2012, 9:28 am

Post Posted March 18th, 2016, 9:16 am

:idea: BUG DESCRIPTION AND QUICK WORK-AROUND: :idea:

:arrow: To reiterate, since a lot of people can't take the time to read over every page of the now very large thread, if there is an in-line graphic in mail that you are replying to/forwarding (e.g. a company logo in a signature) and the mail sits open long enough to get saved to the draft folder, when you finally hit send it is likely to get stuck on the message "Attaching..." The easy workaround that works for most folks is to hit cancel, click into the Drafts folder, then go back to the mail and hit send again. The typical surefire method is to just delete the images before reattempting the send. Shutting off the draft auto-save of course prevents this entirely.

(There may be other circumstances that invoke the same result, but that is the most common one.)

The six year old bugzilla thread on this problem is https://bugzilla.mozilla.org/show_bug.cgi?id=532395 , where the latest activity seems to be people confused about what the bug actually is and asking for a reproducible case, which I have been describing here for over a year. ](*,)

Tom Austin

User avatar
 
Posts: 124
Joined: December 17th, 2005, 5:19 pm

Post Posted March 22nd, 2016, 12:33 pm

I, for one, need to see this fixed. Sometimes I hit "Send" as I'm walking out of the office, only to find it the next day still trying to attach.

Is the way to fix this to report it as bug?

Tom Austin

User avatar
 
Posts: 124
Joined: December 17th, 2005, 5:19 pm

Post Posted March 24th, 2016, 5:00 pm

I'm experimenting with a partial mitigation. For me, most of the time the email hangs because my signature contains an image. So on a thread of replies my image shows up again and again.

Today I used an online converter to convert my signature image to Base 64. Now my signature is all text and my image shows up anyway. If this works, it will solve the problem only when my signature image is the only one that causes the attaching delay. It won't work for other images embedded in the text.

BugHunter
 
Posts: 2
Joined: March 25th, 2016, 5:49 am

Post Posted March 25th, 2016, 5:57 am

Ok, I just joined the forum so I can take a stab at this.

As to "Reproducable". I'm not going to say that is always possible.

Cause: As best I can tell. It appears when you are replying to a message and you end your reply message with a typed character, the send will often fail. It might fail with a "Attaching" message, or I want to say I've seen another situation where it hangs without that, but it's been a while.

Fix: (Well, workaround) At the end of your typed text, make sure you type a space or two and end your message with that. With the spaces on the end it never fails. However, if it has failed with the Attaching message and you've stopped it. You'll need to (SAVE YOUR REPLY MESSAGE SOMEWHERE) close the window, generally force it to do so. Then close and reopen Tbird and with the spaces now it will send. If you don't close and reopen, even the spaces won't help till you do. (Ie: A second send attempt will fail).

Synopsis: How this issue has lasted for YEARS is inconceivable to me. I'm relatively new to TBird, been using it about 6 months. This issue wasn't there when I first installed, but from the first instance of it, it's been a pain since. Typically for the last couple months I've remembered to type the spaces, today for whatever reason I did not. Hence my visit here to see what the status was... Well, the status doesn't look good.

BugHunter
 
Posts: 2
Joined: March 25th, 2016, 5:49 am

Post Posted March 25th, 2016, 6:00 am

Wonderful, and it looks like my messages are queued till they're 'approved'.........

I wanted to edit that and add that most times for me a failure will occur when I end my message with some punctuation, either a period, exclamation, question mark, whatever. .!?%*, all do it. A space or two following them makes them ok.

erenes
New Member
 
Posts: 2
Joined: March 31st, 2016, 3:54 pm

Post Posted March 31st, 2016, 3:55 pm

I have the same issue. Im not using IMAP, just POP.
Small images inside the mail does not want to be attached. Not all of them - but some.

Mostly footnotes. Imagine deleting 50 JPGS before sending a biz mail to push it out. It comes back as thread continue, then you need to delete new ones etc.

Sometimes if this is not a footnote Im trying to delete every JPG pasted into text. But this way Im loosing track and confirmation about what Im discussing with someone which is not acceptable.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 9 guests