MozillaZine

Slow graphics in Thunderand and suggested solutions won't wo

User Help for Mozilla Thunderbird
Lage2
Guest
 

Post Posted May 1st, 2012, 10:38 am

Hi,

I feel a bit bad about bringing this up, since it has been discussed in lenght before, but solutions that have worked for others don't seem to solve the problem:

I just installed Thunderbird 12.0.1 on a Windows 7 machine and the graphics are almost unbearably slow. If I move windows, they slowly flow across the screen. For the unpatient, such as me, this is enough to make me want to downgrade to version 3.

I've tried to search for solutions and have tried, as is commonly suggested, to enable and disable in various combinations the layers.acceleration.* and the gfx.direct2d.* options but to no avail. I use no addons. When Thunderbird is run in XP mode or if I disable aero mode in Windows, Thunderbird works as it should. Graphics acceleration in some form thus seem to be the culprit.

Are there more settings that I can change apart from the ones I've found mentioned in other threads?

Thanks,
David

smsmith
Moderator

User avatar
 
Posts: 19832
Joined: December 7th, 2004, 8:51 pm
Location: Indiana

Post Posted May 1st, 2012, 11:12 am

I've seen the same thing on two of my computers, both laptops, one that I would argue is "upper end" and one that I would agree is low to mid grade. The upper end laptop it's not as noticeable until you open a couple of compose windows, but I can definitely tell that Thunderbird is slower with basic window management/moving. The same experience was seen with Tb 11, but I can't say it was the same in Tb 10. Doesn't happen to me, even on the slower laptop when I run Fedora 16 with KDE, so your assertion that it's an Aero thing seems pretty spot on.

Come to think of it, I recall it starting to happen around the time tabs in the main window were on top, which was Tb 11.

Bugzilla searching has begun...
Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted May 1st, 2012, 5:35 pm

howdy Lage2,

i presume you found some variant of this list ...

in tbird you can turn off hardware acceleration thus ...
[hopefully, a checkbox like the one in firefox will be in tbird someday.]
[1] on windows, tools/options/advanced/general-tab
-- on osx, firefox/preferences/advanced/general-tab
[2] config-editor-button
[3] on windows, search for the 1st item below by putting some or all of it in the filter box
-- on osx, search for the 2nd item below by putting some or all of it in the filter box
Code: Select all
gfx.direct2d.disabled
layers.acceleration.disabled
layers.prefer-opengl

[4] double-click on it to toggle it to TRUE
[5] close that dialog
[6] exit tbird
[7] restart tbird
[8] test

depending on your video system, you may need to toggle any or all of the above to TRUE. don't bother until you've tried the recommended setting for your OS.

*****
you did not mention the 3rd pref listed above. have you tried it?

*****
have you tired mozilla safe mode yet?
you get to mozilla safe mode thus ...
- help/restart-with-addons-disabled
- leave the checkboxes UN-checked
- hit the continue button
- test
- when you restart the app you will be in normal mode again
[more info about it here - http://kb.mozillazine.org/Safe_Mode]

*****
in addition to the above, i am fairly sure that hardware accel is OFF by default in tbird these days. at least, when i started up tbird in my testing profile the H.A. stuff was all OFF.

take care,
lee

Lage2
Guest
 

Post Posted May 1st, 2012, 9:19 pm

Hi Lee and smsmith,

Thanks for your replies. I had tried the layers.perfer.opengl setting. You're right, they all seem to be disabled by default these days.

I tried to run Thunderbird in safe mode, but that unfortunately didn't have any effect on the sluggish graphics. I thought that I stuck with the last version without the aero look for the aestethics of it, but now rembember that the slow graphics actually was the major problem. The problem thus seem, at least for me, to run thru version 5 (4?) to 12.

Regards,
David

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted May 2nd, 2012, 11:51 am

howdy David,

thanks for the feedback! [*grin*]

as i recall, there was no version 4 of tbird. there was a _major_ rework of the whole framework of tbird with v-5 [mostly inherited from firefox] that has been carried forward. so having the problem show from v-5 onward is sorta-kinda sensible.

your situation is really odd. a few more ideas ..

*****
- have you tried turning HA on?
it's a backwards approach according to what i know, but backwards may work. it seems worth trying. since you are on windows i would only try the 1st pref listed in my previous post.

*****
- have you tried a different theme?
there may be some "thing" in your current theme that is triggering the problem. safe mode disables custom themes and uses the default one. maybe the default one is the source of the problem? perhaps you could try one of the non-glass themes ...

*****
- have you tried a new, unmodified profile?
you can do that pretty safely. backup first, of course. then set up only one account [preferably POP for simplicity] and set that account to NOT check for mail at all and to leave mail on the server forever. even if that doesn't help, you will have a nifty testing profile if you ever need it ... [*grin*]

*****
- have you tried a newer [or perhaps simply an older] video driver?
this still sounds _very_ much like a video interaction to me. so trying a different video driver version may help.

*****
- what is in the graphics section of the troubleshooting info report for your install of tbird?
you get there thus ..
- help/troubleshooting information

the graphics info is at the bottom. you can either hilite and copy/paste or use the "copy all to clipboard" button at the top and then trim out everything above the graphics section.

here's mine [done via the copy-all button]. i pasted things into notepad, and then copied the section i wanted.
Graphics

Adapter Description: ATI Radeon HD 2600 XT
Vendor ID: 1002
Device ID: 9588
Adapter RAM: 256
Adapter Drivers: aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Driver Version: 8.850.0.0
Driver Date: 4-19-2011
Direct2D Enabled: false
DirectWrite Enabled: false (6.1.7601.17776)
ClearType Parameters: ClearType parameters not found
WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 2600 XT) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
GPU Accelerated Windows: 0/2


i have no earthly idea what the "GPU Accelerated Windows: 0/2" means. [*grin*]

take care,
lee

smsmith
Moderator

User avatar
 
Posts: 19832
Joined: December 7th, 2004, 8:51 pm
Location: Indiana

Post Posted May 2nd, 2012, 1:08 pm

Lee_Dailey wrote:*****
- have you tried a different theme?
there may be some "thing" in your current theme that is triggering the problem. safe mode disables custom themes and uses the default one. maybe the default one is the source of the problem? perhaps you could try one of the non-glass themes ...

Oddly enough, I ran a quick test on this by switch to the Silvermel theme from the default theme and moving windows around is much quicker, so for me, it's in the default theme. Probably the glass in the toolbar?
Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted May 2nd, 2012, 1:29 pm

howdy smsmith,

that - glass effects - is what i was hoping would be part of the problem. kool, dude! thanks for the info. [*grin*]

take care,
lee

Lage2
Guest
 

Post Posted May 3rd, 2012, 3:45 am

Hi,

Changing to the Silvermel theme did it for me as well. Thanks for all the help and suggestions! I would rather have the regular interface, but since it's working now I won't fiddle with it.

Cheers,
David

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted May 3rd, 2012, 10:47 am

howdy David,

you are quite welcome! very glad to help a little when i can ... [*grin*]

as for that theme, you may want to start a thread asking about a theme that is NON-glass but that looks more like the default theme. i am fairly sure there are some.

take care,
lee

smsmith
Moderator

User avatar
 
Posts: 19832
Joined: December 7th, 2004, 8:51 pm
Location: Indiana

Post Posted May 3rd, 2012, 11:33 am

There's one called NoGlass, but the slowness still seemed to be there, so maybe it's not just the glass but something else, too...

https://addons.mozilla.org/en-US/thunde ... src=search
Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted May 3rd, 2012, 12:43 pm

howdy smsmith,

how annoying ... it otta be something so obvious! [*grin*]

if it gets your interest sufficiently engaged, then you may wanna ask the author of silvermel if he has any clues. ShareBird is pretty active hereabouts.

take care,
lee

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 8 guests