MozillaZine

new version and some emails change font size

User Help for Mozilla Thunderbird
w9ol
 
Posts: 111
Joined: July 15th, 2010, 3:58 am

Post Posted June 18th, 2012, 5:07 am

Prior to updating the other day to 13.0.1, all my incoming emails seemed to be the same font size.
But since the update, some, just a few, the fonts or the email page itself are either much smaller or one or two is real large.

Using View>Zoom and Ctr + or - changes the size.

I 'think' the email is sort of a html maybe? Some sort of page created by one of the email vendors that is really like a web page???
Maybe it was created by a Yahoo or Google Group????
I don't quite know what I'm talking about. LOL

Is there a setting that will display these emails at the same zoom setting for future arriving emails?

Other test type emails all appear normal.

please and thank you

DanRaisch
Moderator

User avatar
 
Posts: 122697
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted June 18th, 2012, 5:30 am

Try displaying those problem messages in plain text. Do that by using Thunderbird menu path View->Message body as->Plain Text.

I believe there is a bug in version 13.x.x that is causing the issue and which should be fixed in a future release.

w9ol
 
Posts: 111
Joined: July 15th, 2010, 3:58 am

Post Posted June 18th, 2012, 7:51 am

ok thanks, I'll just stick with the ctr + - instead of messing with settings till the new version fixes that bug.
thanks for confirming that it wasn't me that goofed up for once.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted June 18th, 2012, 7:16 pm

howdy w9ol,

you _may_ be running into a change in how tbird handles utf-8 fonts. the size for those fonts now needs to be set specifically. thus ...
- tools/options/display/formatting
- fonts-section/advanced-button
- fonts-for/[drop-list]

change the droplist from the default "western" to "other languages" and then set the sizes there. you may want to do a screen shot of your settings for "western" so you can use the same settings for both.

take care,
lee

hdfan2
 
Posts: 4
Joined: July 31st, 2011, 6:20 am

Post Posted June 18th, 2012, 9:18 pm

Hi! After upgrading to 13.0.1, I'm seeing the same thing - some html messages are displayed with very small font. I have option "Allow messages to use other fonts" (on Tools - Options - Display - Formatting - Advanced) turned off, and "Minimum font size" is set to some high value (22 in my case). I guess for some reason these options stopped working. w9ol, do yoг have it turned on or off? Does ANYONE see them working in 13.0.1? For now I'll stick with Ctrl+Plus, but honestly I'd like everything to work as before. Thanks!

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted June 18th, 2012, 9:30 pm

howdy hdfan2,

did you try the fix mentioned in the post immediately above yours?

take care,
lee

hdfan2
 
Posts: 4
Joined: July 31st, 2011, 6:20 am

Post Posted June 18th, 2012, 10:11 pm

Yes, I've tried to increase font size for various char sets. I also have "Minimum font size" changed (which, as far as I understand, should affect all char sets). Nothing helps.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted June 18th, 2012, 10:25 pm

howdy hdfan2,

did you try it for "other languages"? that is where the problem i am talking about is handled. please note that the "minimum font size" selection is SPECIFIC to the item selected in the "fonts for:" droplist.

take care,
lee

hdfan2
 
Posts: 4
Joined: July 31st, 2011, 6:20 am

Post Posted June 19th, 2012, 12:16 am

Thank you very much, Lee_Dailey! You where completely right! After changing this setting for "Other languages", my messages are finally displayed as before. And my apologies for not reading your post attentively enough. Once again, thank you!

P. S. Though I wonder, why this happened at all... Perhaps something changed in the code that detects language, and now they are all detected as "Other"?

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted June 19th, 2012, 12:32 am

howdy hdfan2,

you are quite welcome! [*grin*] plus, you are not alone in sometimes missing an important part of a msg. it's way too easy to do.

as for what happened, i _think_ there was a code change in the way UTF-8 fonts are handled. a side effect was to make it stop using the "western" setting. i dunno if that was intended, tho. [*grin*]

take care,
lee

khisel
 
Posts: 4
Joined: February 22nd, 2007, 6:25 pm

Post Posted July 16th, 2012, 4:39 pm

Thanks, Lee. That one had me uninstalling 13.0.1 and regressing back to 12. With your help I'm back to 13.

Much thanks!

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted July 16th, 2012, 6:10 pm

howdy khisel,

you are quite welcome! glad to have been a help ... [*grin*]

take care,
lee

adric
 
Posts: 65
Joined: May 28th, 2006, 2:21 am

Post Posted September 6th, 2012, 4:29 am

Finally, a tip that hits the nail on the head. Thanks for this. =D> I noticed the different font sizes between utf and western and managed to get a larger font by using the character encoding for western instead of utf from the view drop-down, but that gets to be a pain after a while. I would have never thought of applying the same font settings for western to the other languages drop-down. Most every time a new Mozilla release comes out with subtle changes like this, I end up spending a lot of time getting things back to the way they worked before.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted September 9th, 2012, 11:54 pm

howdy adric,

you are very welcome! it's good be able to help now and then ... [*grin*]

take care,
lee

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 7 guests