MozillaZine

Need to remove master password in Thunderbird

User Help for Mozilla Thunderbird
tracylaugle
 
Posts: 3
Joined: February 14th, 2013, 7:41 am

Post Posted February 14th, 2013, 8:01 am

I am required to update Thunderbird to version 4.6.0.9 (10.0.9). We run Windows XP SP3. In the current Thunderbird version we use (v3.1.12), the master password is set but can be removed by unchecking the box and putting in the default master password to confirm. In the new version, when I uncheck the master password box, there is no warning and I just click OK. However, when I try to subscribe to a newsgroup, I am still asked to put in a master password. Going back in to the Options, the master password box is still checked. It checks itself again whenever I close out of options. Relating this to Firefox, you must disable FIPS to remove the master password in the browser. When I go into that setting in Thunderbird options, the Security Devices button is grayed out - I have no option to disable FIPS, and I'm not even sure if that is part of the problem. Can someone help me - I MUST turn off the requests to enter the master password. Thanks for any assistance.

tanstaafl
Moderator

User avatar
 
Posts: 38822
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted February 14th, 2013, 8:32 am

There never was a Thunderbird version 4.6.0.9 (it jumped from 3.* over 4.* to 5.0). There was a 10.0.9 extended release support (ERS) version, but not one for a normal release (it jumped from 10.0.2 to 11.0). I think 17.0.2 is the latest ERS version. You should be able to install any version of Thunderbird since you have SP3.

http://www.mozilla.org/en-US/thunderbird/organizations/
ftp://ftp.mozilla.org/pub/mozilla.org/t ... /releases/
http://www.mozilla.org/en-US/thunderbir ... uirements/

If you have to use whatever weird build you are using you and removing the master password normally doesn't work you could try resetting it via "Choose Tools -> Error Console, paste the expression: openDialog("chrome://pippki/content/resetpassword.xul") and press the Evaluate button. That will open a dialog asking you if you want to reset your password." If that doesn't work exit Thunderbird, and try deleting both Signons.sqlite and key3.db in the Thunderbird profile. In both cases make certain you write down your saved passwords beforehand if you haven't already.

http://kb.mozillazine.org/Files_and_fol ... hunderbird
http://kb.mozillazine.org/Master_password

tracylaugle
 
Posts: 3
Joined: February 14th, 2013, 7:41 am

Post Posted February 14th, 2013, 10:11 am

Thanks for your reply. In the "About Thunderbird" screen, it said the version is 10.0.9. Not sure where it came from - this is what I was given. I tried both of your suggestions - neither one stops Thunderbird from asking for a master password. The last link you gave (http://kb.mozillazine.org/Master_password) said to click on the Change Password button to remove the master password:

Thunderbird: "Tools -> Options -> Security -> Passwords -> Change Master Password"

I tried changing to a blank password, but it said, "You are currently in FIPS mode. FIPS requires a non-empty Master Password." How do I disable FIPS when the Security Devices button is grayed out on the Certificates tab?

tanstaafl
Moderator

User avatar
 
Posts: 38822
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted February 14th, 2013, 12:44 pm

"Choose Tools -> Error Console, paste the expression: openDialog("chrome://pippki/content/resetpassword.xul") and press the Evaluate button. That will open a dialog asking you if you want to reset your password."

is a workaround that is used when Thunderbird thinks you have a master password even though you never had one. You might have to exit and restart Thunderbird afterwards. If that doesn't help then I suggest you search for any FIPS related settings using the config editor in tools -> options -> advanced -> general.

tracylaugle
 
Posts: 3
Joined: February 14th, 2013, 7:41 am

Post Posted February 14th, 2013, 1:26 pm

It turns out that if you create a dummy mail account in Thunderbird, one of the settings that appears in the left window is security. FIPS may be disabled through that security setting, and then the master password can be removed. Thanks anyway for your help.

hottybrown
New Member
 
Posts: 2
Joined: March 12th, 2013, 1:10 pm

Post Posted March 12th, 2013, 1:31 pm

Hi,
This is how I was able to fix this problem. The reason for the problem is that I clicked the enable fips button in thunderbird, and then, the disable button was not available to turn it back off. Since the fips module couldn't authenticate.

1. find the /thunderbird/profiles.ini file.
2. open this file in a text editor like textwrangler.
3. set the value startswithlastprofile=1 to =0.
4. restart thunderbird.
5. now the disable button works in --security devices fips disable.
6. disable fips.
7. close thunderbird.
8. reopen the profiles.ini file and change the value back to =1 and save the file.
9. restart thunderbird.
10. vacuum up the hair that you pulled out.

Return to Thunderbird Support


Who is online

Users browsing this forum: TBDTBD and 9 guests