MozillaZine

Local Directory Path Is Not Suitable For Message Storage

User Help for Mozilla Thunderbird
dontronics
 
Posts: 16
Joined: November 21st, 2012, 1:30 pm
Location: Australia

Post Posted December 1st, 2013, 7:27 pm

Do what the German forum suggests:

viewtopic.php?p=13147001#p13147001

instead of opening the account manager via "Tools" -> "Account Settings", they right-clicked on an account name in the folder pane and chose "Settings..." without getting the error/warning message.
Hence they were able to modify the account settings unless they clicked on "Local Folders" where they got the error or warning message again.

works for me, w7pro-64

Cheers Don...
Last edited by dontronics on December 4th, 2013, 4:15 pm, edited 1 time in total.

dontronics
 
Posts: 16
Joined: November 21st, 2012, 1:30 pm
Location: Australia

Post Posted December 4th, 2013, 2:12 pm

I also have an old 10" EEE-PC running XP. Checked and it was running V17. something, and not giving this error.

I just updated it to V24.1.1 and the same error (bug) appears.

Cheers Don...

ronbo
 
Posts: 101
Joined: July 2nd, 2004, 3:52 pm

Post Posted December 7th, 2013, 11:18 am

I have all my emails going to my Inbox, except those which are Filtered to go to specific folders. So I can't right click on an account inbox in the Folder Pane. Right clicking on Local Folders causes the same error--Chose another Directory---unless I'm not reading the instructions correctly.

I was able to delete a Tbird email account ( i had already deleted the gmail account) by installing Tbird 17.08 which i happened to have on my system. I then Updated again to 24.1.1 which still has the error.

I guess the programmers still haven't figured out how to fix this bad bug!

So for those who NEED to make changes--a very easy way is install an older version, and then just Update.

Ron

dontronics
 
Posts: 16
Joined: November 21st, 2012, 1:30 pm
Location: Australia

Post Posted December 7th, 2013, 1:05 pm

ronbo wrote:I have all my emails going to my Inbox, except those which are Filtered to go to specific folders. So I can't right click on an account inbox in the Folder Pane. Right clicking on Local Folders causes the same error--Chose another Directory---unless I'm not reading the instructions correctly.

I was able to delete a Tbird email account ( i had already deleted the gmail account) by installing Tbird 17.08 which i happened to have on my system. I then Updated again to 24.1.1 which still has the error.

I guess the programmers still haven't figured out how to fix this bad bug!

So for those who NEED to make changes--a very easy way is install an older version, and then just Update.

Ron


Or if you don't have an additional account other than "LOCAL Folders", then make up a dummy account, and right click on that.
That way, you don't have to uninstall and reinstall versions.

Cheers Don...

ronbo
 
Posts: 101
Joined: July 2nd, 2004, 3:52 pm

Post Posted December 7th, 2013, 2:00 pm

Thanks much for the pointer--it works great--this IS easier than my previous post :)

Ron

tonedeaf2
 
Posts: 99
Joined: July 26th, 2005, 5:14 pm

Post Posted December 10th, 2013, 12:29 pm

I too have the same problem. I setup a new profile but still get the same message

rsx11m
Moderator
 
Posts: 14420
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted December 10th, 2013, 1:09 pm

Can you try updating to 24.2.0?

It should have a partial fix, turning the hard error into a warning, thus should allow editing the Account Settings even for "dangerous" paths.

ronbo
 
Posts: 101
Joined: July 2nd, 2004, 3:52 pm

Post Posted December 10th, 2013, 4:06 pm

tonedeaf2--try dontronics suggestion 4 posts above---which fixed my problem, as long as I left the Feeds present. Once I uninstalled it, it reverted back to the error.
"Or if you don't have an additional account other than "LOCAL Folders", then make up a dummy account, and right click on that." My dummy account was the RSS Feed.

Ron

agilboy
 
Posts: 29
Joined: June 20th, 2007, 9:20 pm

Post Posted December 10th, 2013, 4:06 pm

I upgraded to 24.2 and no change. 2 of my 4 accounts stopped working but the other two work fine. I created a new account and redirected the setting in Browse to that account but get the same error msg. HELP!! this is horrible.

remilton
 
Posts: 2
Joined: November 21st, 2013, 2:29 pm

Post Posted December 10th, 2013, 10:46 pm

Thanks to the programmers for changing the hard error into a warning. I was able to resolve my " '***' is not suitable for message storage. Please choose another directory" issue by moving all the problem mail accounts to another profile/mail directory and reassigning the path in Account Settings. Success at last!

Ron

agilboy
 
Posts: 29
Joined: June 20th, 2007, 9:20 pm

Post Posted December 11th, 2013, 2:10 pm

I'm going nuts trying to solve this prob. Upgraded to TB24.2. FIxed one of two accounts that werre getting this msg. the other two are okay. Then today, i'm back with the original two accounts that don't work. I cannot download email - only send. get the msg "folder not suitable ..." HELP!! I'm unable to work without this fixed and am lost. I've read every post. Don't understand how to get rid of "dangerous" files. Thanks

tanstaafl
Moderator

User avatar
 
Posts: 43362
Joined: July 30th, 2003, 5:06 pm

Post Posted December 11th, 2013, 2:23 pm

agilboy:

I suggest you move the profile to some directory that is outside the directory trees that Windows pays attention to. For example, create a c:\users\agilboy\profile directory and then move your profile there per http://kb.mozillazine.org/Moving_your_p ... hunderbird

agilboy
 
Posts: 29
Joined: June 20th, 2007, 9:20 pm

Post Posted December 11th, 2013, 3:51 pm

Hi -- I tried this last thing - deleted old default references in prefs, but nothign changed. Still cannot get mail from 2 of 4 accounts. still getting the "not suitable for msg storage" error - very frustrated! The upgrade to 24.2 fixed one of the 2 accounts yesterday, but now that one is back to the old error msg again, and i cannot download email (but can send). Any help would be appreciated. thx

tanstaafl
Moderator

User avatar
 
Posts: 43362
Joined: July 30th, 2003, 5:06 pm

Post Posted December 11th, 2013, 3:58 pm

What do you mean by "deleted old default references in prefs"? I suggested you copy your profile directory to a different location and then use the profile manager to modify profiles.ini for you to point to the new location of the profile. That has NOTHING to do with the contents of the prefs.js file.

agilboy
 
Posts: 29
Joined: June 20th, 2007, 9:20 pm

Post Posted December 12th, 2013, 7:43 am

I was doing to the prefs file what was suggested in another post - sorry. I did delete two old default settings and resave the prefs file but that didn't change anything (I have a backup just in case). I followed your instructions, copied the contents to a new location, and can't get Profile Mgr to work. Get the common error

"Profile couldn't be created. Probably the chosen folder isn't writable.
[Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIToolkitProfileService.createProfile]" nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)" location: "JS frame :: chrome://mozapps/content/profile/createProfileWizard.js :: onFinish :: line 196" data: no]

Read a bunch of posts to try to get around this but haven't succeeded. I copied the entire "default" folder into a new FOlder called "Profiles" (because I was afraid to change that name), and tried selecting first the Profiles then the sub-dir default, but keep getting the error msg. I am the administrator. Tbird 24.2, Win 7. Anxious to figure out if your solution works -if I could get Profile Mgr to work.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 4 guests