MozillaZine

TB 24.0.1 IMAP folder access and subscription

User Help for Mozilla Thunderbird
beckerr.fht
 
Posts: 1
Joined: October 17th, 2013, 1:48 am

Post Posted October 17th, 2013, 2:23 am

TB 24.0.1 is unable to use existing IMAP mail folder subscriptions or subscribe to new IMAP mail folders.
Already subscribed mail folders are displayed, but their names are grey and using italic font face.

Accessing INBOX works. Sent messages are not stored in mail folder "send".

I've done some debugging while subscribing a mail folder. It seems, that there is an authentication problem.

Opening IMAP connection (works):
Code: Select all
1050632192[10056e380]: (GSSAPI = 0x1000000, CRAM = 0x20000, NTLM = 0x100000, MSN =  0x200000, PLAIN = 0x1000, LOGIN = 0x2, old-style IMAP login = 0x4)auth external IMAP login = 0x20000000
1050632192[10056e380]: trying auth method 0x1000
1050632192[10056e380]: got new password
1050632192[10056e380]: IMAP: trying auth method 0x1000
1050632192[10056e380]: PLAIN auth
1050632192[10056e380]: a04e000:imap.fh-trier.de:NA:SendData: 3 authenticate plain
1050632192[10056e380]: ReadNextLine [stream=785d510 nb=4 needmore=0]
1050632192[10056e380]: a04e000:imap.fh-trier.de:NA:CreateNewLineFromSocket: +
1050632192[10056e380]: a04e000:imap.fh-trier.de:NA:SendData: Logging suppressed for this command (it probably contained authentication information)
1050632192[10056e380]: ReadNextLine [stream=785d510 nb=291 needmore=0]
1050632192[10056e380]: a04e000:imap.fh-trier.de:NA:CreateNewLineFromSocket: 3 OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE SORT SORT=DISPLAY THREAD=REFERENCES THREAD=REFS MULTIAPPEND UNSELECT IDLE CHILD
REN NAMESPACE UIDPLUS LIST-EXTENDED I18NLEVEL=1 CONDSTORE QRESYNC ESEARCH ESORT SEARCHRES WITHIN CONTEXT=SEARCH LIST-STATUS QUOTA] Logged in
1050632192[10056e380]: login succeeded


Subscribing the folder (does not work):
Code: Select all
1916072320[10056c110]: 133a2000:imap.fh-trier.de:NA:SetupWithUrl: clearing IMAP_CONNECTION_IS_OPEN
1916072320[10056c110]: queuing url:imap://beckerr@imap.fh-trier.de:143/discoverallboxes
1916072320[10056c110]: considering playing queued url:imap://beckerr@imap.fh-trier.de:143/discoverallboxes
1916072320[10056c110]: creating protocol instance to play queued url:imap://beckerr@imap.fh-trier.de:143/discoverallboxes
1916072320[10056c110]: failed creating protocol instance to play queued url:imap://beckerr@imap.fh-trier.de:143/discoverallboxes
438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:ProcessCurrentURL: entering
438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:ProcessCurrentURL:imap://beckerr@imap.fh-trier.de:143/subscribe%3E/AOL-Feedback:  = currentUrl
438833152[119b10e20]: ReadNextLine [stream=1473cd10 nb=107 needmore=0]
438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:CreateNewLineFromSocket: * OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE STARTTLS AUTH=PLAIN] Dovecot ready.
438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:SendData: 1 STARTTLS
438833152[119b10e20]: ReadNextLine [stream=1473cd10 nb=33 needmore=0]
438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:CreateNewLineFromSocket: 1 OK Begin TLS negotiation now.
438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:SendData: 2 capability
438833152[119b10e20]: ReadNextLine [stream=1473cd10 nb=0 needmore=1]
438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:CreateNewLineFromSocket: clearing IMAP_CONNECTION_IS_OPEN - rv = 804b0014
438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:TellThreadToDie: close socket connection
438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:CreateNewLineFromSocket: (null)
438833152[119b10e20]: try to log in
438833152[119b10e20]: IMAP auth: server caps 0x4405425, pref 0x1006, failed 0x0, avail caps 0x1004
438833152[119b10e20]: (GSSAPI = 0x1000000, CRAM = 0x20000, NTLM = 0x100000, MSN =  0x200000, PLAIN = 0x1000, LOGIN = 0x2, old-style IMAP login = 0x4)auth external IMAP login = 0x20000000
438833152[119b10e20]: trying auth method 0x1000
438833152[119b10e20]: login failed entirely
1916072320[10056c110]: creating protocol instance to retry queued url:imap://beckerr@imap.fh-trier.de:143/subscribe>/AOL-Feedback
453513216[119b118d0]: ImapThreadMainLoop entering [this=141db000]
1916072320[10056c110]: retrying  url:imap://beckerr@imap.fh-trier.de:143/subscribe>/AOL-Feedback
1916072320[10056c110]: 141db000:imap.fh-trier.de:NA:SetupWithUrl: clearing IMAP_CONNECTION_IS_OPEN
453513216[119b118d0]: 141db000:imap.fh-trier.de:NA:ProcessCurrentURL: entering
453513216[119b118d0]: 141db000:imap.fh-trier.de:NA:ProcessCurrentURL:imap://beckerr@imap.fh-trier.de:143/subscribe%3E/AOL-Feedback:  = currentUrl
438833152[119b10e20]: ImapThreadMainLoop leaving [this=133a2000]
453513216[119b118d0]: ReadNextLine [stream=1400a610 nb=107 needmore=0]
453513216[119b118d0]: 141db000:imap.fh-trier.de:NA:CreateNewLineFromSocket: * OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE STARTTLS AUTH=PLAIN] Dovecot ready.
453513216[119b118d0]: 141db000:imap.fh-trier.de:NA:SendData: 1 STARTTLS
453513216[119b118d0]: ReadNextLine [stream=1400a610 nb=33 needmore=0]
453513216[119b118d0]: 141db000:imap.fh-trier.de:NA:CreateNewLineFromSocket: 1 OK Begin TLS negotiation now.
453513216[119b118d0]: 141db000:imap.fh-trier.de:NA:SendData: 2 capability
453513216[119b118d0]: ReadNextLine [stream=1400a610 nb=0 needmore=1]
453513216[119b118d0]: 141db000:imap.fh-trier.de:NA:CreateNewLineFromSocket: clearing IMAP_CONNECTION_IS_OPEN - rv = 804b0014
453513216[119b118d0]: 141db000:imap.fh-trier.de:NA:TellThreadToDie: close socket connection
453513216[119b118d0]: 141db000:imap.fh-trier.de:NA:CreateNewLineFromSocket: (null)
453513216[119b118d0]: try to log in
453513216[119b118d0]: IMAP auth: server caps 0x4405425, pref 0x1006, failed 0x0, avail caps 0x1004
453513216[119b118d0]: (GSSAPI = 0x1000000, CRAM = 0x20000, NTLM = 0x100000, MSN =  0x200000, PLAIN = 0x1000, LOGIN = 0x2, old-style IMAP login = 0x4)auth external IMAP login = 0x20000000
453513216[119b118d0]: trying auth method 0x1000
453513216[119b118d0]: login failed entirely
453513216[119b118d0]: 141db000:imap.fh-trier.de:NA:ProcessCurrentURL: aborting queued urls
453513216[119b118d0]: ImapThreadMainLoop leaving [this=141db000]


We are using: Dovecot 1.2.17

Dosc
 
Posts: 3
Joined: October 21st, 2013, 2:07 am

Post Posted October 21st, 2013, 2:11 am

Hi

I updated 5 computers with thunderbird 24 and I got this problem with imap.
So i went back to thunderbird 17.0.9 ESR an now it works properly again.

Dosc

tanstaafl
Moderator

User avatar
 
Posts: 43266
Joined: July 30th, 2003, 5:06 pm

Post Posted October 21st, 2013, 9:58 am

Ralf Becker:

I haven't noticed a bunch of similar threads or a flurry of threads about problems with Dovecot so I'm moving this from Thunderbird Bugs to Thunderbird Support. Does this problem occur with other email providers, or only the servers you are the admin for? (I found some old posts of yours on the Dovecot mailing list.)

Perhaps there is a configuration specific bug with StartTLS support. I searched Bugzilla but didn't spot a relevant bug report. I suggest you add a Gmail IMAP account to one of the PCs and see if it has a similar problem (using SSL/TLS), just for troubleshooting purposes. I have IMAP accounts with seven different email providers but none of them use StartTLS (for IMAP). Do you know of a email provider that provides free IMAP accounts that uses StartTLS?

"Sent messages are not stored in mail folder "send"."
Not every email provider uses "sent", some use "sent items" for example.

Dosc
 
Posts: 3
Joined: October 21st, 2013, 2:07 am

Post Posted October 21st, 2013, 12:13 pm

hmm, i use SSL/TLS. it's a swiss provider (www.genotec.ch)

in a german blog i read about the same problem too.

tanstaafl
Moderator

User avatar
 
Posts: 43266
Joined: July 30th, 2003, 5:06 pm

Post Posted October 21st, 2013, 2:32 pm

Ralf Becker appears to be using StartTLS, not SSL/TLS. The difference is that with StartTLS it initially makes a insecure connection and then upgrades it to a secure (TLS) connection. If you see a TLS negotiation in a IMAP log file that means its using STARTTLS. Just to make it more confusing old versions of Thunderbird used to use ""TLS" to mean "enforce use of STARTTLS to upgrade the connection, and fail if STARTTLS is not supported" and "TLS, if available" to mean "use STARTTLS to upgrade the connection if the server advertises support for it, otherwise just use an insecure connection". "

438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:CreateNewLineFromSocket: * OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE STARTTLS AUTH=PLAIN] Dovecot ready.
438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:SendData: 1 STARTTLS
438833152[119b10e20]: ReadNextLine [stream=1473cd10 nb=33 needmore=0]
438833152[119b10e20]: 133a2000:imap.fh-trier.de:NA:CreateNewLineFromSocket: 1 OK Begin TLS negotiation now.

See https://www.fastmail.fm/help/technology ... rttls.html for some background information.

Dosc:
What are tools -> account settings -> account_name -> server settings -> connection security & authentication method set to?
What port is your IMAP account using?

Dosc
 
Posts: 3
Joined: October 21st, 2013, 2:07 am

Post Posted October 22nd, 2013, 9:28 am

as i wrote: SSL/TLS, normal password, port 993

this helps?

tanstaafl
Moderator

User avatar
 
Posts: 43266
Joined: July 30th, 2003, 5:06 pm

Post Posted October 22nd, 2013, 10:04 am

See http://kb.mozillazine.org/Grey_italic_folders

Perhaps you need to play around with the namespace settings.

demirli
 
Posts: 1
Joined: October 23rd, 2013, 11:08 am

Post Posted October 23rd, 2013, 11:20 am

beckerr.fht wrote:TB 24.0.1 is unable to use existing IMAP mail folder subscriptions or subscribe to new IMAP mail folders.
Already subscribed mail folders are displayed, but their names are grey and using italic font face.


I am having the same problem.

When I un-check "Tools>Account Settings>Server Settings>Advanced>Show only subscribed folders", only then the folders are populated.

I am using SSL/TLS Normal Password 993, in case it matters.

Any help is greatly appreciated.

tanstaafl
Moderator

User avatar
 
Posts: 43266
Joined: July 30th, 2003, 5:06 pm

Post Posted October 23rd, 2013, 1:25 pm

Who is your email provider? Do you know what type of IMAP server they are using?

I currently have IMAP accounts with fastmail.fm, gmail, yahoo, comcast, outlook, inbox, mail, and zoho.

sherringham
 
Posts: 6
Joined: October 24th, 2013, 12:22 am

Post Posted October 24th, 2013, 12:56 am

Hello - I am not sure where to ask this - here, or in :

viewtopic.php?f=39&t=2758679
https://getsatisfaction.com/mozilla_mes ... _lightning

Looking on Bugzilla - there seem to be a number of SSL issues around, some recent. I am not sure if I should open another bug there. This is my issue :

Something seems to have gone wrong with TB's use of SSL/TLS I think (and/or certificate handling). I have been pulling my
hair out about this but have done some tracing.

My setup (considering receiving only) :

Server :

My own domain sherringham.net (Linux, debian oldstable)
IMAP server (dovecot), port 993
Using self-signed cert

Client :

TB 24.0.1
Linux x64 (Debian Testing)

I could receive mail for sherringham.net fine until about a week ago. The break /seems/ to coincide with the 24.0 to 24.0.1 update but I am
not 100% sure.

This all worked up until a week or so ago. IMAP receive and SMTP send, both using :

IMAP - port 993
server : mail.sherringham.net
security - SSL/TLS
auth - normal password

Now, any connect to the IMAP server fails (ignoring send for now) - and the server logs :

2013-10-24 07:43:04 imap-login: Info: Disconnected (no auth attempts): rip=62.3.225.196, lip=85.119.82.212, TLS: SSL_read() failed:
error:14094416:SSL routines:SSL3_READ_BYTES:sslv3 alert certificate unknown

NOTE - "no auth attempts", no username etc.

A normal log is something like :

2013-10-24 08:28:59 imap-login: Info: Login: user=<alastair@sherringham.net>, method=PLAIN, rip=62.3.225.196, lip=85.119.82.212, TLS

Trying a fresh TB install of 24.0 - I cannot complete the server setup at the start - it fails on the test of the account. Error on server as above. TB
does not seem to give any cert errors, or prompt for any cert exception or import etc.

Tracing older versions from :

https://ftp.mozilla.org/pub/mozilla.org ... d/releases

1) 17.0b1 OK
2) 20.0b1 OK
3) 21.0b1 OK
4) 22.0b1 OK
5) 23.0b1 <-- FAIL

I also tried BETA 25.0b1 - with the same error.

I have removed each TB install and re-installed fresh each time. Then tried creating the account fresh.

An "OK" above means I can receive IMAP mail. I am prompted about an error in the cert - it is :

a) self-signed
b) wrong domain (for sherringham.org not sherringham.net)

I "confirm exception" and can read mail OK.

From 23.0b1 - I fail and get NO certificate prompt or notice, just a generic "username or password wrong" message. I also see the IMAP server error log above.

So, I am now using TB 22.0 until I know what's going on.

Testing using :

openssl s_client mail.sherringham.net:993
kmail

is fine - both let me login and see/receive mail.

Thoughts?

Cheer,

Alastair

Ed1
 
Posts: 833
Joined: January 30th, 2005, 2:33 pm

Post Posted October 24th, 2013, 12:01 pm

I also have seen TB lately requesting exception approval of Certificates alleged to be incorrect for my usual mail providers - two of which I have been using for years without such an issue ever arising - AOL, Yahoo and Comcast. These are all IMAP accounts.

sherringham
 
Posts: 6
Joined: October 24th, 2013, 12:22 am

Post Posted October 24th, 2013, 12:18 pm

Ed1 wrote:I also have seen TB lately requesting exception approval of Certificates alleged to be incorrect for my usual mail providers - two of which I have been using for years without such an issue ever arising - AOL, Yahoo and Comcast. These are all IMAP accounts.


Note that my issue is that I am not seeing TB request a certificate "exception" - v22.0 asks but v23.0 does not - and won't connect to the IMAP server, with the server logging "Disconnected (no auth attempts) .." in its log file. If TB pops up a message asking for you to make an exception, it should also be specifying why e.g. cert is self-signed, different domain etc. TB v22.0 does this (I add exception and IMAP mail works) but 23.0 does not and I cannot use it for my email.

Cheers, Alastair

tanstaafl
Moderator

User avatar
 
Posts: 43266
Joined: July 30th, 2003, 5:06 pm

Post Posted October 24th, 2013, 12:38 pm

"SSL3_READ_BYTES:sslv3 alert certificate unknown" sounds like the CA cert for the SSL certificate is unknown. I've found threads for other email clients with the same error string where that was the conclusion. For example, https://groups.google.com/forum/#!topic ... YprpELi7iI . No idea why this doesn't generate a SSL security error popup window.

http://www.iredmail.org/forum/topic3528 ... error.html describes how this also could happen if the email client is required to use StartTLS, and doesn't. With Dovecot that can occur if the following is in dovecot.conf

ssl: required
disable_plaintext_auth: yes

tanstaafl
Moderator

User avatar
 
Posts: 43266
Joined: July 30th, 2003, 5:06 pm

Post Posted October 24th, 2013, 12:42 pm

Ed1 wrote:I also have seen TB lately requesting exception approval of Certificates alleged to be incorrect for my usual mail providers - two of which I have been using for years without such an issue ever arising - AOL, Yahoo and Comcast. These are all IMAP accounts.

I have two Yahoo IMAP accounts and one Comcast IMAP account and have never seen that. The next time it occurs please post details on what certificate it tried to use.

sherringham
 
Posts: 6
Joined: October 24th, 2013, 12:22 am

Post Posted October 24th, 2013, 12:57 pm

tanstaafl wrote:"With Dovecot that can occur if the following is in dovecot.conf

ssl: required
disable_plaintext_auth: yes


Thanks for having a look. I've been all over the web with this and looked at a lot, including the things you mention.

The thing is - this was working OK until a week ago, hence my thought that it was something to do with the 24.0.1 update. I am confused that when I trace back with fresh installs I identified 23.0 as the "break" point though. So 22.0 works, 24.0 doesn't. KMail (KDE) works OK. Using "openssl s_client" works. I've changed nothing on the server, no IMAP or cert change and the certs have not expired.

I obviously don't want to be stuck on TB 22.0 for long so will try and do more digging etc. and look out for solutions. I'd rather not switch or have to use another mail client (I've been using Mozilla mail since the days they did an IRIX client).

Thanks again, Alastair

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot], petergo and 5 guests