MozillaZine

Unable to open attachments

User Help for Mozilla Thunderbird
cbfuk
 
Posts: 2
Joined: October 24th, 2013, 12:51 pm

Post Posted October 24th, 2013, 12:56 pm

Latest upgrade to 24.0.1 has disabled my right-click context menus for attachments - all options are greyed-out. Double-click does not open - nothing happens. The Save button is still present though, and works fortunately, but it's a pain having to save every attachment before I can open it.

This applies to both old and new messages, and I suspect to all types of attachment (I've tried both DOC and PDF files).

Is this a "new" configuration option - seems a weird one?

This on a Windows XP Pro box, btw, latest updates.
Last edited by cbfuk on October 24th, 2013, 6:15 pm, edited 1 time in total.

tanstaafl
Moderator

User avatar
 
Posts: 38941
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted October 24th, 2013, 1:22 pm

See if its due to an add-on by using help -> restart with add-ons disabled.

If that doesn't help try exiting Thunderbird, deleting mimetypes.rdf in the profile, and restarting. That will reset the settings for attachments to default values. Mimetypes.rdf sometimes gets corrupt. If you don't know where your profile is, help -> troubleshooting information -> show folder will open windows explorer at that directory.

http://kb.mozillazine.org/Actions_for_a ... file_types

cbfuk
 
Posts: 2
Joined: October 24th, 2013, 12:51 pm

Post Posted October 24th, 2013, 6:12 pm

Hi, many thanks for that. I wasn't even aware I had any add-ons, haha - till I looked and saw all the crap from MS etc! Anyway, disabled most of them and yep, that fixed the problem. Unfortunately, re-enabling them progressively has failed to replicate the problem - they're all back in, and problem has not resurfaced. So, I can't point the finger at anything specific - maybe it was just a corrupt config file somewhere, as you suggest. At least now I know they're there I can disable most of them again, permanently! Shame it's a common load (as I understand it?) with Firefox, means some like Java and the Adobe reader will have to stay in even though I don't need (or want) them in an email client.
Anyway, grateful thanks again, will remember those tricks in case it happens again.
Cheers
Colin

quewer
 
Posts: 1
Joined: October 25th, 2013, 7:29 am

Post Posted October 25th, 2013, 7:43 am

Hi, I have the same problem, however, nothing helps. I tried to restard Thunderbird with addons off, the same. Then I deleted mimetypes.rdf but the problem is still there.

The dialog window appears, but when I click on "Open" then nothing happens, the program (i.e. Word, Adobe, Excel...) will not start. The button "Save" fortunately works, but it is definitely very annoying to save it before looking at it.

Thx,

Quewer

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 7 guests