MozillaZine

unable to send any messages

User Help for Mozilla Thunderbird
tanstaafl
Moderator

User avatar
 
Posts: 44326
Joined: July 30th, 2003, 5:06 pm

Post Posted May 6th, 2014, 7:11 am

http://help2.talktalk.co.uk/guided-assi ... t-my-email says to use:

Server name: smtp.talktalk.net
Port: 587
Connection Security: None
Authentication method: Normal password

Is that what your smtp server settings are:?

derekpayne
 
Posts: 29
Joined: May 4th, 2014, 10:13 am

Post Posted May 6th, 2014, 9:59 am

Yes just as you have written, its strange because all our pc's started the problem together, just as if Talktalk had blocked me sending email, but apparently not, cant understand it as Pegasus mail works fine.

tanstaafl
Moderator

User avatar
 
Posts: 44326
Joined: July 30th, 2003, 5:06 pm

Post Posted May 6th, 2014, 10:16 am

If you have another account (with a different email provider) use its smtp server instead as a temporary workaround.

derekpayne
 
Posts: 29
Joined: May 4th, 2014, 10:13 am

Post Posted May 6th, 2014, 12:00 pm

My ISP is Talktalk, so surely I have to set all my outgoing messages to their SMTP server to send, even if I had a different email address with another company I would have to set my smtp to talktalk's to send messages?

I am able to use Talktalk's webmail OK and I am able to send messages using Pegasus Mail OK which is strange as it is a Pop3 email client, but I use the Mail merge facility on Thunderbird a lot which is annoying as webmail doesn't have that facility, Pegasus does but I need to learn how to use it.

Cheers

tanstaafl
Moderator

User avatar
 
Posts: 44326
Joined: July 30th, 2003, 5:06 pm

Post Posted May 6th, 2014, 1:39 pm

"My ISP is Talktalk, so surely I have to set all my outgoing messages to their SMTP server to send, even if I had a different email address with another company I would have to set my smtp to talktalk's to send messages?"

No. "The Gmail SMTP server will ignore whatever From: address you supply unless you add it in the Gmail web page at Setting -> Accounts -> "Add another email address". The AOL and AIM SMTP servers won't accept a email address that doesn't match the the screen name used to authenticate when sending. " Those are the only SMTP servers I'm aware of where there is a an issue. The reason it normally works is because you (almost always) provide a username/password to authenticate yourself as a legitimate user of the SMTP server.

http://kb.mozillazine.org/Multiple_SMTP ... hunderbird
http://kb.mozillazine.org/Multiple_iden ... il_account

derekpayne
 
Posts: 29
Joined: May 4th, 2014, 10:13 am

Post Posted May 9th, 2014, 1:19 pm

I have found the solution!!!!!!!!!

I have tried every different setting avoiding entering port 25, trying every other port, just as a last resort, I set the smtp port number to 25 (which is supposed to be blocked by Talktalk for some reason) and everything works again, so why did they change it all of a sudden?

I have been using 587 for ages and now 587 is causing me problems and port 25 is open again.

Anybody else had the same?

Cheers

derekpayne
 
Posts: 29
Joined: May 4th, 2014, 10:13 am

Post Posted May 11th, 2014, 5:41 am

Why is it that all the other email programs I used while I had this problem worked fine on port 587 yet Thunderbird didn't, and its strange that Talktalk have just opened up port 25 where before it was allegedly blocked?

tanstaafl
Moderator

User avatar
 
Posts: 44326
Joined: July 30th, 2003, 5:06 pm

Post Posted May 11th, 2014, 9:01 am

Depends upon the error message. The other email clients might not enforce standards as much. Thunderbird has a history of being fairly strict about whether a connection confirmed to the standard.

Return to Thunderbird Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 6 guests