Email attachments automatically saved to Desktop (Mac)

User Help for Mozilla Thunderbird
Posts: 2
Joined: March 31st, 2015, 1:37 pm

Post Posted March 31st, 2015, 2:03 pm

I've seen this question posted before but can't seem to find a solution. I've been using Thunderbird for about 2 years now and haven't had this problem until very recently. Currently on version 31.5.0 with Firefox 36.0.4 using a MacBook Pro. For some reason, whenever I open an email attachment, it gets automatically saved to my Desktop whether I want it or not. I haven't changed any Preferences and can't find any settings that would allow for this or not. I realize I can change the destination folder of attachments I choose to save, but how I do I stop attachments I don't want to save from being saved? There has to be an explanation for this sudden change in behavior not to mention, a way to fix it. Thanks. ](*,)
Last edited by DanRaisch on March 31st, 2015, 2:25 pm, edited 1 time in total.
Reason: Added (Mac) to subject line.


User avatar
Posts: 1255
Joined: September 5th, 2011, 8:17 am
Location: Paris (not TX)

Post Posted March 31st, 2015, 3:37 pm

1) My preferred solution:
Open TB Preferences -> Attachments -> Incoming.
Choose "Save files to" and hit the "Choose" button.
In the upcoming Finder window select "Macintosh HD", then hit the Shift + Cmd + . (period) keyboard shortcut to show the hidden folders
(N.B. in your Finder window the "List" view must be active, otherwise the keyboard shortcut won't work).
Browse to /private/, select /temp/ and hit "Open".


Now, when you open attachments they will be stored in the hidden temp folder and no longer on your Desktop.
The temp folder will be cleared at each system restart (--> "Recovered files" in the Mac's Trash bin).

2) If you prefer a simple workaround:
open TB Preferences > Advanced > General > Config editor (about:config),
search for "browser.helperApps.deleteTempFileOnExit" and set its value to true.
Now all attachments scattered around on your Desktop will disappear on TB shut down.
Last edited by Eckard on August 4th, 2017, 7:34 am, edited 1 time in total.

Posts: 2
Joined: March 31st, 2015, 1:37 pm

Post Posted April 1st, 2015, 6:05 am

Thanks very much for those workarounds. I'll definitely try both and see which works best for me.

Posts: 7
Joined: December 31st, 2014, 10:43 am

Post Posted August 6th, 2017, 10:46 pm

Thank you...I literally had hundreds piled up on my desktop.

Cleaned them off and by your wonderful guidelines have prevented that from happening again....

That was a longtime mystery - now solved!


User avatar
Posts: 117338
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 7th, 2017, 7:28 am

Glad to hear you found this thread helpful. Locking now as the original thread died more than two years ago. It will still be available for reading but no new posts will be possible.

Return to Thunderbird Support

Who is online

Users browsing this forum: No registered users and 11 guests