MozillaZine

Thunderbird keeps marking my mails as junk

User Help for Mozilla Thunderbird
Mirgogo
 
Posts: 3
Joined: April 4th, 2016, 7:18 am

Post Posted April 4th, 2016, 7:32 am

Hello all,

Starting from 3-4 builds Thunderbird constantly marks my Yahoo mails as junk. They still exist in my mail (not in junk folder) but marked as junk:

http://i.imgur.com/yCY3fqv.png

I mark every email as not been junk and 5 second after that it becomes junk again! And again! I am fighting with this for more than 6 months...No succsess! I tried so many times to change settings, to educate this program but no! Still same issue...
Does anybody have same problem? Any help will be appreciated, I'm just tired to fight with this. And I hate to see emails marked like that!

Thank you!
Last edited by Daifne on April 4th, 2016, 7:38 am, edited 1 time in total.
Reason: removed img tags. Size of image breaking forum format.

DanRaisch
Moderator

User avatar
 
Posts: 117977
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 4th, 2016, 8:06 am

* How is that mail account set up, as POP or IMAP?
* Do you regularly compact your folders? Check http://kb.mozillazine.org/Compacting_folders for more information on compacting folders.
* Do you have TB's built in Junk Mail Controls activated in that profile?

Mirgogo
 
Posts: 3
Joined: April 4th, 2016, 7:18 am

Post Posted April 4th, 2016, 11:09 am

Hi, thanks for the answer!
* I use IMAP
* I compact folders every time TB offers me that.
* Yes, I have JM control set.
The strange thing is that I monitor aroud 9 emails but ONLY Yahoo have such a problem! And not all Yahoo mails, only several specific mails. And I can't find a way to tell TB not to monitor these emails for spam...

DanRaisch
Moderator

User avatar
 
Posts: 117977
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 4th, 2016, 12:07 pm

Turn off the Junk Mail Controls for that account. Tools->Account Settings->Junk Settings.

Mirgogo
 
Posts: 3
Joined: April 4th, 2016, 7:18 am

Post Posted April 5th, 2016, 1:02 am

Ok, done. No effect at all...(
I think TB is not learning anything. Is it possible to be so stupid?
Last edited by DanRaisch on April 5th, 2016, 4:37 am, edited 1 time in total.
Reason: Minor edit for language. Partially obscured just doesn't cut it.

DanRaisch
Moderator

User avatar
 
Posts: 117977
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 5th, 2016, 4:45 am

You can try resetting the training data to eliminate anything in that which might be misleading TB into marking valid messages as Junk. Use menu path Tools->Options->Security->Junk tab->click on "Reset Training Data."

If that doesn't help, try reviewing any messages now in the Junk folder and moving any that you wish to save to a sub-folder of Local Folders. The close Thunderbird.
Backup the Thunderbird profile. Navigate to the Yahoo sub-directory within the ImapMail folder of the profile. Find and delete the files Junk and Junk.msf then restart Thunderbird.

-r0k-
 
Posts: 1
Joined: April 5th, 2016, 7:31 am

Post Posted April 5th, 2016, 7:43 am

Hello. I registered cause i've spent some time today searching for a similar issue. Rather than opening a new thread i guess it's best i ask here.

My question is simple : how do i totally disable the spam filter?
I think i've searched every possible option page both in the main option dialog and each account and unchecked everything with spam in the name, but Thunderbird keeps marking simple all text mails from people in my address book as spam so given how little use i make of the spam filter (i have a large number of custom filters doing a great job of sorting my mails) i'd like to simply turn it off, but it seems like Thunderbird doesn't allow this.
Is there something i can change in the about:config page? (there is a lot of "spam" entries, but only one with a reference to the "bayesian" filter in the name, but it's an integer set to 100000)

Note : i also checked my e-mail provider's settings : their spam filter is disabled.

dalancarter
New Member
 
Posts: 1
Joined: November 13th, 2017, 7:34 am

Post Posted November 13th, 2017, 7:47 am

I've found a solution to this, which I'll post in case you are still having the problem, or other people come to the page (like I did) after searching on the problem. The problem seems to be specific to Yahoo IMAP.

You need to log into Yahoo and mark the message as Not Spam there. If it's in your Inbox, move it to your spam folder, then go to your spam folder and mark it as Not Spam. It will return to your Inbox cleared of its markers and Thunderbird will no longer mark it.

DanRaisch
Moderator

User avatar
 
Posts: 117977
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 13th, 2017, 8:48 am

Thanks for your input on this issue.

Locking this due to the age of the original posts.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 3 guests