MozillaZine

Can't send/receive Gmail. Other accts ok.[SOLVED]

User Help for Mozilla Thunderbird
plonkplonk
 
Posts: 112
Joined: June 8th, 2011, 6:26 pm

Post Posted April 16th, 2016, 9:35 am

When I try to get my Gmail in TB, I get the following message:

"Sending of password for user xxxx@gmail.com did not succeed. Mail server pop.googlemail.com responded: Web login required: https://support.google.com/mail/answer/78754"

I can't send or receive any Gmail. I access 2 other non-gmail accts with TB and they work fine.

This started this morning. I can access Gmail via a browser fine. Ditto my smartphone and iPad. Have reset my Gmail password to no avail. I'm using TB 38.7.2.

Can anyone help?

tanstaafl
Moderator

User avatar
 
Posts: 46700
Joined: July 30th, 2003, 5:06 pm

Post Posted April 16th, 2016, 11:17 pm

Google deliberately prevents users from logging in using "normal password" as the authentication method if their Gmail account is less than 90 days old, as part of their attempt to make more email clients adopt OAuth2. You didn't do anything wrong, they just finally got around to paying attention to your settings.

Either select OAuth2 as the authentication method for the account or select "allow less secure apps access to your account" using http://www.google.com/settings/security/lesssecureapps if you want to keep using "normal password". See http://kb.mozillazine.org/Gmail for more information. Note: that KB article needs to be updated to reflect Thunderbird now supporting OAuth2.

plonkplonk
 
Posts: 112
Joined: June 8th, 2011, 6:26 pm

Post Posted April 17th, 2016, 6:23 am

Thanks! I changed to 0Auth2 for my SMTP server and I can now send outgoing mail.

However, 0Auth2 is not listed as choice for my incoming server settings. I'm using POP. What should I do?

Thanks again for your help.

tanstaafl
Moderator

User avatar
 
Posts: 46700
Joined: July 30th, 2003, 5:06 pm

Post Posted April 17th, 2016, 7:09 am

Select OAuth2 as the authentication method in the POP account's server settings.

plonkplonk
 
Posts: 112
Joined: June 8th, 2011, 6:26 pm

Post Posted April 17th, 2016, 7:48 am

0Auth2 is not among the available choices. I only have encrypted password, TLS, Kerberos and NTLM. No 0Auth2.

tanstaafl
Moderator

User avatar
 
Posts: 46700
Joined: July 30th, 2003, 5:06 pm

Post Posted April 17th, 2016, 12:54 pm

I have normal password, encrypted password, kereberos/gssapi, ntlm, tls certificate and OAuth2 as authentication methods available for my Gmail IMAP accounts. You could enable use less secure apps per my first post if you can't figure out why you have less choices.

Are you using a free Gmail account, a Gmail account provided by your ISP, or "Gmail for business"?

mgagnonlv
 
Posts: 761
Joined: February 12th, 2005, 8:33 pm

Post Posted April 17th, 2016, 4:12 pm

@plonkplonk

You need to have the following settings:

– Security of connection: SSL/TLS
– Authentication method: OAuth2

If the Security of connection (translated from French) is not set to ssl/tls, then you won't see the "OAuth2" choice.

Note: I'm aware that these settings are available for a (new) IMAP connection. Not sure about POP.

Finally, if you configure a NEW account, I notice that the OAuth2 authentication method only appears if you have selected an address@gmail.com. If you have a Google at work account (i.e. some corporate address hosted on a Gmail server, then insert the server names as provided by the account and then the OAuth2 option will appear.
Michel Gagnon
Montréal (Québec, Canada)

plonkplonk
 
Posts: 112
Joined: June 8th, 2011, 6:26 pm

Post Posted April 18th, 2016, 7:01 am

tanstaafl wrote:I have normal password, encrypted password, kereberos/gssapi, ntlm, tls certificate and OAuth2 as authentication methods available for my Gmail IMAP accounts. You could enable use less secure apps per my first post if you can't figure out why you have less choices.

Are you using a free Gmail account, a Gmail account provided by your ISP, or "Gmail for business"?


It sounds like POP pulldown menu does not have the 0Auth2 choice.

Using free Gmail...

Btw, "less secure apps" has been my default choice ever since it was available and I'm still can't retrieve my email...

plonkplonk
 
Posts: 112
Joined: June 8th, 2011, 6:26 pm

Post Posted April 18th, 2016, 7:11 am

mgagnonlv wrote:@plonkplonk

You need to have the following settings:

– Security of connection: SSL/TLS
– Authentication method: OAuth2

If the Security of connection (translated from French) is not set to ssl/tls, then you won't see the "OAuth2" choice.

Note: I'm aware that these settings are available for a (new) IMAP connection. Not sure about POP.


Seems like POP is different...

Thanks for the suggestions tho.

plonkplonk
 
Posts: 112
Joined: June 8th, 2011, 6:26 pm

Post Posted April 22nd, 2016, 5:31 am

Any other suggestions?

plonkplonk
 
Posts: 112
Joined: June 8th, 2011, 6:26 pm

Post Posted April 22nd, 2016, 6:41 am

Problem resolved. I just updated to 45.0 and Gmail works perfectly now.

plonkplonk
 
Posts: 112
Joined: June 8th, 2011, 6:26 pm

Post Posted April 22nd, 2016, 7:31 am

Anyone know how to change the title of my post? Would be nice to tell everyone it's be resolved...

tanstaafl
Moderator

User avatar
 
Posts: 46700
Joined: July 30th, 2003, 5:06 pm

Post Posted April 22nd, 2016, 7:50 am

You should be able to edit it by clicking on the [Edit] button in the upper right corner of the first post in this thread. However, I'll do that for you.

plonkplonk
 
Posts: 112
Joined: June 8th, 2011, 6:26 pm

Post Posted April 22nd, 2016, 10:46 am

TY.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 6 guests