MozillaZine

email account autoconfiguration problem

User Help for Mozilla Thunderbird
annoporci
 
Posts: 3
Joined: May 10th, 2016, 5:07 am

Post Posted May 10th, 2016, 5:30 am

Trying to set up a gmail account on Thunderbird.

1. Go to "Tools" and "Account Settings"

2. Press "Account Actions" weird little drop-down menu on the bottom left window

3. Select Add mail account

4. Fill out: Your name / Email address / Password and press "Continue"

5. "Looking up configuration" message: All good, info correct.

6. Select "IMAP" and "Done"

7. Browser window pops up: "Sign in with your Google Account"

8. Fill out Username and then Password and select "Sign In"

9. Browser goes to

https://accounts.google.com/AccountLoginInfo

then prints message:

Oops! Your browser seems to have cookies disabled. Make sure cookies are enabled or try opening a new browser window.

Back to pop-up window:

Configuration could not be verified -- Is the username or password wrong?

10. ](*,)

Cookies enabled in all my browsers (I assume the browser window is from Firefox, but it's hard to tell as it cannot be resized nor inspected). At the time of setting up, I am logged in successfully into the account in all the browsers : Firefox, Chrome, Opera, in the hope it would help.

In addition, I had to go into the prefs.js to delete information pertaining to previous unsuccessful attempts that were giving met the "incoming server already exists" error message. See, for instance, https://bugzilla.mozilla.org/show_bug.cgi?id=1121151 or google for a dozen or so similar complaints.

I have one other account successfully set up on this Thunderbird. I was not asked to verify the account or anything. This new account is a university account that has its servers with google. Perhaps that's why the extra verification step. Can I set up this account manually? By editing the prefs.js?

DanRaisch
Moderator

User avatar
 
Posts: 117344
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 10th, 2016, 7:47 am

Moving to Thunderbird Support.

You should be able to set up the account manually if you have the information for all of the required server settings.

tanstaafl
Moderator

User avatar
 
Posts: 43117
Joined: July 30th, 2003, 5:06 pm

Post Posted May 10th, 2016, 12:44 pm

You need to have cookies enabled for google.com in your systems default browser for the sign-in for OAuth2 to work. Being able to login to https://mail.google.com/mail/ doesn't prove that .

You could workaround this by selecting "normal password" instead of "OAuth2" in "Secure authentication:" after clicking on https://www.google.com/settings/security/lesssecureapps in a browser and enabling "use less secure apps". Thunderbird isn't actually less secure if you send a normal password over a secure connection instead of using OAuth2, all OAuth2 really does security wise is prevent you from ever looking at the value of your stored password using tools -> options -> security -> passwords. There is a button (forget if its called manual or advanced) in the new account wizard that will let you see and edit all of the settings when you try to add an account.

http://kb.mozillazine.org/Gmail

annoporci
 
Posts: 3
Joined: May 10th, 2016, 5:07 am

Post Posted May 10th, 2016, 10:45 pm

Thank you tanstaafl and DanRaisch.

As I said, COOKIES ARE ENABLED in all my browsers, checked and double checked. Perhaps the bug is with Firefox "cookie enabled" communication with Thunderbird?

tanstaafl's suggestion to use "normal password" worked. Thanks a lot!

annoporci
 
Posts: 3
Joined: May 10th, 2016, 5:07 am

Post Posted June 6th, 2016, 11:13 pm

Since this problem is not going away and the google took me here once more, here for reference what to input for a gmail account:

Your name: Some Name
Email address: username@gmail.com

IMAP
Type: IMAP
Server Name: imap.gmail.com
Port: 993
Secure connection: SSL/TLS
Secure authentication: Normal password
User Name: username@gmail.com

SMTP

Server Name: smtp.gmail.com
Port: 587
Secure connection: STARTTLS
Secure authentication: Normal password
Username: username@gmail.com

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot], tanstaafl and 9 guests