MozillaZine

My from address chosen by the person I'm replying to domain

User Help for Mozilla Thunderbird
astrojetson
 
Posts: 2
Joined: May 25th, 2016, 5:33 am

Post Posted May 25th, 2016, 5:53 am

This is a little complicated. I have three identities set up in Thunderbird: astro@mydomain.com astro@example.com astro@googlelikecompany.net

In the defaults I have it set up so the from address is astro@mydomain.com, when I compose a message, the from field is correct (astro@mydomain.com). The other two identity choices are in the drop down box and I can select them.

If I respond to person@theirdomain.net, the from address is astro@mydomain.com -- what I want
If I respond to person@someotherdomaintheyuse.com, the from address is astro@domain.com -- what I want
If I respond to person@example.com, the from address is astro@example.com -- no, use the default unless I change
If I respond to person@googlelikecompany.net, the from address is astro@googlelikecompany.net -- no, use the default unless I change

It looks like Thunderbird is saying "If the domain I'm sending to matches one of the domains in the identity list, then use that identity, not the default.

Same thing happens when replying to a list of people, if one of them has a domain that matches one of my identities, it uses that identity.

Same things happens when I reply to a message in my sent box, even if I've used the default domain Astro@mydomain.com as the from address.

I've searched in the bug base and this forum, I've not been able to find this same case.

Thanks for your help!
Astro

(Edited to change accounts to identities, identity is the right word)

tanstaafl
Moderator

User avatar
 
Posts: 44054
Joined: July 30th, 2003, 5:06 pm

Post Posted May 25th, 2016, 11:13 pm

"When you write a new message, Thunderbird uses the default identity for the account you are working in. When you reply to a message, Thunderbird uses the identity that matches the address the message was originally sent to, if it can find a match in the account you are working in. Otherwise it uses the default identity. Set mailnews.reply_to_self_check_all_ident to true using the Config editor if you want it to check the identities for all accounts when replying."

My experience is that its not enough to set that setting true, you need to define each accounts email address as a multiple identity in each account to guarantee things work correctly. In some versions if you don't do that it lets you select the desired From: address but its not actually used. In other versions it works as expected.

You list the senders email address and what Thunderbird defaulted to, but don't mention what email address the message (that you are replying to) was sent to, so its unclear if its not working correctly. I haven't read anywhere that its supposed to choose a best match based on just the senders domain, though that doesn't seem unreasonable.

I suggest you see if the same problem occurs if you temporarily disable all add-ons via "help -> restart with add-ons disabled".

tanstaafl
Moderator

User avatar
 
Posts: 44054
Joined: July 30th, 2003, 5:06 pm

Post Posted May 25th, 2016, 11:15 pm

Moved from Thunderbird Bugs to Thunderbird Support as this thread isn't discussing workarounds to a confirmed bug reported in Mozilla Bugzilla.

astrojetson
 
Posts: 2
Joined: May 25th, 2016, 5:33 am

Post Posted May 26th, 2016, 7:30 am

In the example cases above the reply was sent to astro@mydomain.com, or in the case of replying to a message from the sent folder, the message was from astro@mydomain.com.

You wrote "When you reply to a message, Thunderbird uses the identity that matches the address the message was originally sent to, if it can find a match in the account you are working in". It's not, it's a message From:person@example.com To:Astro@mydomain.com and when the reply is done (or a reply out of the sent box) it becomes To:person@example.com From:Astro@example.com

And it's not an account, it's an identity, just to be clear (since they seem to be different, and I'm using an identity)

The attribute mailnews.reply_to_self_check_all_ident didn't make any difference.

I don't have any plugins, but I restarted as requested and have the same results.

Thank you for your help

mgagnonlv
 
Posts: 673
Joined: February 12th, 2005, 8:33 pm

Post Posted June 1st, 2016, 2:39 pm

Hello,

I'm not sure what is the problem. Assuming you have three identities, Thunderbird will try to use one of these identities every time it matches what the sender has used. That way, you can have a full conversation with a secondary identity like "astro@googlelikecompany.net".


If you want to revert to your main identity, you have a few ways:

1. If it's only once in a while, then change the identity manually before you reply to a message. IOW, in the "from" field, chose your main identity; it will then come from "astro@mydomain.com" and will use the proper identity.

2. If you want to gently veer away people from the second identity, then configure it with a "reply-to" addess. The "astro@googlelikecompany.net" would have "reply-to: astro@mydomain.com"

3. For a permanent change, erase the other identity. Then all replies will use the email address and signature associated with "astro@mydomain.com".
(Because it seems to be an alias (i.e. an identity), you will still receive mail sent at "astro@googlelikecompany.net").

********************

If you just want a single email address but two different signatures, then you could have two identities that would be identical, except for the signature. Beware, however, that the main identity is always the one that will automatically be selected.
Michel Gagnon
Montréal (Québec, Canada)

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 6 guests