MozillaZine

Extreme fast (overenthusiastic) scrolling

User Help for Mozilla Thunderbird
belet
 
Posts: 3
Joined: February 7th, 2017, 2:09 pm

Post Posted February 7th, 2017, 2:25 pm

Hey there, my first post. I couldn't find anything about this here or in other Thunderbird forums, but also other people seem to have the same issue: https://brodiesnotes.blogspot.de/2017/0 ... litch.html

I am using a new Lenovo Ideapad, Win 10, Thunderbird 45.7, ELAN Touchpad 11.4.88.2, newest driver.

Issue:
- first: Inertial-scrolling does not work (while in ohter programs it does work). When clicking into an area, I can scroll, hovering the mouse over an area doesn't change the scrolling to this area, I am still scrolling where I was before.
- second: the scrolling is superfast. I can't control it. Especially in the folder menu on the left it jumps from the top to the bottom within one gentle touch on my touchpad.

Any ideas what could cause or solve this problem?

tanstaafl
Moderator

User avatar
 
Posts: 44226
Joined: July 30th, 2003, 5:06 pm

Post Posted February 8th, 2017, 10:37 am

1. Are you talking about inertial scrolling in a multi-touch trackpad or a mouse or both?

Try disabling graphics hardware acceleration by setting gfx.direct2d.disabled true and layers.acceleration.disabled true using the config editor in tools -> options -> advanced -> general, and restarting Thunderbird. Recent versions disable it by default but if you've upgraded it can depend upon what version you first installed. (It was enabled in version 5, disabled in version 9, re-enabled in version 31 and disabled in 38.3.0) You can confirm its disabled by looking near the bottom of help -> troubleshooting information. I've found Firefox threads about scrolling glitches occurring with the touchpad until graphics hardware acceleration was disabled.

See if the problem occurs when running Thunderbird in safe mode (not to be confused with windows safe mode). I've found Firefox threads where the LastPass add-on for example caused problems with touchpad scrolling.

I haven't found any threads (other than yours) about Thunderbird problems with inertial scrolling.

I suggest you find out what each of the windows registry keys for the Elan Touchpad does. I know some can be used to disable inertial scrolling so perhaps some control how fast it scrolls or how sensitive it is etc.

Some laptops support replacing the Elan touchpad driver with one by Synaptics. I don't know about yours.

2. Have you experimented with changing the repeat rate settings in the mouse control panel?

tanstaafl
Moderator

User avatar
 
Posts: 44226
Joined: July 30th, 2003, 5:06 pm

Post Posted February 8th, 2017, 10:39 am

Moved from Thunderbird Bugs to Thunderbird Support as you are not discussing workarounds to a confirmed bug report in the Mozilla Bugzilla database. More people will also read your thread there.

belet
 
Posts: 3
Joined: February 7th, 2017, 2:09 pm

Post Posted February 8th, 2017, 12:36 pm

First of all: Thank you so much for your help! I really appreciate that.

tanstaafl wrote:1. Are you talking about inertial scrolling in a multi-touch trackpad or a mouse or both?
I am using the touchpad of my laptop. Didn't have a mouse yet to try, but I will do so and report later.

tanstaafl wrote:Try disabling graphics hardware acceleration by setting gfx.direct2d.disabled true and layers.acceleration.disabled true using the config editor in tools -> options -> advanced -> general, and restarting Thunderbird. Recent versions disable it by default but if you've upgraded it can depend upon what version you first installed. (It was enabled in version 5, disabled in version 9, re-enabled in version 31 and disabled in 38.3.0) You can confirm its disabled by looking near the bottom of help -> troubleshooting information. I've found Firefox threads about scrolling glitches occurring with the touchpad until graphics hardware acceleration was disabled.
All settings were already like you quoted.

tanstaafl wrote:See if the problem occurs when running Thunderbird in safe mode (not to be confused with windows safe mode). I've found Firefox threads where the LastPass add-on for example caused problems with touchpad scrolling.
This didn't help.
tanstaafl wrote:I haven't found any threads (other than yours) about Thunderbird problems with inertial scrolling.

I suggest you find out what each of the windows registry keys for the Elan Touchpad does. I know some can be used to disable inertial scrolling so perhaps some control how fast it scrolls or how sensitive it is etc.
I can set both (disable inertial scrolling and its sensitivity) in the controls / mouse settings of ELAN. It changes the sensitivity and speed in other apps (e.g. firefox) but in thunderbird it doesn't help. I found out that also in my spotify app it seems to be the same problem, so most probably it's not a thunderbird problem...

tanstaafl wrote:Some laptops support replacing the Elan touchpad driver with one by Synaptics. I don't know about yours.
hmmm, sounds a bit to difficult for me.
tanstaafl wrote:2. Have you experimented with changing the repeat rate settings in the mouse control panel?

Yes, it doesn't help.

So thanks again for your help and ideas!

if these glitches occur to anyone else. I would be happy to hear from you!

belet
 
Posts: 3
Joined: February 7th, 2017, 2:09 pm

Post Posted February 8th, 2017, 12:54 pm

Yeah!

I love the internet (we'll see if i state the same after the presidency of D.T.)!

Reddit saved my life: https://www.reddit.com/r/techsupport/comments/3lhmhq/win10_elan_touchpad_scrolling_issues/


reddit wrote: Open regedit.exe using run

Go to HKEY_CURRENT_USER -> SOFTWARE -> Elantech -> Smartpad

Change ScrollControl_Mode from 0 to 1

Open the elan software and click apply just to make sure the settings get applied



It works now in Spotify as well as in Thunderbird. Still a bit too fast, but i will handle it with the controls.

Thanks again tastaafi!

tanstaafl
Moderator

User avatar
 
Posts: 44226
Joined: July 30th, 2003, 5:06 pm

Post Posted February 8th, 2017, 12:57 pm

Glad you found a workaround. I was just about to post the following when I saw your post. I'll post it anyways in case it helps somebody else.

I found your bug report at https://bugzilla.mozilla.org/show_bug.cgi?id=1337524 . There is a core widget::win32 bug report at https://bugzilla.mozilla.org/show_bug.cgi?id=1199737 about " Inertial scrolling with a trackpad can zoom the webpage on Windows". One of the comments mentioned "this bug is about *momentum* scroll events causing zooming. The offending zooms happen after the fingers have already left the touchpad" .

It also has a link to https://bugzilla.mozilla.org/show_bug.cgi?id=767197 " Linux/GTK: pressing ctrl button after releasing from two finger scroll causes page zoom" . One of the comments was "Workaround: Go to about:config and set mousewheel.with_control.action to 1."

https://wiki.mozilla.org/Gecko:Mouse_Wheel_Scrolling says for mousewheel.with_control.action: "Customizing default action of "wheel" event. The value 0 means "Do nothing", 1 means "Scroll contents", 2 means "Go back or forward in the history", 3 means "Zoom in or out the contents". You cannot specify different action to vertical wheel operation and horizontal wheel operation because both deltaX and deltaY values can be non-zero same time. So, specifying different action doesn't make sense. "

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 2 guests