MozillaZine

Identity shows up as "me" for all accounts

User Help for Mozilla Thunderbird
mafitzsi
 
Posts: 7
Joined: November 12th, 2009, 7:10 pm

Post Posted March 20th, 2017, 7:15 pm

I have three different email addresses which are delivered in three different folders, but when I search for emails in one of these folders, ALL THREE email addresses show up as "me" in any search window or the "from" column. This is obviously very confusing and problematic. I can't find any way to change this so that the email address is explicitly listed separately and none of them show up as "me" . This is a new 'feature' which never occurred in previous installations I had of Thunderbird, and I don't know why it is happening. I used to be able to search for my various email addresses or sort inboxes by "from" and they'd show up in alphabetical order. now all of them just show up as "me".

DanRaisch
Moderator

User avatar
 
Posts: 115490
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted March 20th, 2017, 7:42 pm

Are you using the Global Search function in this situation?

mafitzsi
 
Posts: 7
Joined: November 12th, 2009, 7:10 pm

Post Posted March 20th, 2017, 8:54 pm

It's not just related to any "search" function, and more universal than that. It is the way the emails are displayed in the "correspondents" column, the "Recipients" column, and the To: and From: fields in the headers, regardless of whether I have searched or used filters. When I search for an email address, the results are correct, but the emails are displayed as "Me" or "me" in the Correspondents and Recipients column, but in the Correspondents column, they are never capitalized (always "me") but are mixed (not alphabetical) when you look at the "From" field in the header of each email. For example, the first email header shows "from: me<email#1>" (bracketed part shows up when you hover), the next is "from: Me<email#2>" and later on will be others "from: me<email#1>" or "From: Me<email#3>"

but ALL of them show up as "me" uncapitalized in the "correspondents" column. This is true looking at inbox, sent, drafts, and in search results windows or any folder in which I have stored emails.

I don't want ANY of them to show up as "me" or "Me" ever in any circumstance or window. I just want the explicit email address or name associated with that email address. And to be perfectly clear, I have not given the name "Me" or "me" to ANY of my email addresses, they all have other names which do not show up in the "Correspondents" column. In previous versions of Thunderbird that was not the case. I would find my three email addresses properly alphabetized.

mafitzsi
 
Posts: 7
Joined: November 12th, 2009, 7:10 pm

Post Posted March 20th, 2017, 8:56 pm

I will also say that I do not have these three emails being delivered to one "local" inbox. Each has their own set of inbox, drafts, sent, etc.

DanRaisch
Moderator

User avatar
 
Posts: 115490
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted March 21st, 2017, 6:20 am

Make sure that you have unchecked "Show only display name for people in my address book" using menu path Tools->Options->Display->Advanced. See if that changes what is shown.

mafitzsi
 
Posts: 7
Joined: November 12th, 2009, 7:10 pm

Post Posted March 21st, 2017, 8:56 am

That is amazing. The checkbox works exactly the opposite of what you'd think. Thank you! Now how do you report a bug? The mozilla help pages no longer accept questions.

DanRaisch
Moderator

User avatar
 
Posts: 115490
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted March 21st, 2017, 9:01 am

What bug do you wish to report?

mafitzsi
 
Posts: 7
Joined: November 12th, 2009, 7:10 pm

Post Posted March 21st, 2017, 10:03 am

I spoke too soon. It fixes only some stored emails. Still an issue, but I solved it:
Step 1 uncheck the box "Show only display name for people in my address book" using menu path Tools->Options->Display->Advanced.
1.5 scroll through some emails and find problem not completely fixed
Step 2 re-check the box "Show only display name for people in my address book" using menu path Tools->Options->Display->Advanced.
Step 3 open each of the problem email addresses in address book and check the box "always prefer display name over message header"

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 6 guests