MozillaZine

Thunderbird has block a file from loading into this message.

User Help for Mozilla Thunderbird
KleenaWildaHase
 
Posts: 1
Joined: May 5th, 2017, 1:18 am

Post Posted May 5th, 2017, 1:32 am

Hello,

I've got the same problem using the add-on stationery.

For me, I've found out a workarround for it:
- set mail.compose.attach_http_images to true
- install a tiny webserver eg. http://www.aidex.de/software/webserver/download.html (it only has to serve http://) on your local pc (or in local network)
- put the images in the root folder of the server
- change your template files from src="file:///c:/template/file1.png" to "http://127.0.0.1:81/file1.png"

127.0.0.1 is the localhost
81 is the port, which the server is listen to

Important: the little webserver has to be running, if you want to mail including files

It's not the best solution, but it works for me. Hopefully, that behavior of TB has changed in next version.

Best regards,
KleenaWildaHase

Layne
 
Posts: 7
Joined: June 21st, 2004, 7:45 pm
Location: Canada

Post Posted May 5th, 2017, 1:17 pm

tanstaafl wrote:>Surely this is a bug?

Possibly, since 4 people have reported it in the two threads that I'm aware of. But I can't duplicate it. We need to figure out whats it dependent upon before somebody writes a bug report or it will probably just get closed/ignored.

I suggest you see if this problem occurs if you disable the signature, and just embed images in the message body. The two problems may be unrelated.


Images are no problem using the Image button. I can create a message and signature (text only), and load the same images into my signature that TB refuses to let me load using Quicktext.

Images are also no problem with email I receive containing images.

Layne
 
Posts: 7
Joined: June 21st, 2004, 7:45 pm
Location: Canada

Post Posted May 5th, 2017, 1:20 pm

P.S. If I copy the signature code from Quicktext into the signature text box under Account Settings, everything works as it's supposed to work. The signature shows up complete with images and they are not blocked.

Layne
 
Posts: 7
Joined: June 21st, 2004, 7:45 pm
Location: Canada

Post Posted May 5th, 2017, 1:29 pm

P.S. again. I just stored the same text in an html file on my computer and told TB to "Attach the signature from a file instead (text, HTML, or image):". It worked just fine.

Could it be something with how TB and Quicktext get along. Maybe we should send them to bed without dessert.

judgesinel
New Member
 
Posts: 1
Joined: January 12th, 2015, 12:19 am

Post Posted May 7th, 2017, 8:49 am

I'm having the same issue using the stationery add on to add a "picture" to my email being sent.

j.marty
 
Posts: 1
Joined: May 10th, 2017, 3:30 pm

Post Posted May 10th, 2017, 3:36 pm

That problem happens to me after version 52.

The way I resolve that was making all references to image files as follow:

file://C:/(directory of images)/(name of file)

You could replace C: by some other drive where de images files are.

If you have less than 2 slashes after "file:" thunderbird blocks file, as now it must have image files as URI,
so "file://" is the equivalent of "http://".

Hope it could resolve yours problems.

akankshajoshi
 
Posts: 1
Joined: May 17th, 2017, 11:17 pm

Post Posted May 17th, 2017, 11:29 pm

I had the same problem, but it got sorted out - just follow the following steps:
1. Copy your signature from any old mail into a new empty email
2. Go to Files -> Save As -> File...
3. Save it up on your desktop. (It will get saved in .html format)
4. Go to the file you just saved - right click on it
5. Open with -> Gedit or writer
6. Copy the whole code
7. Open Thunderbird, go to Edit -> Account Settings
8. Paste the code in Signature Text and save it

Tadaaa, you'll have your signature with all the pictures in it

PhxChris
 
Posts: 2
Joined: May 19th, 2017, 11:57 am

Post Posted May 19th, 2017, 2:48 pm

Added a bug report asking that we get the option to do a permanent unblock of individual files: https://bugzilla.mozilla.org/show_bug.cgi?id=1366349

See what happens.

Nachum
New Member
 
Posts: 1
Joined: May 22nd, 2017, 2:23 am

Post Posted May 22nd, 2017, 3:33 am

I have the same issue.

The solution offered by akankshajoshi is nice, but maybe be considered as a workaround. This is not a solution.
I have some more issues, for a long time with signature using tables, that their definition changes sometimes.
I will issue a bug report soon.

Nachum

tanstaafl
Moderator

User avatar
 
Posts: 42805
Joined: July 30th, 2003, 5:06 pm

Post Posted May 22nd, 2017, 12:10 pm


PhxChris
 
Posts: 2
Joined: May 19th, 2017, 11:57 am

Post Posted May 22nd, 2017, 12:14 pm

A good place to create Base64 type image tags is http://base64.wutils.com/encoding-onlin ... to-base64/

The guys at Mozilla are looking at the possibility fixing QuickText themselves -- see last comments in https://bugzilla.mozilla.org/show_bug.cgi?id=1366349

If you know who is currently maintaining the QuickText code, point them to the bugzilla page.

pandufa
New Member
 
Posts: 1
Joined: May 24th, 2017, 11:41 am

Post Posted May 24th, 2017, 11:47 am

I have been having the same problem. Changing the backslash "\" to slash "/" after "file:" in the path of the image made the message disappear.
I.e., I simply changed this:

file:\\\C:

to

file:///C:

That made the trick.

Steve L
 
Posts: 1
Joined: May 30th, 2017, 7:49 am

Post Posted May 30th, 2017, 7:55 am

We too are having this problem with Quicktext. It is preventing me from updating my users. I had the file:///C: setting previously set.

Thank you,
Steve

beretgascon
 
Posts: 4
Joined: March 31st, 2010, 2:20 am

Post Posted June 8th, 2017, 2:15 am

Hello,

I too can report that since a recent update, all images included in all signature files using "Quicktext" are blocked. This function has always worked, and I have changed nothing in a few years.

In the "Quicktext" add-on signature editor, they appear as:
Code: Select all
<img src="file:///D:/Data%20Files/EmailFooter.jpg">


As seen using the "Stationery" add-on, in Edit mode, they appear as follows:
Code: Select all
<img src="file:///D:/Data%20Files/EmailFooter.jpg">


I have set mail.compose.attach_http_images to true, but this changes nothing.

I agree with other posters on this and other forum threads that this is an unnecessary and highly annoying distraction in our email. Whether it is a bug or not isn't clear as this may simply be an over-zealous application of Block Remote Images but, since these are not remote images, it would be good to have it back the way it worked before.

Setting up a (small) local web server to solve this was a smart "thinking out of the box" solution but, for the vast majority of TB users is neither practical nor, in many cases, authorised by IT policy. People not versed in the security implications of running a web server shouldn't be setting up a web server on their main PC - it's just bad practice. I run a couple of CentOS as well as an Ubuntu server but I'm not going down that road on my PC workstation.

If somebody could bring this highly annoying item to the attention of the developers so that it could be resolved in the next update, that would suit most people, I imagine.

rgrun1

User avatar
 
Posts: 18
Joined: September 25th, 2004, 8:31 am

Post Posted June 23rd, 2017, 12:15 pm

I save a lot of graphics as drafts and have them scheduled. If I go to edit one, the graphics are often gone (not always!) and I have to approve them one at a time to get them to load back into the message. I have on rare occasions (as in 10 minutes ago) tried to click the links to allow the messages and only got placeholder boxes

It is a bug and it is annoying. There should be a way to shut off this behavior if you are not in an environment that needs it (whatever that may be)
Thanks!
Rick Grunwald
http://grunwalds.com
XP home SP2, Celeron 2gb 384 RAM, Zone Alarm pro, Kaspersky AV

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 4 guests