MozillaZine

What's With the Mail Toolbar?

User Help for Mozilla Thunderbird
JamesJoey

User avatar
 
Posts: 81
Joined: September 2nd, 2011, 6:22 am

Post Posted May 16th, 2017, 8:12 am

I can't seem to keep the Mail Toolbar items to stay on the left side.
Well, most are left aligned but I can't seem to get the Them and Font Changes item to stay on the left side.
I drag it over but when I reopen Thunderbird it's back on the right side.

Any ideas?
James

DanRaisch
Moderator

User avatar
 
Posts: 117797
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 16th, 2017, 2:35 pm

Does the same thing occur if you launch the application in Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode

JamesJoey

User avatar
 
Posts: 81
Joined: September 2nd, 2011, 6:22 am

Post Posted May 16th, 2017, 3:19 pm

I had to restore a disk imager today. (not because of this issue)
But, the mail toolbar in this Thunderbird installation is fine.

If it happens again I'll start in safe mode.

Thanks,
James

genestoy
 
Posts: 21
Joined: September 27th, 2004, 6:44 am

Post Posted May 18th, 2017, 3:48 pm

Just got an update to Thunderbird and same thing happening to me all mail toolbar icons/buttons are now to the right of the toolbar and the search bar has now disapeared beyond the edge. Started in safe mode and all the icons were back on the left side. Went back and disabled the only two add-ons I have installed and the icons are still on the right?
Anybody know why this is happening or how to fix it?
Thanks

DanRaisch
Moderator

User avatar
 
Posts: 117797
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 18th, 2017, 4:08 pm

If Safe Mode restores the intended layout, see if switching off Hardware Acceleration is helpful in standard mode. That's menu path Tools->Options->Advanced->General->uncheck "Use hardware acceleration...."

genestoy
 
Posts: 21
Joined: September 27th, 2004, 6:44 am

Post Posted May 18th, 2017, 4:21 pm

Was already off and I enabled it and then disable it - no change

DanRaisch
Moderator

User avatar
 
Posts: 117797
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 18th, 2017, 4:25 pm

Sorry. Didn't really expect that to work but disabling HA is one of the things done in Safe Mode so I thought it worth a shot.

genestoy
 
Posts: 21
Joined: September 27th, 2004, 6:44 am

Post Posted May 18th, 2017, 5:50 pm

I rolled T-Bird back to the last version and all is well, so it definitely has a bug

MSPMSP
 
Posts: 2
Joined: December 2nd, 2005, 2:19 pm

Post Posted May 19th, 2017, 3:44 am

I had the same problem when I updated this morning. I tried to sort it out in customise mode by dragging the misplaced buttons back to the left, but this did not work.

In the end, still in customise mode, I did "Restore Default Set". This moved the tool bar back to the left, but removed most of the useful buttons like "Reply", "Reply All", "Delete" and "Junk" etc, and included lots of other unwanted stuff. However, after sorting all that out it is now fine.

Still seems like a bug though.

As a slightly off topic aside, but related to my experience this morning, when Thunderbird displayed its update available dialogue, I clicked on the "more information" link. The page that linked to only showed information about bug fixes, no mention of UI or functionality changes. Those were only mentioned on the page displayed after the update! As someone who avoids any updates that might contain "deal breakers", e.g. the infamous "tabs on top" mode, I think all information about UI and functionality changes should be mentioned upfront, not just bug fixes.

wsmwk
 
Posts: 2393
Joined: December 7th, 2004, 6:52 am

Post Posted May 19th, 2017, 5:16 am

JamesJoey wrote:I can't seem to keep the Mail Toolbar items to stay on the left side.
Well, most are left aligned but I can't seem to get the Them and Font Changes item to stay on the left side.
I drag it over but when I reopen Thunderbird it's back on the right side.
James

Sounds like the same issue we expect to have fixed in next beta. It should also appear in a future update, but unclear how soon that will be. To get the fix earlier you might try the beta from http://www.mozilla.org/en-US/thunderbird/channel/

P38Usul
 
Posts: 23
Joined: November 18th, 2014, 9:00 am

Post Posted May 19th, 2017, 8:22 am

genestoy wrote:I rolled T-Bird back to the last version and all is well, so it definitely has a bug



Is there an easy way to do this?
I am having the same icon problem

TIA

Greg

jwayne
 
Posts: 132
Joined: July 20th, 2003, 6:50 am

Post Posted May 22nd, 2017, 7:34 am

Same thing happened with me. Uninstalled and went back to 52.1.0 but same thing - mail toolbar is "right justified". I guess I was using an even earlier version but don't feel like spending the time testing earlier ones until things look proper again. Hope this will soon get fixed in an update.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 7 guests