MozillaZine

text encoding

User Help for Mozilla Thunderbird
emaharg
 
Posts: 240
Joined: March 1st, 2005, 2:04 pm
Location: spain

Post Posted May 17th, 2017, 1:44 pm

for some reason, I just cannot understand the help pages on how to set the text encoding..in my emails inbox many emails arrive with strtange characters, and ehen I go to View text encoding and set it to Western all becomes clear - but the default is continuously Unicode.
I have been to Tools / options / display /formatting / advanced and set outgoing and incoming mail to Western-122 (whatever that means) but still those "unicode" messages keep appearing which need correcting to Western.
runs Chrome 59, Thunderbird 52 32bit, Windows 7 (64bit), uses TB with POP not IMAP

DanRaisch
Moderator

User avatar
 
Posts: 116408
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 17th, 2017, 1:48 pm


emaharg
 
Posts: 240
Joined: March 1st, 2005, 2:04 pm
Location: spain

Post Posted May 17th, 2017, 11:46 pm

I have explored that, thanks. it doesnt meet my poroblem, which I probably explained incorrectly.
What is happening I now see, is that TB is correctly displaying the majority of incoming message which have text encoding unicode.
Occasionally an email arrives in which many non standard characters (especially ampersands, £ signs $signs etc) look garbled: and for those messages, if I change the text encoding (using the View / Text encoding from the menu bar - and then choose western) they show correctly.
In other words it is as if TB is not able to correctly detect and then apply the relevant text encoding for a particular mail. Perhaps this is a problem with the senders email program and not mine?
runs Chrome 59, Thunderbird 52 32bit, Windows 7 (64bit), uses TB with POP not IMAP

emaharg
 
Posts: 240
Joined: March 1st, 2005, 2:04 pm
Location: spain

Post Posted May 29th, 2017, 3:51 am

I don't think this problem I have is solved..
if I see a message with some strange characters, the British pounds and US dollar signs are a certain indication, coming up as various odd hieroglyphs - then I go to View Text encoding and switch it from unicode to western. That sorts the problem.
But when I then print the message, it seems in printing to revert to the previous encoding.
I am not sure I EVER need "unicode" - can I just eliminate it and so everything is forced to show as Western?
runs Chrome 59, Thunderbird 52 32bit, Windows 7 (64bit), uses TB with POP not IMAP

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 9 guests