"Invalid UID Fetch attribute XSENDER"

User Help for Mozilla Thunderbird
Posts: 11
Joined: August 4th, 2017, 9:14 am

Post Posted August 4th, 2017, 9:20 am

This morning, cannot get emails from Apple iCloud accounts. Changes must be on their side, and I can access mail through their web client. Configured IMAP.

Any thoughts on whether this is a bug on the t-bird side, or is there something I can reconfigure to get things working again?


Posts: 11
Joined: August 4th, 2017, 9:14 am

Post Posted August 4th, 2017, 10:06 am

This bug filed a year ago seems the most on point ... but I don't know the IMAP protocol well enough to understand if it's really a server config issue or a tbird client issue

Posts: 1
Joined: August 5th, 2017, 1:52 am

Post Posted August 5th, 2017, 1:55 am

I've got the same problem.

Posts: 11
Joined: August 4th, 2017, 9:14 am

Post Posted August 5th, 2017, 3:51 am

Just downloaded Opera email client, configured it for my Apple account, and it fetches mail and I can access it fine. Downloaded Thunderbird to a different PC, confirmed problem remains with Thunderbird. I think Apple is changing protocols, and it's breaking Thunderbird. Can anyone who understands how IMAP client-server negotiation works suggest how to proceed debugging it? Thanks!

Posts: 3
Joined: August 6th, 2017, 12:27 pm

Post Posted August 6th, 2017, 12:37 pm

Hmm, where did my reply go? Anyway I can obviously receive emails and mark them as read although I cannot fetch the contents of the messages....

(My earlier reply that did not show up was also thanking fred9999 that he confirmed the issue on another PC and sadly neither am I knowledgeable enough to troubleshoot IMAP but if anyone have any pointers I be happy to help debugging on my computer...)

Posts: 1
Joined: August 7th, 2017, 12:43 am

Post Posted August 7th, 2017, 12:51 am

Also reporting the same problem.


User avatar
Posts: 6
Joined: August 7th, 2017, 7:34 am
Location: Boston

Post Posted August 7th, 2017, 7:40 am

I wonder if they've changed the port settings and haven't updated the documentation ( I don't know much about IMAP either and am not sure if that would cause this error. Other email software might not work also were this the case but I thought I'd throw that idea out there. I'm using Thunderbird on a Mac.

Posts: 11
Joined: August 4th, 2017, 9:14 am

Post Posted August 7th, 2017, 12:20 pm

I've been conversing with Apple support on this topic, we'll see what happens. My overall sense from a light reading of the protocol is that the iCloud server is saying "hey, I support these protocols", Thunderbird is saying "cool, let me try this one", and then Apple responds "nuh uh. not gonna do it".

Apple support walked me through what they thought port settings were, and this doesn't appear to have changed.

hey, mh_76, if you see this: what version of tbird are you running on Mac, and are you seeing this issue there? What servers / ports / parameters does yours use? If you can post your incoming/outgoing settings, that may be a help if it's different than what we're using on the win side.

BTW: on a lark, I tried "repair folder" on one of my larger folders. don't do that. that just exacerbates the current problem in that it tries to refetch all the messages from the server, and you'll see no end of messages (or at least I haven't up to now).

Posts: 1
Joined: August 7th, 2017, 1:34 pm

Post Posted August 7th, 2017, 1:56 pm

same here (ubuntu 16.04)
"Invalid UID Fetch attribute XSENDER" message in thunderbird 52.2.1 for the last 2 days

port: 993
security: ssl/tls
app-specific password has been generated

not any similar message with android/k-9 e-mail client which is working fine with same parameters

Posts: 1
Joined: August 7th, 2017, 3:52 pm

Post Posted August 7th, 2017, 3:59 pm

I had success getting rid of the error by going to the 'Account Settings->Server Settings' and changing the 'Security Settings' to all manner of combinations.
Between combinations, I attempted to 'Get Messages' -- to no avail.
When I set them back to 'Connect security' = 'SSL/TLS' and 'Authentication method' = 'Normal password', I was able to successfully download the new message contents.

(I think that this might be a bit of a Thunderbird bug because the new message headers were showing up, but the "Invalid UID Fetch..." errors were showing up when I tried to open the new messages.)


User avatar
Posts: 6
Joined: August 7th, 2017, 7:34 am
Location: Boston

Post Posted August 7th, 2017, 8:20 pm

Hi fred9999 & others,

Thunderbird 52.2.1 (64-bit) and the ports are IMAP 993 / SMTP 587. Other settings are the same as spqr2k. It looks like all of the IMAP accounts hooked to my Thunderbird use port 993 for IMAP (gmail, outlook-hosted company email, other service hosted) and they work normally. I haven't tried to send from Thunderbird, wanted to get the incoming issue resolved. I have unhooked and re-hooked my account (icloud) to no avail but haven't tinkered with various combinations as marklark has. I tried repairing a folder too, to no avail.

Posts: 1
Joined: August 8th, 2017, 3:26 am

Post Posted August 8th, 2017, 3:35 am

I have the same problem. What’s strange is that it comes and goes. It only affects messages whose content has not been cached, e.g. new messages. Two days ago, the problem was consistent. It disappeared overnight, and TB worked all day yesterday. This morning, it’s back.

I'm running release 52.2.1 on Windows 7. As with other posters, I’ve checked all account settings, reset and reapplied the app-specific password (which works fine), and made the same mistake as one poster, trying “Repair Folder."

I’m prepared to believe that this is an Apple problem, but my search of Apple Support shows nothing. They’re not much interested in Thunderbird, I guess.

I will call Apple. I’d appreciate any other suggestions!


Posts: 11
Joined: August 4th, 2017, 9:14 am

Post Posted August 8th, 2017, 5:23 am

So it appears that clients on windows, mac, and ubuntu are affected, that's good to know. Confirming we're using a common set of incoming server parameters. I tried marklark's changing of parameters, didn't so anything for me. If anything, I suspect it's down to when the client attempts to refresh folders (you can watch some of this going on if you open up tools>activity manager)

I have a case open with Apple, suggest you all do the same. Maybe if more people report it, they'll start working harder on it. I'll contact them later today if I don't hear from them.

My workaround on Windows is to use Opera for that account, I think it's also available on mac and linux.

Posts: 2
Joined: August 8th, 2017, 5:18 am

Post Posted August 8th, 2017, 5:26 am

It doesn't look like it's TB-specific. This is happening to me in SeaMonkey 2.48 as well.

Posts: 4
Joined: December 14th, 2009, 10:11 am

Post Posted August 8th, 2017, 10:52 am

I want to chime in and say that I am seeing it on a client's machine. I'm a computer repair tech and have a customer who just moved to iCloud a few months ago, using Thunderbird. This problem first kicked in for them on August 4th.

Before, it was only messages that weren't cached. I deleted and re-added the account on the 4th and now of course all of the messages are broken. No amount of changing settings did anything here. She's currently using the Mail app in Windows 10 in the meantime until some sort of resolution is reached.

I doubt this is relevant, but 2-factor authentication is enabled on this account and she is using an app-specific password for Thunderbird.

Since the old bug was already closed and it seems that email provider fixed it on their end, I created a new one. If you have anything to add or vote, please see it here.

Return to Thunderbird Support

Who is online

Users browsing this forum: No registered users and 3 guests