MozillaZine

Images don't appear in stationery received

User Help for Mozilla Thunderbird
gilliano56
 
Posts: 8
Joined: April 23rd, 2014, 5:48 am

Post Posted October 24th, 2017, 5:03 pm

I use Thunderbird for my emails, however when I receive email stationery I can only see the background and the images don't show up.
When I used to use Outlook Express I didn't have this problem. Can anyone help me? Thank you. P.S. I receive these
stationeries via Yahoo Groups.

tanstaafl
Moderator

User avatar
 
Posts: 44320
Joined: July 30th, 2003, 5:06 pm

Post Posted October 24th, 2017, 11:21 pm

See http://kb.mozillazine.org/Privacy_basics_-_Thunderbird . The text on the yellow error bar (in the article) is a out of date but you should be able to recognize its replacement (it is still displayed near the top of the message).

If you are seeing just outlines of images look for some text about remote images being disabled to protect your privacy next to a button to manage who can show remote content. Or just go to Tools -> Options -> Privacy -> Mail Content -> Exceptions and add the yahoo group's email address('s) to the exceptions.

Does this problem also occur with HTML mail you get from somebody else?

gilliano56
 
Posts: 8
Joined: April 23rd, 2014, 5:48 am

Post Posted October 25th, 2017, 4:17 pm

Thank you for your reply. I only have this problem with the stationeries that I receive. Just now and again I do manage to see a stat as it should be. I don't even get an outline
of the image or any text about remote images being disabled, just the background. I questioned my friend who sends the stats and she just said that others see the stats ok and
didn't see any reason why I couldn't. I do own a website for oe stationery for which I wrote the HTML. It just seems to be a Thunderbird problem?

tanstaafl
Moderator

User avatar
 
Posts: 44320
Joined: July 30th, 2003, 5:06 pm

Post Posted October 26th, 2017, 10:11 am

One possibility is that you are getting messages with a complex mess of MIME body parts and Thunderbird has problems parsing it. This occurs a lot with newsletters that try to be too fancy. However, frequently if this occurs you'll see the raw HTML tags from a HTML MIME body part interpreted as the plain text body of a message. You don't appear to be running into that but it would still be worth a moment to see if the show all body parts add-on at https://addons.mozilla.org/en-US/thunde ... ts/?src=ss makes a difference. Its not a great workaround as it may force you to see some inline images as attachments but if it makes a difference that would confirm whats causing it.

Another possibility is those messages have trivial flaws in MIME syntax that cause parsing problems for Thunderbird, but many other email clients tolerate. There was a thread a little while ago where an extra ; in a Content-Type header caused Thunderbird to display a blank message body while other email clients had no problem. viewtopic.php?f=39&t=3034547

I suggest you experiment with view -> message body as -> Simple HTML. That displays images but disables a lot of HTML functionality, so its possible that might help. In general though it looks a lot worse then Original HTML so if it helps I wouldn't leave it as the default setting.

gilliano56
 
Posts: 8
Joined: April 23rd, 2014, 5:48 am

Post Posted October 29th, 2017, 4:13 pm

Thank you for your reply. I downloaded the add-on to show body parts.All I then get to see is each attatched image as a separate entity. At least I get to see the images
but I really would like to see the stationery properly. I'll ask around in my stationery group if anyone there uses Thunderbird and if they see the stationery as it should be.
Thanks again.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 9 guests