MozillaZine

"Get Messages" button can't sync all folders

User Help for Mozilla Thunderbird
river09
 
Posts: 2
Joined: October 26th, 2017, 8:07 pm

Post Posted October 26th, 2017, 8:20 pm

thunderbird is 52.4.0 (32-bit). The setting is IMAP. Mail rules have been set on the webmail classification. but when I press the "Get Messages" button on PC's thunderbird, only Inbox has checked, and the other folders are not responding. Need to click the specific folder to check the specific folder's message. Account settings have been selected "to synchronize all messages to the local side", but still invalid, may I ask what settings to be changed? Or what plug-in can solve this problem?
Thank you

tanstaafl
Moderator

User avatar
 
Posts: 44321
Joined: July 30th, 2003, 5:06 pm

Post Posted October 27th, 2017, 1:19 am

Is the problem that it does not notify you of new mail in other folders (than the inbox) unless you open that folder?

Choose one of those folders, right click on it in the folder pane, and select properties. Check the checkbox for "when getting new messages for this account, always check this folder", press OK, restart Thunderbird, and see if that works around the problem.

I normally don't bother checking that checkbox because with a IMAP account you can rely upon IDLE support automatically notifying you of new mail (without waiting for "check for new mail every x minutes", pressing the get messages button, or opening the folder) in all folders. IDLE support is now called "allow immediate server notifications when new messages arrive" in the accounts server settings. Is it checked?

river09
 
Posts: 2
Joined: October 26th, 2017, 8:07 pm

Post Posted October 27th, 2017, 1:40 am

Sorry, no explanation clearly, server notifications have been confirmed to open. "check for new mail every x minutes" has been set to 10 minutes to check, but still only check Inbox, other folders did not.
right click on folder, "when getting new messages for this account, always check this folder" option is open, the current test is ok. But all folders are required to open. The problem seems to be successful at present, and I will look at it again.
Thank you for your answer.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 5 guests