MozillaZine

Quote Inserted into outgoing email address for multiples

User Help for Mozilla Thunderbird
kirkdickinson
 
Posts: 32
Joined: October 2nd, 2007, 8:53 am

Post Posted November 4th, 2017, 2:31 pm

I have one installation of TB that I am having a problem with. When that user sends individual emails, they go fine, If he tries to send to multiples, they all bounce. He has tried sending multiples with BBC and using the Alexander Bergmann Mail Merge Extension.

I have looked at the emails in the outgoing message and they look fine but after they send, I can look at them in the sent folder and there has been an extra quote inserted into them. For instance:
mike@gmail.com
jane@msn.com
bill@yahoo.com

turn into:
mike"@gmail.com
jane"@msn.com
bill"@yahoo.com

This is crazy and I haven't any idea how to fix it. I have searched for someone else with this error, but am obviously not searching for the correct terms.

Any ideas? Something is obviously parsing the outgoing message wrongly and it is recorded as such in the sent folder.

DanRaisch
Moderator

User avatar
 
Posts: 120265
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 4th, 2017, 6:47 pm

How are they entering the multiple email addresses, using a Mailing List or entering separate addresses? If the latter, on one line or multiple?
Does the same thing occur if you launch the application in Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode

kirkdickinson
 
Posts: 32
Joined: October 2nd, 2007, 8:53 am

Post Posted November 6th, 2017, 8:42 am

DanRaisch wrote:How are they entering the multiple email addresses, using a Mailing List or entering separate addresses? If the latter, on one line or multiple?
Does the same thing occur if you launch the application in Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode


DanRaisch, he is entering them on one line.

mike@gmail.com, jane@msn.com, bill@yahoo.com

He has a list of emails and when he cuts and pastes them on one line, TB automatically puts commas between them.

I will check in safe mode.

kirkdickinson
 
Posts: 32
Joined: October 2nd, 2007, 8:53 am

Post Posted November 6th, 2017, 8:55 am

I think I figured it out. The list he was copying from had an extra space between each address and TB was inserting two commas:
mike@gmail.com,,jane@msn.com,,bill@yahoo.com

I think the first one goes and the rest get an added quote and don't go.

Thanks.

DanRaisch
Moderator

User avatar
 
Posts: 120265
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 6th, 2017, 8:57 am

Ah, then clearing the extra space between addresses may be all that it will take to eliminate the quotes. Thanks for reporting back with your findings.

kirkdickinson
 
Posts: 32
Joined: October 2nd, 2007, 8:53 am

Post Posted November 6th, 2017, 10:32 am

Yeah, I think that will fix it. The addresses in his list were like this:


mike@gmail.com

jane@msn.com

bill@yahoo.com

So when Copying them to TB, it parses them as:

mike@gmail.com,,jane@msn.com,,bill@yahoo.com

And in the sent box, it looks like the second two adrresses get reparsed as:
jane"@msn.com and bill"@yahoo.com

Why? I don't know, but have found the fix. Hopefully if someone else has this same problem, they can find this thread. :)

Thanks Dan for commenting. :)

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 10 guests