MozillaZine

Slow mail download

User Help for Mozilla Thunderbird
aik_au
 
Posts: 23
Joined: November 13th, 2016, 10:13 pm

Post Posted November 24th, 2017, 6:18 pm

I have a gmail account with 20 folders/labels, TB is configured to work with it via IMAP.

Quite often when I switch to some folder and click on a message, I see "sending login information" (1) or "opening folder blahbla" (2), this may take a while until some syncing is done and only then TB shows me a message. Ok, I understand that if I did not open the folder in last 20 minutes, it is a natural thing to do the syncing but (1) and (2) happen way too often, like 2-3 minutes delay - and there is that syncing again.

So the questions are:
1. is it possible to tell TB to show the selected mail first, and then do the syncing?
2. is it possible to change the timeout after which the connection is reset? Other timeouts?
3. is there any addon to do profiling/debugging on what is really going on right now? Like how many IMAP connections are active now, etc? Anything will do, just need to get a picture.

Thanks.

ps. I know about compacting folders, reducing a number of messages exported by gmail in a folder and other things, doing all of that helps for a day or so and it feels I am digging in wrong direction, hence there questions.

DanRaisch
Moderator

User avatar
 
Posts: 120605
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 25th, 2017, 5:27 am

Do you have Thunderbird set to store copies of all messages on the local computer to facilitate access when no Internet connection is available? If you don't need that functionality, turning that off might speed up the display process.
Do you have the Global Search and Indexing active? If so, turning that off may help as it would eliminate the need for TB to scan for changes in messages and index all messages incoming in each of those 20 folders/labels.

tanstaafl
Moderator

User avatar
 
Posts: 44622
Joined: July 30th, 2003, 5:06 pm

Post Posted November 26th, 2017, 3:30 pm

Syncing the offline folders (created due to tools -> account settings -> gmail -> synchronization & storage -> keep messages for this account on the computer) normally runs in the background. It may slow performance but should not block anything. I suggest you try disabling syncing and global search/indexing (tools -> options -> advanced -> general) to verify that one of them is the culprit. It might be something else, in which case I suggest you see if http://kb.mozillazine.org/Performance_-_Thunderbird gives you any ideas.

See http://kb.mozillazine.org/Session_logging_for_mail/news if you want to enable IMAP logging.

aik_au
 
Posts: 23
Joined: November 13th, 2016, 10:13 pm

Post Posted March 7th, 2018, 6:42 pm

It took me a while :-) I downloaded the latest 59.0b2 (64-bit), tried the logging. Here one of the examples with 30 seconds hiccup - I simply clicked on a new message, TB said "Loading message" and nothing was happening for 30 seconds, any idea how to fix this kind of pause?


2018-03-08 01:37:25.933696 UTC - [13028:Unnamed thread 0x7f9170fda040]: I/IMAP 0x7f915ffcc800:imap.googlemail.com:S-watch:SendData: 12 STATUS "skiboot" (UIDNEXT MESSAGES UNSEEN RECENT)
2018-03-08 01:37:26.192213 UTC - [13028:Unnamed thread 0x7f9170fdaee0]: D/IMAP ReadNextLine [stream=0x7f917d4bfc90 nb=10 needmore=0]
2018-03-08 01:37:26.192267 UTC - [13028:Unnamed thread 0x7f9170fdaee0]: I/IMAP 0x7f917fc36800:imap.googlemail.com:S-qemu:CreateNewLineFromSocket: + idling
2018-03-08 01:37:27.867614 UTC - [13028:Main Thread]: D/IMAP proposed url = redhat folder for connection watch has To Wait = FALSE can run = FALSE
2018-03-08 01:37:27.867665 UTC - [13028:Main Thread]: D/IMAP proposed url = redhat folder for connection ARM has To Wait = FALSE can run = FALSE
2018-03-08 01:37:27.867690 UTC - [13028:Main Thread]: D/IMAP proposed url = redhat folder for connection qemu has To Wait = FALSE can run = FALSE
2018-03-08 01:37:27.867729 UTC - [13028:Main Thread]: D/IMAP proposed url = redhat folder for connection kernel has To Wait = FALSE can run = FALSE
2018-03-08 01:37:27.867765 UTC - [13028:Main Thread]: D/IMAP proposed url = redhat folder for connection dpdk has To Wait = FALSE can run = FALSE
2018-03-08 01:37:27.867999 UTC - [13028:Unnamed thread 0x7f9170fdaee0]: I/IMAP 0x7f917fc36800:imap.googlemail.com:S-qemu:SendData: DONE
2018-03-08 01:37:56.198197 UTC - [13028:Unnamed thread 0x7f9170fdab80]: D/IMAP ReadNextLine [stream=0x7f917d4bfb30 nb=20 needmore=0]
2018-03-08 01:37:56.198258 UTC - [13028:Unnamed thread 0x7f9170fdab80]: I/IMAP 0x7f916c5de800:imap.googlemail.com:S-dpdk:CreateNewLineFromSocket: * BYE System error
2018-03-08 01:37:56.198351 UTC - [13028:Unnamed thread 0x7f9170fdab80]: D/IMAP ImapThreadMainLoop leaving [this=0x7f916c5de800]
2018-03-08 01:37:56.207979 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP ReadNextLine [stream=0x7f917d4f50e0 nb=20 needmore=0]
2018-03-08 01:37:56.208093 UTC - [13028:Unnamed thread 0x7f9171eb8820]: I/IMAP 0x7f917fc37800:imap.googlemail.com:S-ARM:CreateNewLineFromSocket: * BYE System Error
2018-03-08 01:37:56.208194 UTC - [13028:Unnamed thread 0x7f9171eb8820]: I/IMAP 0x7f917fc37800:imap.googlemail.com:NA:ProcessCurrentURL: entering
2018-03-08 01:37:56.208278 UTC - [13028:Unnamed thread 0x7f9171eb8820]: I/IMAP 0x7f917fc37800:imap.googlemail.com:NA:ProcessCurrentURL:imap://aik%40ozlabs%2Eru@imap.googlemail.com:993/customKeywords%3EUID%3E/pci%3E55116:55117%3ENonJunk%3E: = currentUrl
2018-03-08 01:37:56.208388 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP try to log in
2018-03-08 01:37:56.208424 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP IMAP auth: server caps 0x75e0c2625, pref 0x1006, failed 0x0, avail caps 0x4
2018-03-08 01:37:56.208448 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP (GSSAPI = 0x1000000, CRAM = 0x20000, NTLM = 0x100000, MSN = 0x200000, PLAIN = 0x1000, LOGIN = 0x2, old-style IMAP login = 0x4, auth external IMAP login = 0x20000000, OAUTH2 = 0x800000000)
2018-03-08 01:37:56.208467 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP trying auth method 0x4
2018-03-08 01:37:56.208681 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP got new password
2018-03-08 01:37:56.208809 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP IMAP: trying auth method 0x4
2018-03-08 01:37:56.208840 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP old-style auth
2018-03-08 01:37:56.208977 UTC - [13028:Unnamed thread 0x7f9171eb8820]: I/IMAP 0x7f917fc37800:imap.googlemail.com:NA:SendData: Logging suppressed for this command (it probably contained authentication information)
2018-03-08 01:37:56.213978 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP ReadNextLine [stream=0x7f917d4f50e0 nb=0 needmore=1]
2018-03-08 01:37:56.214128 UTC - [13028:Unnamed thread 0x7f9171eb8820]: I/IMAP 0x7f917fc37800:imap.googlemail.com:NA:CreateNewLineFromSocket: clearing IMAP_CONNECTION_IS_OPEN - rv = 80470002
2018-03-08 01:37:56.220245 UTC - [13028:Unnamed thread 0x7f9171eb8820]: I/IMAP 0x7f917fc37800:imap.googlemail.com:NA:TellThreadToDie: close socket connection
2018-03-08 01:37:56.220359 UTC - [13028:Unnamed thread 0x7f9171eb8820]: I/IMAP 0x7f917fc37800:imap.googlemail.com:NA:CreateNewLineFromSocket: (null)
2018-03-08 01:37:56.220422 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP authlogin failed
2018-03-08 01:37:56.220464 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP marking auth method 0x4 failed
2018-03-08 01:37:56.220504 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP IMAP auth: server caps 0x75e0c2625, pref 0x1006, failed 0x4, avail caps 0x0
2018-03-08 01:37:56.220551 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP (GSSAPI = 0x1000000, CRAM = 0x20000, NTLM = 0x100000, MSN = 0x200000, PLAIN = 0x1000, LOGIN = 0x2, old-style IMAP login = 0x4, auth external IMAP login = 0x20000000, OAUTH2 = 0x800000000)
2018-03-08 01:37:56.220594 UTC - [13028:Unnamed thread 0x7f9171eb8820]: D/IMAP no remaining auth method
2018-03-08 01:37:56.220630 UTC - [13028:Unnamed thread 0x7f9171eb8820]: W/IMAP IMAP: ask user what to do (after login failed): new passwort, retry, cancel
2018-03-08 01:37:56.220667 UTC - [13028:Unnamed thread 0x7f9171eb8820]: E/IMAP login failed entirely

aik_au
 
Posts: 23
Joined: November 13th, 2016, 10:13 pm

Post Posted March 28th, 2018, 6:16 pm

any ideas how to fight this? imho this is rather a server's fault that the connection becomes stale and TB has to start all over again.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 10 guests