MozillaZine

Thai language issue (Linux)

User Help for Mozilla Thunderbird
qualtrough
 
Posts: 16
Joined: February 19th, 2015, 3:05 am

Post Posted November 25th, 2017, 2:01 am

I have Thunderbird 45.5.1 installed on cinnamon machine. I can compose and read message in Thai, but if I open one of my sent messages the Thai has been transformed into gibberish with composed of random Thai characters. This is now a real problem for me as I need to establish that I sent a message but the contents no longer appear in Thai.

I would be grateful if anyone can advise me on what might be going on and how to fix it. Also, for messages already sent and saved on my machine, is there any way to retrieve or view the original Thai as sent?
Last edited by DanRaisch on November 25th, 2017, 5:20 am, edited 1 time in total.
Reason: (Linux) added to subject line.

Grumpus

User avatar
 
Posts: 11696
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted November 25th, 2017, 11:04 am

You might want to open the repositories and see if you are missing any fonts for Thai, in some cases the alphabet might not go by normal form standards.
Install Synaptic, check you have all the repositories open and reload once Synaptic is open.
See if any Thai fonts are missing or available for installation.
There has been less and less support, as a general statement, for 32 bit machines in a number of areas.
You might want to update to the latest Thunderbird after the fonts and adjustments.

Once you have the necessary fonts, if you needed them.
Open Thunderbird and open Preferences/Display/Formatting/Fonts & Colors/Advanced -set Fonts for: to either "other writing systems" or Thai - specifically
Also look at Text Encoding and set it for Unicode (UTF-8) - set for both incoming and outgoing and see if that helps
Make sure you set Font Control to "allow messages to use other fonts or uncheck if it works better the other way

qualtrough
 
Posts: 16
Joined: February 19th, 2015, 3:05 am

Post Posted November 25th, 2017, 7:24 pm

Grumpus, thank you so much for taking the time to help. Turns out it was your last suggestion that fixed the problem. Only incoming was set to UTF-8. When I set incoming to UTF-8 that solved the problem and I am able to read the Thai in my outcoming mail. Big relife!

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 2 guests