MozillaZine

Message Filter Automatically Disengages

User Help for Mozilla Thunderbird
John Bilecky
 
Posts: 12
Joined: November 15th, 2007, 10:11 am

Post Posted November 28th, 2017, 9:51 am

Recently, I have begun having problems with one of my Message Filters. I have three that run when I ‘Get Messages’ and they have all been fine for years. Now one of them automatically disengages when I start Thunderbird. I engage it again, but it shuts off when I retrieve mail. The other filters are fine.

Any idea what could be causing this and how to fix it?

Regards…John

[Version 52.3.0 on Windows 7]

tanstaafl
Moderator

User avatar
 
Posts: 43375
Joined: July 30th, 2003, 5:06 pm

Post Posted November 28th, 2017, 10:39 am

What do you mean by disengages - that it says its enabled but the filter log shows it didn't run?

Does it use the same features as the other message filters or does it rely upon an add-on such as FiltaQuilla?

POP or IMAP account? Are the good filters for the same type of account?

John Bilecky
 
Posts: 12
Joined: November 15th, 2007, 10:11 am

Post Posted November 29th, 2017, 10:54 am

Thanks for your reply, tanstaafl. When I said Disengaged, I meant that the box was no longer checked as 'Engaged' when you viewed the list of message filters.

I was able to resolve the situation by myself though. Under the filter's 'Perform these actions' I had it set to 'Move Message To' a particular folder. I don't know why, but the setting disappeared even though the folder was still there. Don't know why this occurred. Strange. I reset it and it's running fine again.

Thanks again.

mgagnonlv
 
Posts: 639
Joined: February 12th, 2005, 8:33 pm

Post Posted November 29th, 2017, 1:27 pm

There is one explanation for that.

If you remove the destination folder (or anything else that would make the rule impossible to follow), then the rule is disengaged. Well, if you are on IMAP and have a flaky connection, it is quite possible that Thunderbird couldn't connect "in time" to one of your folders. Therefore, that one time, one of your folder wasn't loaded – or was loaded with an extreme delay – and then the rule was de-activated.

Three things *may* help prevent this issue :

– If you haven't set for automatic compaction, either make it automatic or compact regularly.
Automatic compaction is found under Tools –> Options –> Advanced –> Network and Disk space ; it's the last item.

– If your message folders are really huge (especially on IMAP), archiving some messages to a folder outside of IMAP helps connections and speeds up the process. It also speeds up phone connections too (especially if the Inbox and Sent folders are relatively small).
I tend to archive messages that are more than 2 years old in "Local Folders – Archive".

– Try to avoid situations with a flaky connection (ex. poor wi-fi connection), especially when you start Thunderbird. That way, all your folders will connect properly (unfortunately, easier said than done).
Michel Gagnon

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 9 guests