MozillaZine

Character encoding

User Help for Mozilla Thunderbird
beachesto
 
Posts: 50
Joined: March 5th, 2005, 1:18 pm

Post Posted November 29th, 2017, 11:25 am

Suddenly, characters are not appearing properly when composing a message in Thunderbird. Apostrophes are backward, quote (double apostrophe) doesn't work at all.

I've done a search and found http://forums.mozillazine.org/viewtopic.php?f=39&t=2006231. The character encoding properties are as described in that thread. The problem appears no where else, it's confined to Thunderbird.

I've obviously, inadvertently hit some magic combination of keys while typing. What magic antidote exists?

Thanks.

mgagnonlv
 
Posts: 639
Joined: February 12th, 2005, 8:33 pm

Post Posted November 29th, 2017, 1:18 pm

You baffle me. The "Character encoding" properties are typically for messages you receive, not for those you write.

On Windows 7, it is unfortunately quite easy to set a different keyboard map for each application. You may use the US keyboard for almost everything but use the French keyboard for Thunderbird, for example. And with the default settings, you can easily switch by mistake by pressing Windows-Alt-spacebar (I think).

I'm going by memory as I don't have Windows 7 anymore (besides, my system is in French so I may not have the exact terms), but check if the language/keyboard icon (near the taskbar) stays the same when you switch between Thunderbird and other programs. If it changes, you may try to reselect your keyboard/language within Thunderbird, but I think a better long-term option would be the following:

1. Quit Thunderbird and all other programs. In other words, only the system itself should run.

2. In Control Panels, open "Keyboard" (or is it Regional Settings?) and select (again) the language and keyboard mapping you want to use. Also make it default. That's the important step to make sure all other applications will use the same keyboard mapping.

3. Before you click OK and close, there is a button called either "Keyboard shortcuts", "Extra" or something like that. Open it and remove all keyboard shortcuts that allow to switch between keyboard on the fly (unless you are one of the few who need that option).

4. Then click OK and save your preferences. If indeed I have identified the issue properly, then your problem should be solved. If not...
Michel Gagnon

makaiguy

User avatar
 
Posts: 16495
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted November 29th, 2017, 2:14 pm

There does seem to be a character encoding setting for messages you write. Don't know if this could be source of your problem.

Tools | Options | Formatting | Advanced -- there's an Outgoing Mail picklist of encodings.
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 52.4.0 ESR (64bit), TB 52.3.0 (32bit)║ Android 7.0/7.1.1: FF 57.0, No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

beachesto
 
Posts: 50
Joined: March 5th, 2005, 1:18 pm

Post Posted November 30th, 2017, 1:50 pm

That path doesn't seem to be available in my version makaiguy.

Anyway, the problem is resolved. When the computer was booted up this morning, formatting was back to the way it should be. Whatever magic keyboard shortcuts I inadvertently hit must have been temporary and reset to default on reboot. Not restarting Thunderbird, but rebooting the computer.

makaiguy

User avatar
 
Posts: 16495
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted November 30th, 2017, 1:59 pm

beachesto wrote:That path doesn't seem to be available in my version makaiguy.

OOPS! Left out a step. Should be:
Tools | Options | Display | Formatting | Advanced (button not tab)

Glad it's now working for you.
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 52.4.0 ESR (64bit), TB 52.3.0 (32bit)║ Android 7.0/7.1.1: FF 57.0, No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 6 guests