MozillaZine

Apparmor, open link in Browser, Thunderbird, Debian9

User Help for Mozilla Thunderbird
Ytre
 
Posts: 3
Joined: December 6th, 2017, 2:30 am

Post Posted December 6th, 2017, 2:34 am

Hi all,

i have a problem with opening links in my browser Vivaldi (1.13.1008.34 (Stable channel) (64-bit)) via Thunderbird (52.4.0 (64-bit)).

uname -a
Linux sun 4.13.0-1-amd64 #1 SMP Debian 4.13.13-1 (2017-11-16) x86_64 GNU/Linux.

Vivaldi is set systemwide as my preferred browser. Thunderbird has it as the preferred action to open http/https links with my standard browser. I`ve tried also with the path to the browser (/opt/vivaldi/vivaldi) in the config of Thunderbird, but it didn't work.

I've checked with
tail -f /var/log/messages:
Dec 6 09:19:09 sun kernel: [17764.341411] audit: type=1400 audit(1512548349.389:549): apparmor="DENIED" operation="exec" profile="thunderbird" name="/opt/vivaldi/vivaldi" pid=10791 comm="thunderbird" requested_mask="x" denied_mask="x" fsuid=1000 ouid=0

This comes up, when i click on links in Thunderbird to open it with Vivaldi.

When i change my standard browser i.e. to Chrome or Firefox, it works. It is possible to open links in mails with my standard browser. When i go back to Vivaldi as my standard browser the apparmor message comes up and it is not possible to open links in mails.

I'v tried also a complete reinstallation of Thunderbird and Vivaldi. Same problem.

I've found this:
https://git.launchpad.net/~u-d/apparmor ... 217579e845

These patch is inside the profile /etc/apparmor.d/usr.bin.thunderbird. I 've didn't change anything in the profile.

When i stop apparmor with

/etc/init.d/apparmor teardown

it is possible to open links via Thunderbird with Vivaldi.

So the problem must be inside the Apparmor profile for Thunderbird.

Any ideas?

regards
Ytre

Ytre
 
Posts: 3
Joined: December 6th, 2017, 2:30 am

Post Posted December 6th, 2017, 4:23 am

it works with kernel 4.12

$uname -a
Linux sun 4.12.0-2-amd64 #1 SMP Debian 4.12.13-1 (2017-09-19) x86_64 GNU/Linux

So it is a problem within the combination Kernel 4.13 and AppArmor, profile for Thunderbird

tanstaafl
Moderator

User avatar
 
Posts: 44328
Joined: July 30th, 2003, 5:06 pm

Post Posted December 6th, 2017, 6:13 am


Ytre
 
Posts: 3
Joined: December 6th, 2017, 2:30 am

Post Posted December 6th, 2017, 6:21 am

tanstaafl wrote:See if http://kb.mozillazine.org/Changing_the_ ... hunderbird lets you workaround that.


this solution is not working in this case. It's a problem in AppArmor and the profile for Thunderbird. When i deactivate AppArmor or boot with an older Kernel it works normal

look here: https://bugs.debian.org/cgi-bin/bugrepo ... bug=880424

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 14 guests