MozillaZine

change quotation color in plaintext composition

User Help for Mozilla Thunderbird
pista
 
Posts: 41
Joined: February 9th, 2008, 1:21 pm

Post Posted December 27th, 2017, 1:34 pm

I need to change the default color for quoed text in plain text composition. This is because I changed the font color to white and the background color to black using options, but blue over black is practically unreadable!
I've found some very old threads about the same subject (two of them are viewtopic.php?f=39&t=378018 and viewtopic.php?f=39&t=513670) but none works.
For example, following the suggestion in the second cited thread the color change is that of quoted text in view mode and not composition mode.
Please help me!
Last edited by pista on December 27th, 2017, 2:30 pm, edited 1 time in total.

DanRaisch
Moderator

User avatar
 
Posts: 120442
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 27th, 2017, 2:00 pm

Plain text messages can not include any colors except black text on a default background. That's because the selection and display of colored fonts requires the presence and use of HTML tags which are not supported in plain text.

pista
 
Posts: 41
Joined: February 9th, 2008, 1:21 pm

Post Posted December 27th, 2017, 2:26 pm

NOT AT ALL!
Because in a standard Thundebird installation, when you reply to a message in plain text mode the cited text IS BLUE!!!

DanRaisch
Moderator

User avatar
 
Posts: 120442
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 27th, 2017, 2:55 pm

Not when it gets to the recipient, unless they have set their email client to display that color. The point is that you have no control over what color the recipient sees when sending a plain text message because what Thunderbird sends does not include any actual color information.

pista
 
Posts: 41
Joined: February 9th, 2008, 1:21 pm

Post Posted December 27th, 2017, 4:25 pm

You missed the point completely.
I'm NOT interested AT ALL in how the recipient will read the message.
I need to change the color of quoted text because in dark mode the default color (blue) PREVENTS ME TO WRITE (AND READ) MY REPLY MESSAGE IN A DECENT WAY.
Why don't you try to set the background color to black and foreground color to white in Options > Diplay > Colors, and check if it is readable for you?
No, wait, I've already made such a task for you: https://imgur.com/oPmFlNe
DO YOU UNDERSTAND NOW?

Frank Lion

User avatar
 
Posts: 20075
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted December 27th, 2017, 5:16 pm

pista wrote:You missed the point completely.
I'm NOT interested AT ALL in how the recipient will read the message.
I need to change the color of quoted text because in dark mode the default color (blue) PREVENTS ME TO WRITE (AND READ) MY REPLY MESSAGE IN A DECENT WAY.
Why don't you try to set the background color to black and foreground color to white in Options > Diplay > Colors, and check if it is readable for you?
No, wait, I've already made such a task for you: https://imgur.com/oPmFlNe
DO YOU UNDERSTAND NOW?

We seem to have an understanding problem here.

Let me explain how it works. Show a rude attitude towards a Moderator here and the guys who could help you... are not going to. -

Image

Do you understand now?
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

DanRaisch
Moderator

User avatar
 
Posts: 120442
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 27th, 2017, 8:07 pm

Your first message is not clear. You speak of changing the colors to white text with a black background but then say that "blue over black is practically unreadable". If you changed the text to white, what does blue have to do with anything?

makaiguy

User avatar
 
Posts: 16655
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted December 27th, 2017, 8:50 pm

I believe he's asking about the color used to display the quote of the original message text when entering a reply. On my system, at least, it is shown in blue, no matter what is chosen as text display color. When specifying a dark background, the blue can be hard to read.
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 52.9.0 ESR (64bit), TB 60.3.0 (32-bit) ║ Android 8.0/7.1.1: FF 62.0.1 No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

DanRaisch
Moderator

User avatar
 
Posts: 120442
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 28th, 2017, 6:59 am

Ah, see how helpful it is when the issue is presented clearly and in detail. I suppose the appropriate answer to that problems would be: don't change the background to black.

morat
 
Posts: 2905
Joined: February 3rd, 2009, 6:29 pm

Post Posted December 28th, 2017, 9:51 am

@pista

You need to level up your patience.

Try this:

Code: Select all
/* Thunderbird userContent.css */

span[_moz_quote="true"] {
  color: lightgreen !important;
}
pre[_moz_quote="true"] {
  color: lightpink !important;
}

http://kb.mozillazine.org/UserContent.css

How to test:

* open 3pane window
* select a message
* hold shift and click reply button for plain text format

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 5 guests