MozillaZine

Imap Trash folder weirdness

User Help for Mozilla Thunderbird
bsh
 
Posts: 42
Joined: June 20th, 2005, 11:10 pm

Post Posted January 1st, 2018, 5:05 am

Hello and happy new year to everyone!
I have a local imap server with an already existing account, which I'm accessing with TB on many devices since years. The account on the server already has a lot of mail, subfolders, shared folders, and whatnot. The "default" inbox/sent, inbox/drafts and inbox/trash folders are there too.
So far, when ever I added this account in TB on any device, it automatically recognized these default folders (sent/drafts/trash) and added them in the tree under inbox, with localized hungarian names and special icons.
However, now I newly added this account to TB on my desktop, and this time it only shows the sent and drafts folders localized, but not Trash: it just seems like any other folder, no special icon and no localized name. Also when I delete a mail, it doesn't go into Trash either.
So I went to account settings -> server settings -> and where I choose what to do when deleting mail, it shows a dropdown menu showing "Select folder...". When I do try to select the already existing Trash folder, it shows "inbox...>"inbox" and under that I see the existing folders. When I select the Trash folder, a new Folder is created under my account/inbox: it's a greyed out "Inbox" folder with the trash folder as a subfolder, and it is localized and and having the bin icon as usual. This greyed out "inbox" subfolder can not be deleted. (Only through the file system.)
What's going on with this? I didn't have this problem before, not even on this very same device. (Which is windows 7 pro x64 hungarian btw.) It still works fine on the other device.
Thanks for any ideas.

mgagnonlv
 
Posts: 704
Joined: February 12th, 2005, 8:33 pm

Post Posted January 1st, 2018, 10:38 pm

As a user of Thunderbird in French (and also of a phone on top of Thunderbird), I am aware that localization doesn't always work properly. I would suggest the following cure (I hope it works):

– In the left panel, right-click on the account name and select "Account Properties"

– Select "Server Parameters", then click on "Advanced".

– In the dialog box that opens, at the top :
– Folders on the IMAP server –> write : INBOX
– Namespace (3rd line from the bottom) –> write : "INBOX." (with the quotes)

Then quit and restart Thunderbird. That way, all various folders you have, including Sent and Trash won't appear as subfolders of Inbox but rather on the same level as inbox.

Now that you have restarted Thunderbird, do the following:

– Select "Synchronization and disk space" (5th item under the account), then click on "Advanced"

– At that point, you'll see a list of folders to which you are subscribed

– Click on Download to refresh the list, then make sure all relevant folders and subfolders for the account are selected, including the Trash folder. I don't know if "Trash" will be listed in English or in Hungarian, as I have some servers which are listed with French terms and others with English ones.

– Quit and restart Thunderbird (sometimes it helps).

– Now under Account Parameters, select "Server Parameters", then "Copies and Folders" (2nd item). You should be able to properly assign folders for trash, sent messages, templates, etc.

Hope it works.
Michel Gagnon
Montréal (Québec, Canada)

wsmwk
 
Posts: 2522
Joined: December 7th, 2004, 6:52 am

Post Posted January 2nd, 2018, 3:10 pm

There are some improvements for imap namespace issues (like trash and inbox) coming to beta in the next several weeks which may help.

tanstaafl
Moderator

User avatar
 
Posts: 44353
Joined: July 30th, 2003, 5:06 pm

Post Posted January 2nd, 2018, 3:42 pm

I suggest you do a custom setup of a en-us locale version of Thunderbird in a different directory (it will use your existing profile) and see if it has the same problem. If it does, then you can experiment with different values for the "personal namespace" and/or the "IMAP server" directory in tools -> account settings -> account_name -> server settings -> advanced in the hungarian version. If it doesn't have that problem then you know its a locale specific problem and can either try a beta or rollback to an earlier version that uses the hungarian locale. See http://kb.mozillazine.org/Go_back_to_an ... hunderbird if you want to use a older version. It will reuse your existing profile too.

You could also sign up for a Gmail webmail account, add a Gmail IMAP account in Thunderbird per http://kb.mozillazine.org/Gmail and see if it has a similar problem. I'm not suggesting you switch accounts, just that you do this to help troubleshoot who is to blame. Its also easier to get help with somebody using a popular email provider such as Gmail since we know what namespace settings to use. I typically set it's IMAP server directory to [Gmail] , leave the personal namespace set to "" , and leave "allow server to override these namespaces" checked. Setting the IMAP server directory to [Gmail] flattens the folder hierarchy to something more reasonable.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 7 guests