MozillaZine

(Resolved) Deleting messages

User Help for Mozilla Thunderbird
PennsyNut
 
Posts: 186
Joined: March 15th, 2004, 3:40 pm
Location: TX

Post Posted February 6th, 2018, 12:03 pm

I use Tb with all email, including Yahoo and ATT. Never a problem. However, I am having trouble deleting mail. I try holding shift and delete each message and group messages. In all cases, they disappear. Then, when I come back to that folder, those messages are all there again. I try to make sure the messages I delete are in all the folders. i.e. some messages are in more than one folder. And I delete them all. But when I open those folders again, there they are. I am bypassing the trash. i.e. Open the message and hold shift and click delete. Any help appreciated.

Grumpus

User avatar
 
Posts: 11869
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted February 6th, 2018, 1:01 pm

Check under Server Settings for the account you are using.
See if Leave message on server is checked and what the other settings are.
Also the settings for Disk Space in the account settings.

DanRaisch
Moderator

User avatar
 
Posts: 119442
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 6th, 2018, 1:19 pm

How is the account set up in Thunderbird, as POP or IMAP? Find out using menu path Tools->Account Settings->Server Settings->Server Type at the top right of the dialogue.

PennsyNut
 
Posts: 186
Joined: March 15th, 2004, 3:40 pm
Location: TX

Post Posted February 6th, 2018, 5:17 pm

Dan. I am positive I set them all up as POP. I just checked and some are IMAP and some POP. Duh! Now what? close out and reinsert all over? One at a time? Or all at once?

DanRaisch
Moderator

User avatar
 
Posts: 119442
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 6th, 2018, 7:35 pm

Why change them? Is there some reason you do not want to use IMAP?

PennsyNut
 
Posts: 186
Joined: March 15th, 2004, 3:40 pm
Location: TX

Post Posted February 7th, 2018, 4:55 pm

Dan. I am lost. I wrote above on 2/6 that I am having trouble deleting messages. When I click delete on a message, it goes to Trash. CORRECT. When I hold Shift and click delete, it is supposed to go away. Or, also, if it's in Trash. I open it, hold Shift and click delete, it is supposed to go away. This does not happen. Or rather, it happens and as soon as I leave and return, those messages are still there. I double check each folder because the message appears in several folders. Example: Important, Save, and an individual folder of my choice, such as "Finance" or "Medical". Another problem is that all my messages are going to "Important", not the "Inbox"; but only on my primary email address. On another, secondary email address, the message goes to both "Inbox" and "Important". This whole thing has me bewildered. I don't shive a git about IMAP or POP. I have no idea what they do. Other than POP is Post Office Protocol, etc. Which does not matter to me. I just want to send and receiver email like any body else. IMAP and POP are technical garbledegoop to me.
Morgan,a PC novice.With Windows 10 64 bit, Comodo free, Fx 58.0.1, Tb 52.6.0. (Disabled SpyBot & Malwarebyte because they were not working right with W 10.

DanRaisch
Moderator

User avatar
 
Posts: 119442
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 7th, 2018, 6:44 pm

Is that a Gmail account and is it set up as IMAP? This is important because some servers, notably Gmail's, don't actually use folders but labels, and any message can have multiple labels, as shown by your messages found in the Important, Save, and Finance or Medical "folders" at the same time.

Try right clicking on the name of each folder in the left hand folder pane and selecting "Properties" from the context menu and then clicking on the "Repair folder" button.

PennsyNut
 
Posts: 186
Joined: March 15th, 2004, 3:40 pm
Location: TX

Post Posted February 7th, 2018, 7:21 pm

Dan. Yes, all gmail accounts are set up as IMAP. And yes, folders and labels. Phooey! It's like Trash, Spam, Junk, and what ever. Why isn't there a trash can like windows. You delete, it goes to that trash can. Open the trash can and delete from there and it's Gone. (Yes, I realize it is still hidden on your PC, but you never see it again. This is rhetorical. Give me some time to check "properties" on each folder.
Morgan,a PC novice.With Windows 10 64 bit, Comodo free, Fx 58.0.1, Tb 52.6.0. (Disabled SpyBot & Malwarebyte because they were not working right with W 10.

DanRaisch
Moderator

User avatar
 
Posts: 119442
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 8th, 2018, 6:38 am

Well, when Thunderbird is working normally, that is what happens. But that may be impacted by settings on the Gmail web page. Under "Forwarding & POP/IMAP" there are options identifying what Gmail will do in response to an email client's request to delete a message being accessed as an IMAP account. See how the option called "When a message is marked as deleted and expunged from the last visible IMAP folder:" is set in your case.

PennsyNut
 
Posts: 186
Joined: March 15th, 2004, 3:40 pm
Location: TX

Post Posted February 8th, 2018, 9:31 am

OK Dan I think I've got it. I went to "Forwarding & POP/IMAP". I turned "Auto Expunge" OFF. And then marked "When marked xxxx immediately delete". Is that what you meant? I assume it is. So, you need reply only if that was not what you meant. And "THANK YOU" once again. You are an important asset to our forums.

DanRaisch
Moderator

User avatar
 
Posts: 119442
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 8th, 2018, 9:38 am

I wasn't suggesting a particular selection from those settings, only pointing out that they can impact the way things appear n an IMAP account in Thunderbird because they change Gmail's reaction to messages being deleted by the client (TB). If the change you noted gets things working as you intend, great. If not, experiment with another selection on the Gmail side.

PennsyNut
 
Posts: 186
Joined: March 15th, 2004, 3:40 pm
Location: TX

Post Posted February 8th, 2018, 9:52 am

Dan Now I'm again confused. The setting "was":Auto Expunge ON. If I left that, I would have made no change. But that was not working. As for "experiment with another selection on the Gmail side". What can I do? I thought we had exhausted Gmail settings. Let me restate what I actually do: I do not always open a message. Sometimes I can tell from the subject or sender that I don't want it. I have two choices. Click delete. Or hold the Shift key and click delete. If I click delete, it goes to Trash. And when I go to Trash, I can click delete again. Or in Trash, hold Shift and click delete. In either of these last two cases, the message disappears completely. If I then go elsewhere, when I return to "All Mail", those deleted messages are back. I then hold Shift and click Delete again. And they go away. As soon as I return to "All Mail", they are back again. I can not permanently delete anything. And all this happens when I open a message and do all the above. I am waiting for that Gmail change to take effect. That might solve this. And now, I will respectfully ask to wait until I get a chance to see if this is working.
Morgan,a PC novice.With Windows 10 64 bit, Comodo free, Fx 58.0.1, Tb 52.6.0. (Disabled SpyBot & Malwarebyte because they were not working right with W 10.

DanRaisch
Moderator

User avatar
 
Posts: 119442
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 8th, 2018, 9:59 am

It was another of the settings on Gmail's page that likely needs tweaking. That setting is:

When a message is marked as deleted and expunged from the last visible IMAP folder:
Archive the message (default)
Move the message to the Trash
Immediately delete the message forever


I think you want to choose either the second or third choices because "All Mail" is just the aggregate of messages in any of the labels. I'd test option 2 and if that still doesn't work, try 3.

PennsyNut
 
Posts: 186
Joined: March 15th, 2004, 3:40 pm
Location: TX

Post Posted February 8th, 2018, 10:20 am

That's what I thought. As of right now, it's the 3rd, and I'm waitng to see if it works.

PennsyNut
 
Posts: 186
Joined: March 15th, 2004, 3:40 pm
Location: TX

Post Posted February 8th, 2018, 4:43 pm

It's been 5 hours and so far, so good. All the messages I deleted are gone and have not come back. I will be here tomorrow with final results. FYI I went online in Gmail and deleted them there too. That should take care of that. I had messages from 2009 that are saved and they are still there. But everything else from then till 1/1/17 is now gone. Free's up a lot of space. Not that that is important. I figure one year plus is enough to save. What's with the signature? It shows "Mozilla/5.0 (Windows NT 10.0; etc." and that isn't me. I checked the way mine is set up and updated it. But it still shows wrong? Should be: Morgan,a PC novice.With Windows 10 64 bit, Comodo free, Fx 58.0.1, Tb 52.6.0. (Disabled SpyBot & Malwarebyte because they were not working right with W 10.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 11 guests