MozillaZine

Default Browser Broken! [Linux.][Solved]

User Help for Mozilla Thunderbird
kenj69
 
Posts: 15
Joined: February 8th, 2018, 8:18 pm
Location: West of Seatlle

Post Posted February 8th, 2018, 9:58 pm

Dang, shot myself in the foot!

I attempted to change the default browser when clicking on hyperlinks in email according to this link http://kb.mozillazine.org/Changing_the_web_browser_invoked_by_Thunderbird and I couldn't get it to work. So, I reset the value according to this same article and now NO browser is invoked!

I tried changing the values several times with the same result. Then, I deleted TB, rebooted, and re-installed - but TB still refuses to launch even the default browser. Now what? I'm stuck.

-=Ken=-
Last edited by kenj69 on February 22nd, 2018, 10:20 pm, edited 3 times in total.

LIMPET235
Moderator

User avatar
 
Posts: 38336
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted February 9th, 2018, 2:27 am

Hi,
Have you seen &/or tried this KB article...?
> http://kb.mozillazine.org/Default_browser
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. (Always choose the "Custom" Install.)

kenj69
 
Posts: 15
Joined: February 8th, 2018, 8:18 pm
Location: West of Seatlle

Post Posted February 9th, 2018, 8:18 pm

Thanks, I had not seen that page.

I wrote a new procedure for Linux KDE 5 if you like, since things have changed quite a bit.

I changed the default web browser and the file associations to no avail. Thunderbird fails to launch ANY browser - and I tried Firefox, Chromium and Seamonkey. Incidentally, Seamonkey Mail ignores these system settings and always launches the Seamonkey browser.
I tried creating the user.js file according to the referenced web page and that didn't work either.
Still stuck!

-=Ken=-
Linux KDE Neon 5.12 running on homebrew AMD Ryzen 3 1200 / ASRock MB

kenj69
 
Posts: 15
Joined: February 8th, 2018, 8:18 pm
Location: West of Seatlle

Post Posted February 9th, 2018, 10:51 pm

OK, I solved the problem. After removing Thunderbird I deleted the .thunderbird folder hidden in my Home folder. I re-installed and my preferred browser Chromium comes up. Now, all I have to do add back all my customizations.
It seems unsafe to edit the about:config file. :)

BTW, here is a procedure for Linux KDE 5

Open System Settings - Personalization/Applications
In Default Applications select Web Browser
Under Default Component select "In the following application:"
select from the drop-down list your prefered browser.

In File Associations/Known Types open "text" and select html
Then, in Application Preference Order select your preferences
and re-order them with Move Up or Move Down. Such as:
Chromium Web Browser
Firefox Web Browser
Mozilla Build of Seamonkey
Bluefish Editor

-=Ken=-
Linux KDE Neon 5.12 running on homebrew AMD Ryzen 3 1200 / ASRock MB

LIMPET235
Moderator

User avatar
 
Posts: 38336
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted February 9th, 2018, 11:59 pm

Many thanks for posting your fix.
May help others with the same problem.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. (Always choose the "Custom" Install.)

jelabarre59
 
Posts: 12
Joined: July 23rd, 2012, 10:31 am

Post Posted March 2nd, 2018, 2:54 pm

I wonder if you're hitting the same issue I'm having. Thunderbird will periodically set the OS' default browser to itself (Thunderbird). Which means TB will send web requests to itself, and doesn't know what to do with them. I have even found that if I switch it back to Waterfox, the links will start opening up, seems the OS or desktop has them waiting in a queue.

I have been seeing this with Cinnamon as well as Mate desktops, three different machines (don't recall seeing it happen on my netbook, but I don't use that one much anyway). I have to change the "default browser" in the desktop's configuration settings. Can't figure out what triggers it yet, could be a combination of TB updates, some extension messing with settings, or some issue with particular emails. Can't duplicate it at will.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot], sajjansinghania and 5 guests