MozillaZine

help to have a sound when i send an email please?

User Help for Mozilla Thunderbird
mantra
 
Posts: 326
Joined: September 29th, 2010, 7:21 am

Post Posted February 13th, 2018, 1:15 am

Hi
i'm running thunderbird 52.6.0 under windows 10 & 7 both 64bit

i have installed tonequilla 1.1.1

i have create a filter (i have tried several filter settings to have a sound when i send an email )
i create this filter

i have even added from ->is -> my email address ,but always without luck

what's wrong?

thanks

> https://i.imgur.com/NI7uYkS.png
Last edited by LIMPET235 on February 13th, 2018, 1:51 am, edited 1 time in total.
Reason: Image tags removed to restore the forum layout.
http://www.pcmech.com/article/clearing- ... he-how-to/
windows firefox 49.0.2 ,thunderbird 45.4 and under linux , firefox and thunderbird are always updated

DanRaisch
Moderator

User avatar
 
Posts: 120431
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 13th, 2018, 6:21 am

when i send an email

Filters only run automatically when new message are received. All other filters must be run manually.

mantra
 
Posts: 326
Joined: September 29th, 2010, 7:21 am

Post Posted February 13th, 2018, 7:30 am

DanRaisch wrote:
when i send an email

Filters only run automatically when new message are received. All other filters must be run manually.

hi
in short i can' have a sound when i send an email , can i?
thanks
http://www.pcmech.com/article/clearing- ... he-how-to/
windows firefox 49.0.2 ,thunderbird 45.4 and under linux , firefox and thunderbird are always updated

DanRaisch
Moderator

User avatar
 
Posts: 120431
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 13th, 2018, 8:29 am

Not simply, no. It might be possible to use the extension Filtaquilla to run some program that would generate a sound, but the two built in filter functions are for forwarding and replying, not for composing and sending a new message.

mantra
 
Posts: 326
Joined: September 29th, 2010, 7:21 am

Post Posted February 13th, 2018, 9:19 am

DanRaisch wrote:Not simply, no. It might be possible to use the extension Filtaquilla to run some program that would generate a sound, but the two built in filter functions are for forwarding and replying, not for composing and sending a new message.

hi
thanks but about the rules screenshot is right ?
and do you know which program could i use ? NirCmd v2.81 ? http://nircmd.nirsoft.net/mediaplay.html
thanks
http://www.pcmech.com/article/clearing- ... he-how-to/
windows firefox 49.0.2 ,thunderbird 45.4 and under linux , firefox and thunderbird are always updated

makaiguy

User avatar
 
Posts: 16654
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted February 13th, 2018, 10:11 am

Near the top of the filter create/edit dialog you need to have "After sending" checked. It used to be that you had to install an extension for this but it's been in the main program for a while now.

I don't think you want either of the top two choices checked, or EVERYTHING matching the filter criteria will play the sound.

Also, you must give it some filter criteria to match or else the filter will never be triggered. Try:
[From] [is] [your address]
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 52.9.0 ESR (64bit), TB 60.3.0 (32-bit) ║ Android 8.0/7.1.1: FF 62.0.1 No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

mantra
 
Posts: 326
Joined: September 29th, 2010, 7:21 am

Post Posted February 13th, 2018, 10:26 am

makaiguy wrote:Near the top of the filter create/edit dialog you need to have "After sending" checked. It used to be that you had to install an extension for this but it's been in the main program for a while now.

I don't think you want either of the top two choices checked, or EVERYTHING matching the filter criteria will play the sound.

Also, you must give it some filter criteria to match or else the filter will never be triggered. Try:
[From] [is] [your address]


hi
i have changed the rule , i have checked on only after seding
rule -> from -> is ->my email account
action play sound
but it doesn't work
have you tried? does it work to you?
thanks
http://www.pcmech.com/article/clearing- ... he-how-to/
windows firefox 49.0.2 ,thunderbird 45.4 and under linux , firefox and thunderbird are always updated

makaiguy

User avatar
 
Posts: 16654
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted February 13th, 2018, 8:28 pm

Yes I just tried it - but not with that extension as the action. Don't have or need that extension.

Try changing your action to something you can test like Add star (what I used in my test), to see if your filter trap is catching your outgoing messages. Once you have that working right, you can change back to Play Sound and see if that works.

You might also want to enable filter logging (button in lower right of filter dialog) and see what it says after trying the filter.

I'm more suspicious of the sound playing than I am the action of the filter. Are you sure you have the extension set up correctly?
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 52.9.0 ESR (64bit), TB 60.3.0 (32-bit) ║ Android 8.0/7.1.1: FF 62.0.1 No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

mantra
 
Posts: 326
Joined: September 29th, 2010, 7:21 am

Post Posted February 16th, 2018, 1:31 am

makaiguy wrote:Yes I just tried it - but not with that extension as the action. Don't have or need that extension.

Try changing your action to something you can test like Add star (what I used in my test), to see if your filter trap is catching your outgoing messages. Once you have that working right, you can change back to Play Sound and see if that works.

You might also want to enable filter logging (button in lower right of filter dialog) and see what it says after trying the filter.

I'm more suspicious of the sound playing than I am the action of the filter. Are you sure you have the extension set up correctly?


hi i did it
but sadly the sound is played when i got the email and not when i send
i have used start nircmd.exe mediaplay 180000 "c:\Thunderbird\send.wav"
weird i guess thunderbird can not perform an action when i send an email
http://www.pcmech.com/article/clearing- ... he-how-to/
windows firefox 49.0.2 ,thunderbird 45.4 and under linux , firefox and thunderbird are always updated

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 5 guests