MozillaZine

Identities and v60.0

User Help for Mozilla Thunderbird
OZO
 
Posts: 40
Joined: March 2nd, 2009, 7:58 pm

Post Posted August 8th, 2018, 1:04 pm

Today I've tried to update TB from v52.9.1 to 60.0.0 and discovered, that two of my very important add-ons are incompatible now :(
1. Identity Chooser - support multiple identities with one mail account
2. QuoteAndComposeManager - removes > from incoming mails

Those two add-ons are so important for me, that I have to return back from the latest version (60.0) to the old (and working well) 52.9.1.

Do you know "Identity Chooser"-like add on that will help to manage multiple identities, that is compatible with 60.0?
Is there any way to remove > from incoming mails without using QuoteAndComposeManager?

Thanks!

mozray
 
Posts: 50
Joined: March 10th, 2017, 3:48 pm

Post Posted August 8th, 2018, 2:46 pm

You could try setting the following config options to false -- extensions.strictCompatibility and extensions.checkCompatibility.60.0 -- under Options > Advanced > Config Editor.

This might make your extensions work or not. It worked for Quote Colors, an older addon I was using that isn't marked as compatible for v60.

tanstaafl
Moderator

User avatar
 
Posts: 44224
Joined: July 30th, 2003, 5:06 pm

Post Posted August 8th, 2018, 2:51 pm

Have you tried setting extensions.strictCompatibility false (per the release notes) using the config editor? The add-on still might not work due to changes in the mozilla toolkit, but that should at least let it attempt to install/run.

I've never bothered using the identity chooser add-on since I just choose one from the From: list box. But the external links section of http://kb.mozillazine.org/Multiple_iden ... il_account lists many identity add-ons. Have you tried others to see if they work with version 60?

https://addons.thunderbird.net/en-US/th ... src=search claims to "Remove the ">" prefix from quote when you make a reply." and support up to version 64.

The nestedquoteremover add-on at thunderbird.net only supports up to version 38. However, the authors home page at http://mozext.achimonline.de/nestedquot ... wnload.php has a later version that claims to support version 60.

The author of QuoteAndComposeManager states on his home page that he has started to work on updating to support version 59 so I suspect he will add support for version 60 later on.

OZO
 
Posts: 40
Joined: March 2nd, 2009, 7:58 pm

Post Posted August 8th, 2018, 3:22 pm

Thank you, @tanstaafl for the good news. I'll be waiting for QuoteAndComposeManager add-on update :)

@mozray, I've checked my extensions.strictCompatibility setting and it's already set to false. Next time I'll try 60.0, I'll check for the option extensions.checkCompatibility.60.0 too. But I'm worry that this is version specific option and with next update this option will be removed and therefore my add-ons will be disabled again. And the process of re-installing them is quire time consuming... Thank you for your advises.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 9 guests