MozillaZine

Can't Install Themes In T'Bird 60

User Help for Mozilla Thunderbird
tpaulr
 
Posts: 419
Joined: June 22nd, 2004, 8:01 am

Post Posted August 13th, 2018, 5:07 am

Is theme installation not allowed in T'Bird 60?

I dislike the default themes, would like to try something new. Everytime I try to install a new theme in T'Bird, it changes my Firefox theme, doesn't add anything to T'Bird.

I can't download any theme, there is no save button, just an add button.

Did I miss something? :?

WaltS48

User avatar
 
Posts: 3880
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted August 13th, 2018, 6:27 am

Did you try saving the theme's .xpi file to your Downloads folder, then in Thunderbird use the less than ideal case for installation?

https://support.mozilla.org/en-US/kb/in ... d-xpi-file
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

tpaulr
 
Posts: 419
Joined: June 22nd, 2004, 8:01 am

Post Posted August 13th, 2018, 7:36 am

There isn't anyway to download and save an .xpi file on any of the themes I saw.

I turned off UBlock, my A/V, everything I can think of that might be preventing me from seeing the "save button", nothing there on my screen, just "install".

Changes my Firefox theme, but doesn't add the theme to Thunderbird.

DanRaisch
Moderator

User avatar
 
Posts: 121425
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 13th, 2018, 7:57 am

There is no "save" butt but have you tried right clicking on the link and selecting "Save Link As", which is what is suggested in the link posted by WaltS48?

LIMPET235
Moderator

User avatar
 
Posts: 38674
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted August 13th, 2018, 8:05 am

Hi,
The link to the actual Theme may help....
&, as Dan posted....
The way to install any extension or theme in Thunderbird is to D/L the .xpi file first & then use Thunderbird to install it
using the Addons screen/option.
You have to right click the D/L button & Save link as....

ps. I just tried D/L'ing a full Theme, (Classic TB2) & it still works that way.
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0-61.0-62.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
(Always choose the "Custom" Install.)

tpaulr
 
Posts: 419
Joined: June 22nd, 2004, 8:01 am

Post Posted August 13th, 2018, 9:07 am

Dan & Limpet...

Yes, I always save and install from file in Thunderbird.

The few that I liked all downloaded as a Firefox HTM files.

Limpet, on complete themes, I can download, yes, the option is front and center.

Not necessarily looking for a complete theme, but it's an option I hadn't considered, not since the early days of Thunderbird.

As always, thank you all, greatly appreciated... :)

BTW, I like this new version of T'Bird, not so with FF...

DanRaisch
Moderator

User avatar
 
Posts: 121425
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 13th, 2018, 3:18 pm

How about a specific URL for the "theme" you were trying to install in Thunderbird?

tpaulr
 
Posts: 419
Joined: June 22nd, 2004, 8:01 am

Post Posted August 13th, 2018, 3:35 pm

Dan, a couple things...

1. URL is https://addons.thunderbird.net/en-US/th ... gold-iris/

2. I was able to install a complete theme, no problems whatsoever, same process as always, download the .xpi file, install it from T'Bird

Thanks... :)

tanstaafl
Moderator

User avatar
 
Posts: 45318
Joined: July 30th, 2003, 5:06 pm

Post Posted August 13th, 2018, 3:55 pm

I've had no problem installing themes (personas) with TB 60 but when I install a complete theme such as Monterail it doesn't change the icons in the folder pane, change the background color of the folder pane etc. - it looks exactly like the default theme. What complete theme did you install?

https://addons.thunderbird.net/en-US/thunderbird/addon/monterail/?src=cb-dl-created

tpaulr
 
Posts: 419
Joined: June 22nd, 2004, 8:01 am

Post Posted August 13th, 2018, 5:47 pm

Tanstaafl,

Phoenity Shredder is the complete theme I installed...

tanstaafl
Moderator

User avatar
 
Posts: 45318
Joined: July 30th, 2003, 5:06 pm

Post Posted August 13th, 2018, 6:08 pm

Thanks. That complete theme works on my copy of version 60. I was also able to use Novola. Metal Lion Sea Monkey works on most windows, but not the main window. When I tried to install classic tb2 Thunderbird claimed it was corrupt. The rest don't seem to support version 60.

tpaulr
 
Posts: 419
Joined: June 22nd, 2004, 8:01 am

Post Posted August 14th, 2018, 4:12 am

T.,

You're welcome.

Pauliemon
 
Posts: 77
Joined: August 19th, 2013, 11:50 am

Post Posted August 14th, 2018, 11:00 am

I have the complete themes for Thunderbird bookmarked. Lots of themes aren't compat with ver 60. Your Phoenity was just updated. Its funny, thats the one I'm currently using. The theme I kinda used for the last few years is called Tangobird and it hasn't been updated. Phoenity is good. I'll stick with it.

tanstaafl
Moderator

User avatar
 
Posts: 45318
Joined: July 30th, 2003, 5:06 pm

Post Posted August 14th, 2018, 3:48 pm

I was able to get Metal Lion Sea Monkey working properly by re-installing 52.9.1 , running it (the theme worked fine there), exiting, and running 60 again. Both are using the same profile. Same with Monterail which initially displayed the default theme in 60.0 despite being installed and enabled. I couldn't install classic tb2 directly in 60 (claims it was corrupted) but I could install it and use in 52.9.1. It worked fine when I switched to using 60.

I assume part of this is due the code checking some parameters when installing a theme that it doesn't check when loading a theme.

WaltS48

User avatar
 
Posts: 3880
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted August 14th, 2018, 6:01 pm

I prefer the built-in Dark theme.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 13 guests