MozillaZine

Not displaying tagged mail

User Help for Mozilla Thunderbird
Londoner674
 
Posts: 6
Joined: July 20th, 2016, 1:57 am

Post Posted September 5th, 2018, 3:59 am

Some of my mail is tagged, for whatever historic reason, and shows up in the default 'All' View with eg location 'Important' as well as location 'Inbox'. So the same email is shown twice because tag.

I've made a new Custom View called 'NoTag' with the pattern 'Tags' 'Doesn't contain' 'Important' and so on for all the tag categories. Using that view doesn't make any difference, I still see duplicates of tagged messages.
A Custom View called 'OnlyTags' with reverse pattern 'Tags' 'Contains' 'Important' and all the other categories displays duplicates.
A Custom View called 'OnlyImportant' displays all mail tagged Important from both locations, 'Important' and 'Inbox'.

I have no idea if any of this is working as designed (leaving a question about why it would be designed like that).

I don't want to see duplicates, which doesn't seem unreasonable. How do I get rid of them? Ideally I want to see what's in the location 'Important' without seeing the same messages from location 'Inbox' (which is, tbh, how I'd expect Thunderbird to behave by default). Failing that, and as the Custom View clearly doesn't work sensibly, if there's nothing else I'll conclude I don't really care about tags, so a simple 'untag everything' would be ok as a last resort. But then, they were tagged for some reason, so really, being able to view them or not would be kindof handy. Having to wade through 10+ years of mail untagging individual messages is not a viable solution :)

DanRaisch
Moderator

User avatar
 
Posts: 120457
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted September 5th, 2018, 4:29 am

In Thunderbird, tagging a message does not move it to a new location. It simply adds an additional element to the message file.

How is the account set up in Thunderbird, as POP or IMAP? Find out using menu path Tools->Account Settings->Server Settings->Server Type at the top right of the dialogue.
Who is the email provider? In other words, what comes after the @ in your email address?

Londoner674
 
Posts: 6
Joined: July 20th, 2016, 1:57 am

Post Posted September 5th, 2018, 6:38 am

OMG!

Thankyou for your help, it never occurred to me that this was being foist on me by Gmail, but apparently it's "Important according to Google magic". Grrr.

I've turned it all off in gmail. That hasn't updated in TB, I hope IMAP will take care of it but even preventing duplicate messages in the future is better than nothing.

Thanks again, i'm very grateful.

.

DanRaisch
Moderator

User avatar
 
Posts: 120457
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted September 5th, 2018, 8:10 am

I don't know that turning off that "Important" determination in Gmail will remove the existing label on messages previously received. You can unsubscribe from that Gmail "folder" and that might eliminate the duplication in Thunderbird -- https://www.liquidweb.com/kb/how-to-sub ... underbird/

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 4 guests