MozillaZine

reinstalled firefox, now links in emails won't open (Linux)

User Help for Mozilla Thunderbird
ginahoy
 
Posts: 221
Joined: October 18th, 2007, 8:32 pm

Post Posted November 5th, 2018, 9:52 pm

I'm running Linux Mint. I recently upgraded Firefox from v55 to v56. Since v56 is not current, I had to do the installation manually. Due to poor instructions on how to do that, I installed FF in the wrong path (/opt/firefox). Interestingly. T'bird somehow found the new path and I was able to open links from emails from within Thunderbird. However, I had other problems with FF due to wrong installation path so I eventually moved it to the 'normal' path for my OS (/usr/lib/firefox) with a shortcut (pointer) in /usr/bin/firefox. This is how FF is installed from the Linux Mint 18.3 installation disk. But now I get an 'invalid path' error when I try to open a web link from within Thunderbird. As a workaround, I created another shortcut in the /opt/firefox path

So how does one properly tell Thunderbird where to find Firefox?
Last edited by DanRaisch on November 6th, 2018, 5:20 am, edited 1 time in total.
Reason: (Linux) added to subject line.

tanstaafl
Moderator

User avatar
 
Posts: 44494
Joined: July 30th, 2003, 5:06 pm

Post Posted November 6th, 2018, 11:46 am

See http://kb.mozillazine.org/Default_browser if you want to make Firefox the default system browser. See http://kb.mozillazine.org/Changing_the_ ... hunderbird if you don't want to use the default system browser with Thunderbird.

ginahoy
 
Posts: 221
Joined: October 18th, 2007, 8:32 pm

Post Posted November 7th, 2018, 8:37 pm

Thanks for your reply, tanstaafl.

For reasons I can't recall, I was advised in the Linux Mint forum not to set a default browser at the O/S level. I've had no issues with this in the 15 months since switching to Linux. So I followed the instructions in the second link to set the protocol-handler strings to the correct path (/usr/bin/firefox). My version of Thunderbird (52.7) didn't already have these settings so I added (as instructed on linked page). However, after closing and re-opening T'bird, it still uses the previous path (/opt/firefox) and therefore throws and error message without the workaround shortcut I installed in that path. The instructions imply this should work for older versions. To troubleshoot, I rebooted, and verified the protocol-handler settings and paths I added were indeed saved. No joy.

tanstaafl
Moderator

User avatar
 
Posts: 44494
Joined: July 30th, 2003, 5:06 pm

Post Posted November 7th, 2018, 11:03 pm

I'm running windows 10. Give me a couple of days and I'll try to duplicate the problem running a Linux distro under VMware.

ginahoy
 
Posts: 221
Joined: October 18th, 2007, 8:32 pm

Post Posted November 8th, 2018, 12:33 am

Thanks. The thing is, I have no idea how the path got changed to begin with. I downloaded the FFv56 tarball and used the GUI (xfce with Thunar file manager) to extract and then copy the files into the /etc/firefox path. How Thunderbird was able to re-point itself to that path is a mystery. I know it wasn't anything I did. The invalid error pop-up doesn't have a 'find target' button, as I recall with Windows XP for certain broken associations. In any case, to duplicate and further troubleshoot the error, I suspect you'd need to install the same version of TB I'm running (52.7). And since I have a easy workaround, that seems like a lot of trouble. It may simply be that my TB version doesn't support the protocol-handler setting. As an aside, one issue I have with support/reference articles on this site is that they never (or rarely) mention which version(s) of T'bird they apply to, or even when they were written.

tanstaafl
Moderator

User avatar
 
Posts: 44494
Joined: July 30th, 2003, 5:06 pm

Post Posted November 8th, 2018, 1:10 am

The Thunderbird KB articles usually only mention a version if they're dealing with backward compatibility issues or there is an issue with what add-ons will work. The assumption is that they apply to the current version, even if the article hasn't been updated for a good while.

The very bottom of the web page for the KB article mentions when it was last updated. The bottom of "Changing the web browser invoked by Thunderbird" for example has "This page was last modified 14:49, 31 December 2016. This page has been accessed 249,967 times." I'd be surprised if your version doesn't support the protocol handler setting. I suspect the problem is how you configured the browser, that seems to be a common issue with Linux.

I've been meaning to create a Linux VM for a while in order to help troubleshoot Thunderbird problems under Linux. Don't worry about it.

tanstaafl
Moderator

User avatar
 
Posts: 44494
Joined: July 30th, 2003, 5:06 pm

Post Posted November 8th, 2018, 2:16 am

I tried both vmware and virtualbox and in each case I got linux mint to boot but it had serious problems. Rather than spend more time trying to figure out whats causing that I'll configure dual booting tonight.

update:
The Linux Mint flash drive I configured using rufus was recognized by the boot manager but ran grub, rather than booting linux. I reformatted it using fat32 and configured it using YUMI. Its not recognized by the boot manager. This is going to take a lot longer than I thought :)

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 8 guests