MozillaZine

Please Help - Font Size Question With Update

User Help for Mozilla Thunderbird
Hey Man
 
Posts: 50
Joined: December 24th, 2014, 7:09 am

Post Posted November 11th, 2018, 9:43 am

BuddhaNature wrote:Hey Man,

I don't myself know the answer to your problem with received old emails. All I know is how I managed to fix my own issues regarding font size.

For some clue on how you might proceed with the Fonts& Encoding settings see the "sfhowes" post here: viewtopic.php?p=14814816#p14814816

I tried what he suggested there and it didn't seem to make any difference when I was doing the settings Fonts for: Latin.

However, then I tried doing the settings for Fonts for: Other Writing Systems that did make a clear and obvious difference - even to display of my old emails. I set the Minimum font size: to 17 and unchecked Allow messages to use other fonts. I also found out that if I checked (ticked) Allow messages to use other fonts the change in minimum font size to 17 still got applied.

So I would suggest experimenting with the Fonts for: Other Writing Systems settings and see if that works for you. Just experiment with it for a while but before you do keep a note of the original settings in case you want to get back to them.

Tomorrow I'm going to read this http://kb.mozillazine.org/Font_settings_in_Thunderbird and see if helps in understanding how font sizes are assigned in Thunderbird. As it stands I find it confusing too.


Thanks I will try this.

My font size is currently 16/Large and I am happy with that when it comes to composing and receiving my own emails when I do a test. Should all the sizes be set to 16 as well in the advanced page and Other Writing System when it comes to receiving from other people?

Font Size should be one of the easiest things to change with any email program, so it's kind of frustrating that no one truly has a definitive answer here with TB.

Click this. Do That. Done. It's like how you remember it with the previous version of TB.

lasardo
 
Posts: 182
Joined: September 9th, 2018, 1:41 pm

Post Posted November 11th, 2018, 10:01 am

Remember, in addition to the font size you set, there is also a size controlled by ctrl-mousewheel that ranges from six choices - from tiny to huge that affects something. If you get a combination you like, you may want to change mousewheel.withcontrolkey.action to disable the adjustment so you don't get things out of sync by accident. Set to 0 for example, after things are right, if you want to disable the zoom.
https://www.ghacks.net/2011/02/11/enabl ... underbird/

BuddhaNature

User avatar
 
Posts: 307
Joined: January 3rd, 2008, 9:44 am
Location: Scotland

Post Posted November 11th, 2018, 10:33 am

lasardo wrote:Remember, in addition to the font size you set, there is also a size controlled by ctrl-mousewheel . . .

You can also do this via the following keyboard combinations:

[CTRL]+[+] Increases the magnification.
[CTRL]+[-] Decreases the magnification
[CTRL]+[0] Sets the magnification back to the default (i.e. to the original 100%)

I find that a bit less confusing than using [CTRL]+[MouseWheel], especially for getting back to the default size view.
OS: Windows 7 Pro. SP1 x64

Hey Man
 
Posts: 50
Joined: December 24th, 2014, 7:09 am

Post Posted November 11th, 2018, 10:37 am

lasardo wrote:Remember, in addition to the font size you set, there is also a size controlled by ctrl-mousewheel that ranges from six choices - from tiny to huge that affects something. If you get a combination you like, you may want to change mousewheel.withcontrolkey.action to disable the adjustment so you don't get things out of sync by accident. Set to 0 for example, after things are right, if you want to disable the zoom.
https://www.ghacks.net/2011/02/11/enabl ... underbird/


But isn't zoom only for people who for example who have an eye sight problem or when emails are too small? Correct me if I am wrong, but it's not meant to be a standard thing. I certainly didn't have a zoom settings implemented prior to this update and font size wasn't an issue.

BuddhaNature

User avatar
 
Posts: 307
Joined: January 3rd, 2008, 9:44 am
Location: Scotland

Post Posted November 11th, 2018, 10:44 am

Yes, I think zoom is only for a quick increase/decrease of viewing the message text - it doesn't in any way that I can see affect the actual size of fonts in message, they stay fixed according to your settings elsewhere. Zoom did exist in previous incarnations of TB because much of TB is based on Firefox. The above mentioned mouse-wheel and keyboard combinations also work in Firefox. But when you do it in Firefox you get a visual display in the address-bar as to what the zoom level is (with the exception of 100%).
OS: Windows 7 Pro. SP1 x64

Hey Man
 
Posts: 50
Joined: December 24th, 2014, 7:09 am

Post Posted November 11th, 2018, 10:51 am

BuddhaNature wrote:Yes, I think zoom is only for a quick increase/decrease of viewing the message text - it doesn't in any way that I can see affect the actual size of fonts in message, they stay fixed according to your settings elsewhere. Zoom did exist in previous incarnations of TB because much of TB is based on Firefox. The above mentioned mouse-wheel and keyboard combinations also work in Firefox. But when you do it in Firefox you get a visual display in the address-bar as to what the zoom level is (with the exception of 100%).


So are all your issues fixed now? Sending, receiving/replying (old and new emails), font size in the reading pane of inbox/sent box - are all in the font size/same font size that you want with the change from Latin to Other Writing Systems? Or do you still have some things you are trying to work out?

If you could post a screenshot of your Fonts and Encodings section - that would be great.

BuddhaNature

User avatar
 
Posts: 307
Joined: January 3rd, 2008, 9:44 am
Location: Scotland

Post Posted November 11th, 2018, 12:59 pm

Hey Man,

Here is a screenshot of the settings I now have (and that I will be sticking with):
Image
When I was experimenting with setting that up I found the following:

(1) For the drop-down selector making the Proportional: setting you can choose either Serif or Sans Serif. Whichever of those choices you make that Proportional setting determines whether the specified Serif font or the specified Sans-Serif font will be used for display of messages. So, from the example shown above, I had selected Proportional: Serif. This means that the font that will be used for displaying messages will be Times New Roman. (If I had chosen Proportional: Sans Serif then the font that would be used would be Arial. (Just experiment a bit with it and watch the effects that setting has.)

(2) When making these settings I found that the order I did it in was important. First, make the settings you want to use for Latin - once you have made those settings click the OK button. (This will take you back to the main Formatting tab.) Now click on the Advanced . . . button again and then make the changes you want to the Other Writing Systems settings. Once finished there click the OK button and you go back to the Formatting tab. On that tab just click the OK button and then you can go test if the settings you have made cure the issues you are complaining about.
OS: Windows 7 Pro. SP1 x64

Hey Man
 
Posts: 50
Joined: December 24th, 2014, 7:09 am

Post Posted November 11th, 2018, 1:24 pm

BuddhaNature wrote:Hey Man,

Here is a screenshot of the settings I now have (and that I will be sticking with):
Image
When I was experimenting with setting that up I found the following:

(1) For the drop-down selector making the Proportional: setting you can choose either Serif or Sans Serif. Whichever of those choices you make that Proportional setting determines whether the specified Serif font or the specified Sans-Serif font will be used for display of messages. So, from the example shown above, I had selected Proportional: Serif. This means that the font that will be used for displaying messages will be Times New Roman. (If I had chosen Proportional: Sans Serif then the font that would be used would be Arial. (Just experiment a bit with it and watch the effects that setting has.)

(2) When making these settings I found that the order I did it in was important. First, make the settings you want to use for Latin - once you have made those settings click the OK button. (This will take you back to the main Formatting tab.) Now click on the Advanced . . . button again and then make the changes you want to the Other Writing Systems settings. Once finished there click the OK button and you go back to the Formatting tab. On that tab just click the OK button and then you can go test if the settings you have made cure the issues you are complaining about.


So 2 is what you are using now - but 1 was what it used to be?

I played around with my Other Writing System and size and things are how I want them now when it comes to Font Size - even with old emails and the reading pane. Your fix seems to work. Although I am sure, I will notice some other glitch later on.

However I never made a separate change for Latin and for Other Writing Styles. Maybe I misunderstood you, but I thought you meant to discard Latin altogether and just focus on Other Writing Styles.

Also I never made any changes regarding Serif or Sans Serif and my Use Other Fonts is still unchecked. Here is how mine is currently.

Image

BuddhaNature

User avatar
 
Posts: 307
Joined: January 3rd, 2008, 9:44 am
Location: Scotland

Post Posted November 11th, 2018, 1:34 pm

Hey Man wrote:So 2 is what you are using now - but 1 was what it used to be?

No, I adjusted the settings for Latin and also for Other Writing Systems too - so the screenshots show the settings I ended up with for each of them. I just found that I had to set Latin first and after that set Other Writing Systems. But I'm just toying around with the settings and trying to see what works. In the end, as you can see my settings for Latin and for Other Writing Systems are just duplicates of each other.

In any case, I'm glad you got a fix that you're happy with too.
OS: Windows 7 Pro. SP1 x64

Hey Man
 
Posts: 50
Joined: December 24th, 2014, 7:09 am

Post Posted November 11th, 2018, 1:48 pm

BuddhaNature wrote:
Hey Man wrote:So 2 is what you are using now - but 1 was what it used to be?

No, I adjusted the settings for Latin and also for Other Writing Systems too - so the screenshots show the settings I ended up with for each of them. I just found that I had to set Latin first and after that set Other Writing Systems. But I'm just toying around with the settings and trying to see what works. In the end, as you can see my settings for Latin and for Other Writing Systems are just duplicates of each other.

In any case, I'm glad you got a fix that you're happy with too.


What happens for you if you don't have Allow Other Fonts checked?

Like I said I hope my problems are over, but I am not 100% confident yet, but I would like to thank you for your help thus far.

BuddhaNature

User avatar
 
Posts: 307
Joined: January 3rd, 2008, 9:44 am
Location: Scotland

Post Posted November 11th, 2018, 1:59 pm

Hey Man wrote:What happens for you if you don't have Allow Other Fonts checked?

I tried both ways and didn't see any difference in any of my emails. So I just set it back to checked which is the default setting in a new install of TB.
OS: Windows 7 Pro. SP1 x64

burris
 
Posts: 54
Joined: May 8th, 2005, 5:13 am

Post Posted November 12th, 2018, 8:54 pm

I had the same problem and solved it by finding TB 60.3.0 64bit...on the release channel.
That allowed the theme font and size changer to work again.
For me, the 32bit version disabled the extension but the 64bit again allowed it.

tanstaafl
Moderator

User avatar
 
Posts: 45244
Joined: July 30th, 2003, 5:06 pm

Post Posted November 13th, 2018, 12:49 am

Bad eyesight - Thunderbird has many suggestions for ways to customize how things look . The theme font and size changer add-on doesn't work with 60.* (though you can install it if you set extensions.strictCompatibility false), but theme font and size changer fixed does.

My impression is that you can use tools -> options -> display -> formatting -> advanced to minimize the impact, but you can't guarantee the exact same font size across all versions since its not designed for that type of backwards compatibility . Bugs in the 21 year old HTML editor also cause problems. When pasting marked up text into the message body and sanitizing it using format commands to remove text styles/font changes etc. it looks like it worked, but when you get a quoted reply you frequently see some of the text still used different fonts/font sizes. You can try to workaround that by using edit -> paste without formatting instead, but that doesn't change the fact that what you see doesn't always reflect what it stores in the message.

Tools -> options -> display -> formatting -> advanced wants you to set separate serif and sans-serif fonts but if you scroll the list box far enough you can select any font. I have both serif and sans-serif set to Verdana for example. I keep "allow messages to use other fonts" unchecked as I've seen it make a difference in messages I get from somebody else. I also set the minimum fontsize.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 10 guests