MozillaZine

Can I turn off Thunderbird autofill with a Registry edit or

User Help for Mozilla Thunderbird
zibby
 
Posts: 3
Joined: November 14th, 2018, 7:41 am

Post Posted November 14th, 2018, 7:43 am

We do not want our users to use autofill with Thunderbird. We want them to have to enter the email address each time. Somehow at least one of our users has autofill turned on on her client. Is there a Registry edit or a GPO I can create and push to all users to ensure that they can't use autofill?

DanRaisch
Moderator

User avatar
 
Posts: 122038
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 14th, 2018, 8:25 am

Thunderbird adds nothing to the Widows Registry except settings for default programs (eg. default email program).

Try menu path Tools->Options->Composition->Addressing->uncheck all of the options under "Address Autocompletion".

tanstaafl
Moderator

User avatar
 
Posts: 45684
Joined: July 30th, 2003, 5:06 pm

Post Posted November 14th, 2018, 8:39 am

I think you meant autocomplete since its for email addresses. You didn't mention why you want to do this. Take a look at the add-ons at the bottom of http://kb.mozillazine.org/Multiple_iden ... il_account such as the flexible identity add-on and see if they might help prevent whatever you're worried about. It "checks the list of recipients before sending a message and displays a warning if the outbound email address or domain does not match your needs." The folder account add-on which "Lets you associate user accounts and identities with specific folders. Great for multiple users who share TB, or for managing mailing lists." is another possibility.

You could create a user.js file in the profile that sets mail.enable_autocomplete false. That will override whatever is changed by the config editor, edits to the prefs.js file or in the GUI, the next time Thunderbird is started. For most users that's enough to discourage them although whatever you do a knowledgeable user can probably bypass.

See http://kb.mozillazine.org/Restricting_u ... hunderbird and http://kb.mozillazine.org/User.js_file

morat
 
Posts: 3381
Joined: February 3rd, 2009, 6:29 pm

Post Posted November 14th, 2018, 8:43 am

Here are the preference names for those options mentioned by DanRaisch.

* Local Address Books

mail.enable_autocomplete

* Directory Server

ldap_2.autoComplete.useDirectory

* Automaticaly add outgoing email addresses to my

mail.collect_email_address_outgoing

zibby
 
Posts: 3
Joined: November 14th, 2018, 7:41 am

Post Posted November 14th, 2018, 8:47 am

I tried editing the pref.js file on my computer. I added mail.enable_autocomplete to false and autocomplete still comes up in my client. I also tried editing it through Config Editor. I still have autocomplete on mine.

DanRaisch
Moderator

User avatar
 
Posts: 122038
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 14th, 2018, 8:51 am

Did you try unchecking the choice of address books under Tools->Options->Composition->Addressing->uncheck all of the options under "Address Autocompletion".

Also, when you tried editing the prefs.js file, did you do it with Thunderbird closed?
Have you tried using the user.js file approach?

zibby
 
Posts: 3
Joined: November 14th, 2018, 7:41 am

Post Posted November 14th, 2018, 8:59 am

Dan,

I need to do this to more than 60 computers. I would prefer not to have to go into every computer and change the settings in the client.
I did edit the pref.js file with Thunderbird closed.
I created a file called users.js, put the following line in it: user_pref("mail.enable_autocomplete", false); and put the file in C:\Users\<My Name>\AppData\Roaming\Thunderbird\Profiles>l6gats70.default but I still have autocomplete in my client.

tanstaafl
Moderator

User avatar
 
Posts: 45684
Joined: July 30th, 2003, 5:06 pm

Post Posted November 14th, 2018, 1:11 pm

I tested on my installation of 60.3 and setting mail.enable_autocomplete false using the config editor and restarting does disable auto-complete.

The file is called user.js, not users.js. Was that a typo? I suggest you start by disabling the setting using the config editor and verify that works as expected. If it does, then reset that setting, exit Thunderbird and try editing user.js again.

Return to Thunderbird Support


Who is online

Users browsing this forum: tanstaafl and 6 guests