MozillaZine

something changed with delete function

User Help for Mozilla Thunderbird
ruggb
 
Posts: 93
Joined: March 27th, 2004, 3:44 am

Post Posted December 5th, 2018, 3:25 pm

something changed with delete function and I don't like it. Previously, when an email was highlighted, either in blue or gray, I could hit delete and it would delete. Now, I must individually click each email before I can delete it. It might be highlighted in blue or gray, but it will not delete until I click it. That is a PITA. Can you put the old functionality back? - or did some setting get changed - I didn't change anything in the last year.

DanRaisch
Moderator

User avatar
 
Posts: 120593
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 5th, 2018, 4:15 pm

I don't understand your reference to messages being highlighted in gray. In the current version of Thunderbird and with the default theme in use, messages that are selected are highlighted in blue. How are you highlighting (selecting) a message so that it show in gray?

Can you put the old functionality back? -

So things are clear here, we didn't take anything out and can't put anything back as we are not Mozilla. This forum is not run by or formally associated with Mozilla. We're an independent user-helping-user community.

ruggb
 
Posts: 93
Joined: March 27th, 2004, 3:44 am

Post Posted December 5th, 2018, 5:27 pm

got it - when I click on an entry it highlights in blue, then when I move pointer off, it turns gray.
At this point I used to be able to hit delete and delete the item. I cannot any more. I must click it again to make it stay blue then it will delete. So it now requires 2 clicks then delete to delete. Once deleted the next item is highlighted in blue then gray. Again I must click it again to delete.

DanRaisch
Moderator

User avatar
 
Posts: 120593
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 6th, 2018, 4:55 am

Check the setting under Tools->Options->Display->Advanced. You might want to set "After displaying for" to 99999 seconds.

ruggb
 
Posts: 93
Joined: March 27th, 2004, 3:44 am

Post Posted December 6th, 2018, 8:30 am

I have that set to 5, so I don't know what setting it to 99999 will buy me as I do not wait even 5 sec after selecting it to delete.
If I select Close message window........... , when I hit delete it will move to the next message highlighting it in blue and I can delete that one, but the next one is highlighted in gray and I must click it to blue to delete.

DanRaisch
Moderator

User avatar
 
Posts: 120593
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 6th, 2018, 11:34 am

Setting it to all 9's will mean it will never be marked as read until it is actually read. The shift you describe, dropping from blue to gray, may be Thunderbird marking the messages as read.

ruggb
 
Posts: 93
Joined: March 27th, 2004, 3:44 am

Post Posted December 6th, 2018, 12:36 pm

It occurs when I click an already read message. If I click an unread message it turns blue and stays that way. I can then delete that one but the next one I must click first.

DanRaisch
Moderator

User avatar
 
Posts: 120593
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 6th, 2018, 1:04 pm

I can't duplicate your experience. Do you have the preview pane open below the message list display?

makaiguy

User avatar
 
Posts: 16672
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted December 6th, 2018, 1:50 pm

The only time I have found when get a message in the message list highlighted in grey is when I return to a folder -- the last selected message during that program session is then highlighted in grey.
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 52.9.0 ESR (64bit), TB 60.3.1 (32-bit) ║ Android 8.0/7.1.1: FF Mobile 63.0.2 No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

tanstaafl
Moderator

User avatar
 
Posts: 44614
Joined: July 30th, 2003, 5:06 pm

Post Posted December 6th, 2018, 2:25 pm

I'm using the default theme in 60.3.2. If I select a message in the folder listing its highlighted in blue. If I move the mouse over another message, it is highlighted in a light blue. However, if I press the delete key the first message (blue) is deleted. That is because hovering a mouse over a message doesn't actually select it. I can second makaiguy's comment about the last selected message in a folder being grey if you return to it again, before exiting.

Deleting seems to work the same way it used to in 52.9.1. I suggest you see if your problem goes away if you use safe mode (help -> restart with add-ons disabled). Your problem might be a side effect of an add-on that isn't working correctly with 60.*.

ruggb
 
Posts: 93
Joined: March 27th, 2004, 3:44 am

Post Posted December 6th, 2018, 4:50 pm

OK, that got it! BUT - I started it in safe mode and all worked. I restarted it normally and everything worked without disabling anything.
Go figure.
Thanks for the tip.

makaiguy

User avatar
 
Posts: 16672
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted December 6th, 2018, 7:35 pm

We have often speculated that when you go back to normal mode from safe mode sometimes the extensions may get loaded in a different order. If your problem was due to an interaction between multiple extensions, this has the potential of changing things.
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 52.9.0 ESR (64bit), TB 60.3.1 (32-bit) ║ Android 8.0/7.1.1: FF Mobile 63.0.2 No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 2 guests