MozillaZine

TB 60.4.0 " "open in conversation" doesnt work

User Help for Mozilla Thunderbird
cinarsoysal

User avatar
 
Posts: 4
Joined: January 8th, 2019, 5:52 am

Post Posted January 8th, 2019, 5:58 am

After updating to 60.4.0 open in conversation stopped working.
ctrl+shift+O doesn't work.
Safe mode start does not work.
My config:
No extension installed
Default theme
windows 10 pro

open in conversation alwasy greyed out.Please see photo

Image

WaltS48

User avatar
 
Posts: 3826
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted January 8th, 2019, 7:59 am

There seems to be several reports of that starting with 60.3.3.

https://groups.google.com/forum/?fromgr ... A8RTJBfsEk

I haven't been able to reproduce the problem with Thunderbird on Windows or Linux.

Try a new profile if it doesn't work in safe mode.

http://kb.mozillazine.org/Profile_Manager
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

morat
 
Posts: 3105
Joined: February 3rd, 2009, 6:29 pm

Post Posted January 8th, 2019, 9:02 am

It works for me.

Thunderbird 60.4.0
Windows 7 SP1 32-bit

I can disable the command by toggling the mailnews.database.global.indexer.enabled preference to false. (default true)

Does the global search feature work correctly?

Global Search
http://support.mozilla.org/en-US/kb/global-search

Troubleshooting for advanced users...

Try selecting a POP3 or IMAP message, then run the following code snippets in the error console.

Tools > Developer Tools > Error Console

Error Console command line
http://developer.mozilla.org/en-US/docs/Tools/Browser_Console#Browser_Console_command_line

Code: Select all
gFolderDisplay.selectedCount == 1;

Code: Select all
gConversationOpener.isSelectedMessageIndexed();

Code: Select all
gConversationOpener.openConversationForMessages(gFolderDisplay.selectedMessages);

The first and second code snippets both have to be equal to true for the command to be enabled. The third code snippet runs the command.

If there is an error after running a code snippet, then post the error in the thread.

Here is the error I receive if I try running the third code snippet with a NEWSGROUP message.

Couldn't find a collection for msg: [xpconnect wrapped nsIMsgDBHdr]

cinarsoysal

User avatar
 
Posts: 4
Joined: January 8th, 2019, 5:52 am

Post Posted January 9th, 2019, 3:17 am

I entered the codes to console here is the ss,What should I do to correct it?

Image

morat
 
Posts: 3105
Joined: February 3rd, 2009, 6:29 pm

Post Posted January 9th, 2019, 6:29 am

Sorry, I can't see a screenshot in the post or in the hizliresim.com page.

Posting a screenshot on the forum
http://kb.mozillazine.org/Posting_a_screenshot_on_the_forum

TinyPic
http://tinypic.com/

cinarsoysal

User avatar
 
Posts: 4
Joined: January 8th, 2019, 5:52 am

Post Posted January 9th, 2019, 7:08 pm

morat wrote:Sorry, I can't see a screenshot in the post or in the hizliresim.com page.

Posting a screenshot on the forum
http://kb.mozillazine.org/Posting_a_screenshot_on_the_forum

TinyPic
http://tinypic.com/


here is the ss
http://tinypic.com/r/ip5grt/9
Image
Image

morat
 
Posts: 3105
Joined: February 3rd, 2009, 6:29 pm

Post Posted January 9th, 2019, 9:21 pm

The selected message isn't indexed. I don't know why. It could be the global indexer is turned off or the global database is corrupted.

Is the mailnews.database.global.indexer.enabled preference set to true in the Config Editor?

i.e. Tools > Options > Advanced > General > [check] Enable Global Search and Indexer

Config Editor
http://support.mozilla.org/en-US/kb/config-editor

If the preference is set to true, then try rebuilding the global database after creating a backup of the profile, then test again.

Rebuilding the Global Database
http://support.mozilla.org/en-US/kb/rebuilding-global-database

Similar thread
http://support.mozilla.org/en-US/questions/1115166

Reference
http://dxr.mozilla.org/comm-esr60/search?q=isSelectedMessageIndexed

cinarsoysal

User avatar
 
Posts: 4
Joined: January 8th, 2019, 5:52 am

Post Posted January 10th, 2019, 7:08 am

morat wrote:The selected message isn't indexed. I don't know why. It could be the global indexer is turned off or the global database is corrupted.

Is the mailnews.database.global.indexer.enabled preference set to true in the Config Editor?

i.e. Tools > Options > Advanced > General > [check] Enable Global Search and Indexer

Config Editor
http://support.mozilla.org/en-US/kb/config-editor

If the preference is set to true, then try rebuilding the global database after creating a backup of the profile, then test again.

Rebuilding the Global Database
http://support.mozilla.org/en-US/kb/rebuilding-global-database

Similar thread
http://support.mozilla.org/en-US/questions/1115166

Reference
http://dxr.mozilla.org/comm-esr60/search?q=isSelectedMessageIndexed



Great,thanks a lot I solved with above solution.

morat
 
Posts: 3105
Joined: February 3rd, 2009, 6:29 pm

Post Posted January 10th, 2019, 9:58 am

You're welcome.

Return to Thunderbird Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 5 guests