MozillaZine

Messages NOT deleted from server...?

User Help for Mozilla Thunderbird
ACFairbanks
 
Posts: 257
Joined: April 23rd, 2011, 5:51 pm

Post Posted January 19th, 2019, 1:43 pm

Hello,

One of our systems runs TB 45.1.0 under Win 10. We run POP on TB.

We periodically get notifications from our Web Hosting Server that the system's mailbox is soon to reach its content limit...

But when I check the TB settings on the system I see that "Leave Messages On Server" is NOT checked, yet, they are apparently being left on the server anyway.

Is there another setting that I am missing?

Sincere thanks,

A.C.

DanRaisch
Moderator

User avatar
 
Posts: 121254
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 19th, 2019, 4:55 pm

Try toggling that setting. Check it to "Leave messages on server" then close and restart Thunderbird and uncheck it. Close and restart again and see if new messages are deleted from the server.

ACFairbanks
 
Posts: 257
Joined: April 23rd, 2011, 5:51 pm

Post Posted January 20th, 2019, 8:49 am

Hi Dan,

I will certainly try your suggestion, but I do have a related question:

With the "Leave Messages On Server" box UnChecked, are messages automatically deleted from the POP server after they go the the TB Inbox?

I ask because (and I am not in the office right now to check these details) the system with the problem belongs to my Assistant, and if I recall correctly, it is set up with a filter that takes new messages, and puts them in a folder called "Unread Messages" (or some such).

That might mean that they never get into the Inbox in the first place. Could that setup be the cause of the failure to delete from the Server?

Thanks, as before,

A.C.

DanRaisch
Moderator

User avatar
 
Posts: 121254
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 20th, 2019, 1:39 pm

With the "Leave Messages On Server" box UnChecked, are messages automatically deleted from the POP server after they go the the TB Inbox?

Normally they would be, unless one of the option switches was checked; either "For at most NN days" or "Until I delete them".

Where is the filter that you referred to located, on the server or in your assistant's Thunderbird installation?

ACFairbanks
 
Posts: 257
Joined: April 23rd, 2011, 5:51 pm

Post Posted January 20th, 2019, 1:59 pm

Hi Dan,

The filter is local, that is, on my Assistant's system. I was about to write that neither of boxes you mentioned was checked, but I decided to actually take a look. To my surprise, there was a check in the duration box, so is displayed as "For at most 14 days." I unchecked that.

But that checkbox is not likely to be the cause of the problem (though it could be a modest contributor) because the system receives a low mail volume, and the server notifies us of impending "overflow" every six months, or so, when it accumulates many thousands of messages.

Thanks for any further thoughts,

A.C.

DanRaisch
Moderator

User avatar
 
Posts: 121254
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 20th, 2019, 2:07 pm

It's possible that the server is not complying with Thunderbird's deletion command but that isn't something reported here often. I'd say to try toggling that setting with the restarts and see if that makes a difference.

ACFairbanks
 
Posts: 257
Joined: April 23rd, 2011, 5:51 pm

Post Posted January 20th, 2019, 2:21 pm

Hi Dan,

I very much appreciate your assistance, and will give it a try when I am next in the office.

All the best,

A.C.

ACFairbanks
 
Posts: 257
Joined: April 23rd, 2011, 5:51 pm

Post Posted January 20th, 2019, 2:46 pm

Hi again Dan,

I tried the toggle, and learned that the problem had nothing to do with TB...

After toggling the setting, I went to the server to see if the huge pile of messages had been deleted, and there I spotted the problem:

Fairly frequently, people send email to us with "creative" addressing. So, suppose my Assistant's address is Assistant@OurDomain.com some folks might send, instead, to FirstNameOfAssistant@OurDomain.com.

Some of those errors are very easily predicted, and so. somewhere along the way, we created an email box on our server for FirstNameOfAssistant@OurDomain.com and set it to forward to Assistant@OurDomain.com. And it is Assistant@OurDomain.com that TB reads. But the mailbox that was overflowing was FirstNameOfAssistant@OurDomain.com.

So, the problem is resolved, and I feel like a dunce...

Thanks for your assistance,

A.C.

DanRaisch
Moderator

User avatar
 
Posts: 121254
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 20th, 2019, 2:49 pm

So, the problem is resolved, and I feel like a dunce...

No need for that. It's one of those "It was a great solution but I'd totally forgotten about it because it was working so well" situations. Thanks for reporting your findings.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 3 guests